Creative SB X-Fi audio card - No Sound via Roon

Hello @support

So far I have only had success in playing roon on my friend’s OPPO-203.

His OPPO-203 showed up in network devices immediately, and so I was able to make that work. Of course, he took his OPPO home now, and I am trying to evaluate Roon on its merit, even though my OPPO-205 will not show up on Roon.

So right now I am running Roon client on Windows 10, 64 bit, and the Core on the Synology NAS. This is a powerful NAS with 8GB of RAM. The core runs fine.

However, for the life of me, I cannot get my PC’s high-end audio card - which I otherwise use all day, every day with foobar2000 to play my music, to be recognized by Roon.

The Play button on Roon is greyed out, and I can’t play music. I am starting to lose hope on Roon.

Please help. This should work like a charm, and I am sure that there is no issue with the network.

BTW, all the devices that Roon recognizes on my PC, when I enable them, show up as greyed out on Roon. :frowning:

Silly question but is there any thing selected to play? if I select a new zone (or a zone that I have cleared the queue on) I just activated the play button is grayed out until I actually try to play a track.
looks like this:

until I select a track to play

1 Like

If your friend’s works, your’s should too. Are you using all the same connections that were setup on the 203? Could be a bad ethernet cable, switch, etc. Maybe the Oppo is the root problem? Is the Oppo setup to work via wifi or wired?

Can you get the 205 to be recognized in your general network outside of Roon? For example, can you update the device via wired, or wi-fi connection? Puzzling for sure. Hang in there, I’m sure you’ll track it down.

1 Like

I had the OPPO 203 & 205 in the exact same set up. All I would do is move the network cable from the one to the other. So it could not be the Ethernet cable.

I saw another topic where Roon turns on debugging on somebody’s account in order to troubleshoot it. It would be nice if @support could do that for me as well.


I see what you are saying. So I cue up several songs. Roon tries to play each one, but gives up within 2 seconds then goes to the next one, then gives up again.

Something is wrong. It should be easier than this.

1 Like

That is weird, let’s wait for support to come in and see what they say.

Do you have the most current version of Roon and Roon app (if you are operating by tablet/phone) uploaded. Since you can now play tracks (for only or second or two), maybe a full reboot of your computer, router, modem, and network would help. Nothing to lose by trying it.

1 Like

Since your friends showed up instantly, that sounds like the issue is with the Oppo. Have you double checked the network setup of the Oppo to make sure it is correct and used the Network Test function in the Oppo’s settings to verify?

Try turning off your firewall – if that doesn’t help, @support can take a look at your diagnostics.

A reboot did the trick. My apologies on behalf of Microsoft. Lately I have noticed, when they want to upgrade your Windows 10, they start making your computer behave weird, and then you go to reboot, and bam, they are upgrading you Windows 10.

This just happened here. So I am passed that hurdle, down to hopefully the last one: Now I have the audio card device being recognized, and no longer greyed out. Now I can play a song, and the zone associated with the audio card is showing animation of music playing.

BUT, alas, no sound comes out of the PC. At the same time, any other music or sound producing application on the PC plays it’s music perfectly: youtube, foobar2000, any of the video players.

Do I have some device setting wrong? Which mixer should I be using?


The network works perfectly, both wired and wireless.

I will try to compare ALL the settings on the 205 vs. the 203. Failing that, the implication is that my brand new oppo 205 is faulty.

That’s one of the first few things I tried, and the fact that the 203 works fine does not support the theory that it’s the firewall.

I hope it is messed up settings.

Afraid I’m a mac guy, but there are lots of PC users on the Roon forum who should be able to help sort this out.

Glad you got the 205 up & running…

Check through the Audio Setup KB page. Enable Exclusive Mode if it is available.

I am down to hopefully the last problem trying to play from the Windows 10 64-bit client. @support, I am looking for your help. I really would like to get an answer that says “this usually happens when X”, as opposed to “tell me your full configuration”.

From my perspective, I tried this exact same Roon Windows 10 64-bit client on 4 other computers, and none of them have any issues. Only the one where I really need this Roon client to run it is not working.

Also, it bothers me that every other application on this computer involving the use of the audio card works flawlessly: Tidal, foobar2000, WinAmp, all the video players, YouTube in a browser. So why is Roon not working?

Right now I am getting the error Transport: Device in Use. At one point it went away, but then it came back for absolutely no reason - I didn’t change anything!

So please, why does this error occur? As far as I can tell, there is no other program on this computer using the audio card. I did try the exclusive mode, without any luck.


Hello @Goran_Janevski,

Could you take some screenshots of your configuration for us so we can do some further troubleshooting? Please provide screenshots of the following pages

  • Settings > Audio (make sure the device in question is visible)
  • Settings > Audio > Device Setup (for the device in question) > Playback (Make sure Exclusive mode is on)

Are you able to play to the “System Output” zone listed in Roon for this computer?


No. I tried every zone and this will not play.

I will send you screenshots of the only zone that worked.

Hi @Goran_Janevski ---- Thank you for the continued feedback and more importantly, thank you for your patience here.

Continuing forward, in order to ensure you get the help you need I think there is some information in regard to the mentioned Win10 device that still needs to be clarified so we can properly advise on this issue you are experiencing. Please see below.

  1. Please verify the make and model of the “high-end audio card” you are referencing in your post that is now being recognized by Roon but during playback is producing no sound . It’s not the “Creative SB X-Fi” mentioned in your latest, is it?

  2. This maybe a silly question but do you have any other applications running that may be trying to take hold of the mentioned sound card while Roon is active?

  3. You are certain that the the Win10 computer has no active firewalls or antivirus applications running it that could be affecting playback in Roon?

  4. As asked in @john’s previous, please provide a screenshot of the “audio” tab in Roon on the Win10 device so we can see all of the available audio zones.