Crestron Module not communicating with Roon Nucleus

We just installed a Nucleus server in our showroom. We have both Crestron and Control4 on display throughout our showroom within many various systems. Can we control the ROON Nucleus Server using the provided Drivers/Modules simultaneously? The idea is to Show from both Crestron and Control4 GUI’s the ROON in use by a control system.


Hi @Jorge_Castro ---- Thank you for the post!

In regard to your question, yes, you should be able to control Nucleus using the provided drivers/modules.


Eric, I’ve just tried to Add Crestron Control of the Nucleus. But, we currently already have the Control4 driver integrated and working. The Crestron EXTENSION isn’t populating. I’m I missing something. We want to have both control systems working simultaneously.


Hi @Jorge_Castro ---- Thank you for the follow up and sharing your latest observation with me. Very appreciated!

I touched base with our tech team members today regarding your most recent post and as per the conversation the team has requested the following information:

  1. Please provide exact details into how you are trying to setup the Crestron integration with Roon. The more information you can provide us, the better.

  2. What is the exact symptom you are seeing?

Additionally, I would like to enable diagnostics on the account linked to the Nucleus server, so our techs can have a closer look into the this behavior for you. However, I will need the email address tied to the account in which Nucleus was setup under. If you could send me a PM with this information I will take care of this asap.


The store showroom has many different Media Players (SONOS, BlueSound, Play-Fi/Airplay, C4 ShareBridge) to include a BlueSound Vault and Sony HAP-Z1ES. We have a Roon Nucleus installed on a Anthem Pre-Amp using USB. I’ve setup the Roon Nucleus (Core) with Music files from both the Vault and Sony. We’ve confirmed and tested the Roon working with many of our players throughout the showroom. Yesterday we Loaded the Roon Control4 Driver into the sound room (Nucleus location). Tested and confirmed that was working. The Roon settings show the Conrol4 Extension connected. Today, I’ve loaded the Crestron Module on to the Pro3 system we are using and again, have the room module setup to the Soundroom. The Extension menu showed the Crestron enable button. I clicked and setup the settings to link to the Nucleus “room”. Once that was done, the Crestron extension disappeared. And the Crestron system SHOWS ready fb (high) but, No data is flowing the Roon Room module.

Here are extension pages:

Here are the players:

Hi @Jorge_Castro ----- Thank you for the follow up! Confirming that I have received your PM and have enabled the mentioned diagnostics. What this action will do is the next time Nucleus is up and running a diagnostics report containing a set of your Roon logs will be automatically generated/uploaded to our servers. I will be sure to confirm when it has been received so you know we have it.

Furthermore, thank you for providing the requested feedback regarding how you are trying to setup Crestron with Nucleus, the insight is appreciated! I will be adding this information to your ticket and attaching the mentioned diagnostics report, once it has been received for review by our tech team. Once your ticket has been updated and passed back, I will be sure to share the team’s thoughts/findings with you ASAP.


UPDATE: Looks like the diagnostics report has reached our servers.

Extension showed back up. but, I now have 2? Still not working though?

Hi @Jorge_Castro ---- Thank you for touching base with me, very appreciated!

Upon seeing your latest, I checked the status of your ticket and can see that is still in our tech team’s queue. I have placed a feedback request with the team to try and expedite this process to the best of my abilities.

In the meantime, while this may seem elementary, have you tried removing the additional extension in Roon?


Yes, Steve and I had a Video Conference this morning. We attempted to remove the 2nd Crestron. The Nucleus was having some weird issue with our media files. So, (per his suggestion) I set the Nucleus to a static IP and rebooted the unit. Now, I only have 1 and 1 Extension authorized but, neither the Control4 nor the Crestron show a connected extension.

Steve said he was going to ask support and get back to me. That was this morning.


Hi @Jorge_Castro —— Thank you for the continued feedback but more importantly, thank you for your patience here while I have been discussing this issue you’ve reported with the team.

Continuing forward, I am going to be breaking this response down into two sections, one to address the Control 4 extension and the other to address the Crestron extension. Kindly see below.


The tech team has a theory that the C4 extension settings were not updated when the Nucleus’s IP address was changed. The C4 extension will not do automatic discovery of any sort and as such the IP address of the Nucleus must be typed into the settings screen in the C4 director software.

Our techs have recommended visiting the Crestron user guide and using the information found in “section 3” to reconfigure the C4 module. If you have any more issues, just let us know, and we will be glad to help

According to the team’s analysis of the logs we received attached to the mentioned diagnostics report we can see the extension appearing to connect and appearing to function normally. However, after a short amount of time (approx 15minutes) we can see it disconnect and unfortunately the log traces are not pointing to anything conclusive as to why this is happening. In light of this observation I will be sending you a PM to discuss further.


Hi @Jorge_Castro ----- Just wanted to follow up as I haven’t heard back from you in a few days concerning the above.



Sorry for the delay in response. I’ve been out finalizing projects and haven’t had time to work on the Roon/Crestron testing. I can say, that we still don’t have a communication link between the Crestron and the nucleus. I’ve already updated the ROON OS recently (possibly the same day it was released). I can schedule for Monday or Tuesday (June 21-22, 2018) to have working conference call with you and your Crestron Expert to try to resolve this.

Hello @Jorge_Castro,

I just want to follow up with you here, my name is Noris and among a few other responsibilities, I handle Crestron Support for Roon.

Before we proceed, I want to direct you to our newly updated Crestron Modules here. I ask before you try anything else to please first update the code on your processor and review the user manual since we have made some significant improvements since the last release. We are always working to improve our products so please also be on the lookout for additional updates to the Crestron module, which will be located at that link.

We generally do all of our support here on the Community Site, where our sales team, dev team, and product management staff have visibility and can weigh in as needed. We’ve found that in the vast majority of cases phone support is not needed, but let me know how things are going with the updated module and documentation and we’ll make sure we get this resolved for you whatever it takes!


So, I’m just now getting a chance to update the Crestron Modules in my programming for the store from 1.5 to 1.6. I removed all digitals/analogs/serials (NON-CRPC$) from the Device module. I followed the Archived programming. I’ve attached the ROON module to the Same Media Player Router that I use to control my other SG Media Player devices in the system (SONOS). My test Tablet (iPadMini4thGen) shows the MediaPlayer SG loaded with a ROON logo in the top left corner of my subpage. I get a Blank Disc icon in the Cover Art (Current) location. All other fields are blank. I still see a Busy spinning icon in the top right (List top line) field. It doesn’t go away. Debugger shows the following info on the CRPC and CPRC FB strings:

Roon_CRPC -> 209c00dc{“params”:{“format”:“JSON”,“type”:“symbol/json-rpc”,“ver”:“1.0”,“encoding”:“UTF-8”,“maxPacketSize”:65535,“uuid”:“773FCB47-85A0-1995-E184-A20BD71581AD”,“name”:“Smart Graphics=”},“id”:14354,“method”:"Crpc.

Roon_CRPC -> 209e001aRegister",“jsonrpc”:“2.0”}

Roon_CRPC_fb -> 209c00c0{“jsonrpc”:“2.0”,“result”:{“ver”:“1.0”,“name”:“CRPC Service1”,“uuid”:“f3121109-4276-48c1-aad9-bd392913535d”,“connections”:{“symbol/json-rpc”:{“ip”:“”,“port”:“0”},“cip-direct/json-rpc”:{

Roon_CRPC_fb -> 209e0077"ip":“”,“port”:“41800”}},“maxPacketSize”:65536,“encoding”:“UTF-8”,“format”:“JSON”},“error”:null,“id”:14354}

Roon_CRPC -> 209e0045{“params”:null,“id”:14355,“method”:“Crpc.GetObjects”,“jsonrpc”:“2.0”}

Roon_CRPC_fb -> 209c00c0{“jsonrpc”:“2.0”,“result”:{“objects”:{“object”:[{"@category":[“Media Player”,“Residential”],“name”:“RoonMediaPlayer”,“instanceName”:“roonmedia:0”,“interfaces”:[“IMediaPlayer”],“uuid”:"03528f74

Roon_CRPC_fb -> 209e003a-cfd4-4573-a44d-ddf7cecf39a5"}]}},“error”:null,“id”:14355}

Roon_CRPC -> 209e0071{“params”:{“handle”:“sg”,“ev”:“ObjectDirectoryChanged”},“id”:14356,“method”:“Crpc.RegisterEvent”,“jsonrpc”:“2.0”}

Roon_CRPC_fb -> 209e0035{“jsonrpc”:“2.0”,“result”:{},“error”:null,“id”:14356}

Note: We have Control4 and Crestron on our one network. We also have both automation systems trying to control the same Nuclues player (USB to PreAmp) to McIntosh

I would like some help getting this resolved.


Hello @Jorge_Castro,

Thanks for bringing this to behavior our attention, this does indeed seem strange and we will be looking into this issue further and having our QA team try to reproduce this. Can you please confirm the following for me:

  • Have you restarted your Roon Core after uploading the new module? You will need to perform a complete reset of the Roon Core for the module to be able to properly communicate.
  • Is your selected zone powered on before attempting to access it?
  • Have you followed the steps listed under the User Guide and enabled the Crestron extension in settings and set destination audio zones?
  • Since you are using the archived version here, have you compiled it in SIMPL before uploading?
  • What email address is associated with your Nucleus? If it is different than the one you use to log into the community site, can you please PM it to me?

I have gone ahead and enabled diagnostics mode for this account and if the Nucleus you have is associated with your current account, a set of logs will automatically be generated and uploaded to our servers for further analysis. While we have a chance to analyze those logs, can you please let me know your reply to the above questions?


As requested, I power cycled the Nucleus this morning. I waited about 5 minutes and attempted to visit the settings to confirm that the Crestron Room is listed but, it came out blank.

strong text
Here is the next another view:

Yes the zone is powered on.
I opened up Simpl and brought in the two modules in the USER database. Then, made similar connections in my programming for the source in use:

I’ll send you a PM with my account.


Hello @Jorge_Castro,

Thanks for answering those questions and providing the email address by PM. Can you please confirm that you have added the following files to your root SIMPL project folder before compiling:

  • devicemodule.ush
  • devicemodule.usp
  • RoonSystem.clz
  • systemmodule.ush
  • systemmodule.usp

Roon will require these files in the project directory to work properly, if any of them are missing at the time of compile, it will not work. After confirming that those files are there, I would also try restarting the Roon Remote application you are using, if the destination is still not showing up under “Extension Settings” (1st screenshot) then you can go ahead ahead and remove the Crestron Extension Authorization (2nd screenshot), restart the Nucleus & Roon Remote and re-pair with the discovered Roon extensions. Please let me know if those steps help solve the issue at hand.


Yes, I have confirmed that those files are indeed listed in the folder of my project.

Could you explain what you mean by “re-pair” with discovered Roon Extensions. What process is that?


So, I’ve removed the Crestron authorization as requested. I power cycled the Nucleus. Then I had two Crestron extension listed.

I enabled (re-pair I guess) the first one. Then, I clicked settings. It showed all the players in the system. I could not find the USB output. HDMI was listed but, is not what I should be controlling. I then enabled the second Crestron Extension. I Clicked settings and I got nothing listed. So, I went back to the first extension. Still no USB listed. I then turned on the McIntosh Preamp and now, the USB is listed. So I selected it. Then, I opened up the Crestron App and looked at the Smart Graphics. Same as before but, now without a spinning icon.

Now what?