Currently stumped with playback on Android with Chord Mojo DAC

@support I need to enlist your help with this please. I’ve been trying to resolve the issue I’m having for a while now and I’m not getting further.

Symptoms are stuttering / clicking while playing back using my Samsung Galaxy S5 as endpoint with Chord Mojo DAC connected via OTG cable.

My Roon Server (64 Bit) sits on my Windows 10 HP ProBook Laptop (Intel i5 / 8Gb RAM) on a directly connected USB HDD. I’m pretty sure the issue doesn’t lie with this part of my setup, since I can playback using the server with the Chord Mojo directly attached without any issues.

My 1st choice would have been to use my Apple iPad Air 2 as end point with the Chord Mojo, but I’m not holding my breath anymore, so I now had to start looking at various Android devices in the household (some newer than my Galaxy S5) and I’m just not able to get the playback working on any of these endpoints without the stuttering / clicking. Both the Server and Endpoints are connected via WiFi and I have tested with and without other traffic on the home network.

I have enabled Jumbo Packets on the Laptop and had a look at enabling Flow Control on my Netgear N300 Router, but I can’t find a way to do this and am currently assuming it can’t be done on this Router. I have been using this Router for many years streaming the whole household Netflix, Internet, etc without any issues, so even though I know it is old I am not terribly suspicious of the device either.

I’m totally stumped and basically at the end of my expertise - I need help please! I know it is a big ask though, since there could be such a magnitude of variables involved here. But I can’t honestly believe that this is not working - it isn’t rocket science. Thanks in advance to anybody willing to assist me!

Enabling jumbo packet and flow control is the last thing you want to do.
Read here for more details:

Looks like a network problem and hopefully this can help.

Well, Flow Control isn’t enabled, since I couldn’t find out how to do it on my Router and Jumbo Packets actually seemed to make a minute improvement. Additionally I have also tried switching Windows Firewall off, but this didn’t make a difference. I have been looking in the Roon threads in order to gain some further insight. I’ll have a look at what you sent in the post above here as well.

Are you playing 16/44 PCM to the Android/Mojo endpoint or trying up-sampled music to DSD256 to the Mojo?

Does playback stutter with 16/44 PCM music (and all Roon DSP turned off)?

Hi @Emil_Saayman ----- Thank you for the report and sharing your feedback with us. Both are very appreciated!

Moving forward, may I kindly ask you to please provide/verify the following for me:

  1. Screenshots of:
  • The device settings you are using for the Chord Mojo in Roon.

  • The signal path coming out of Roon when you are noticing the stuttering/clicking sound.

  1. Based on your report I understand that the Chord is not having an issue when it is directly connected to the Win10 laptop hosting Roon. During your troubleshooting have you:
  • Tried with another DAC mounted to the Samsung Galaxy S5? If so, what was the experience like?

  • If you playback audio content through the internal speakers on the S5, is it uninterrupted (ie no stuttering / clicks)?

  1. Lastly, and this may seem very elementary, but have you tried swapping out the OTG connecting cable for a different one?


Thanks Eric for your reply and questions. I\m sorry I haven’t been able to get back to you yet.

I will have a look what I can do to send you the info you requested.

I have tried two different OTG cables though to answer that question and the result is the same.


1 Like