DAC stuck on "Enabling"

Core Machine (Operating system/System info/Roon build number)

Windows 10
Roon 1.7 (build 500) stable
The core is running on the machine I’m trying to listen my music on (no Roon Server).

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

After installing Roon, I tried to enable my DAC in my audio devices, but after clicking “Enable” it got stuck on “Enabling” and never finished. After that, every time I opened Roon it would still be stuck on “Enabling”. Sometime the section “This PC” on the audio device list would disappear and clicking on the refresh icon would just show a “Refreshing” popup that would never end.
I can enable my Google Home or my on-board soundcard (Realtek) but my DAC doesn’t enable.

I was able to find a temporary fix:
Open Roon and disable all audio devices.
Restart Roon (now there is no enabled audio device)
Enable my Realtek ASIO device (onboard soundcard). It gets enabled without a problem.
Enable my RME ADI-2 DAC device. It gets enabled without a problem.

Now it enables my DAC and everything is working just fine. So it seems that enabling my on-board sound card lets me enable my DAC. But then if I close Roon, the next time I open it, it still get stuck on “Enabling” for my devices (I guess it’s trying to enable my DAC first), so I have to repeat all the previous step to get it working.

I tried changing my DAC usb cable or change the usb port it’s connected to, but it still doesn’t work.

Hi @Oloko,

If you temporarily disable any firewall or antivirus running on this machine is there any change in behavior?

Hi @dylan,

I tried disabling the firewall/antivirus and it still doesn’t work.

Thanks for the reply.

I had a similar problem a year ago with a different product. Digging through my product manual I was able to find a recent USB driver which solved my problem.

RME has some updated USB firmware that was released a month ago. Have you looked at their support site and made sure you’re running the latest & greatest software? Doing so may not solve your problem but at least that would eliminate it as a possibility if it doesn’t. It couldn’t hurt & it might help.


I clicked on Windows then USB to find it.

That’s a good point, I did update my RME windows USB drivers to the latest and also updated the DAC firmware to the latest version. It did not fix the issue.

Hi @Oloko,

In the past there have been reports of Realtek Audio drivers causing issues with Roon. If you are not using this sound card, is there any change if you uninstall the Realtek drivers? See this thread for more info:

1 Like

Thank you @noris! That solved it!
I’m not using my on-board card sound right now so uninstalling it is fine.

Now Roon can use my DAC without any issue.

1 Like

Happy to help @Oloko!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.