'No audio devices found' issues [Resolved - Realtek driver]

Hi @support,

Like some others, I am having some issues with intermittent (but frequent) ‘no devices found’.

Version 1.3 (build 259) 64-bit
Windows 10 Home
Alienware 13 R3 laptop, i7-7700HQ, 16GB
Audioquest Dragonfly Red via USB
Music stored locally (only a few dozen tracks) on 512GB SSD or Tidal streaming

On most occasions Roon will show ‘no devices found’, this is the case regardless of whether the device is plugged in at startup, plugged in before loading Roon, or after loading Roon. Under audio settings, it seems to pick up the device for a split second on each occasion it is hot-plugged, but then it disappears immediately. A reset resolves the issue around 50% of the time. The issue appears isolated to Roon. Tidal running in either exclusive or non-exclusive mode works fine.

The issue exists with both the Dragonfly and default (Realtek) souces.

Hi @Chris_Jermyn ----- Thank you for the report and sharing your feedback with us.

Based on the symptoms you are describing, I believe this could be related to the Realtek driver(s) as I have seen similar issues in the passed caused by these drivers. I’d like to have you verify this for me by temporarily disabling the Realtek driver(s) and see if this triggers a change in behavior here.

Note: The last time I came across this behavior the user had to actually uninstall the driver completely to identify the issue, should disabling not yield a positive result I figured I mention what the “resolve” was previously.


Thanks for the quick reply, @Eric. No change disabling the driver, both before and after a reset.

Before the reset, I got:


I only get (or my eyes are only good enough to see) that first ‘enabling’ screen on initial Roon startup - subsequent hot-plugs are gone in a split second. This is as it was before disabling the driver.

Upon reset with the Realtek remaining disabled and the Dragonfly not plugged in, I got ‘select an audio zone’, which I don’t think I’ve seen before, but I realised the system picked up my Momentum 2.0 Wireless over Bluetooth, which Roon then defaulted to and worked okay. Upon close and restart of Roon, that doesn’t work either - I’m back to ‘no audio devices found’ and ‘manage audio devices’.

Audio drivers are:

I’ll try an uninstall of the Realtek drivers in the morning.

Just tried disabling the Nvidia device and Intel Display Audio, which don’t help either.

Hi @Chris_Jermyn ---- Thank you for the follow up and the feedback. I appreciate you sharing your observations with me.

Moving forward, please let what you observer after the uninstall and if things do not stabalize I would recommend the following:

New RAATServer folder:

  • Make sure the application is not running on the laptop (core) or any remote devices. All instances of the application should be inactive.

  • Restore your system back to it’s “normal sate” as it was at the time you reported this behavior (i.e usual drivers installed/active).

  • Navigate to the directory in which your Roon Database is located and re-name your “RAATSerer” folder to: RAATServer_Old

  • Launch the application and confirm if you make the same observations (i.e no audio devices found).

If the above fails, then it’s time to look at your logs :microscope:

Hi @Eric, I think we’re good.

I removed the driver, although it reappeared on reboot - the first time I booted Roon on startup, default audio appeared correctly, as did the Dragonfly when I plugged it in. However, closing Roon and restarting it presented the same problem as before.

I then tried an uninstall plus ‘delete the driver software for this device’. That reverted the default audio to the (I think Windows generic?) High Definition Audio driver, during which everything seemed to be working perfectly. A few minutes later, Realtek re-appeared in the driver list and the system wanted to reset. I assumed I’d be looking for a way to permanently remove the Realtek driver at this point (and stop it reinstalling), however it seems to be behaving fine since reinstalling itself. Have cycled the system and Roon a few times and haven’t been able to trip it up.

Thanks heaps for your help!

1 Like

Awesome, glad to hear @Chris_Jermyn!

Just a head ups, I will be closing this thread and marking it as “resolved”. Should this behavior pop up again, just drop me a PM and I will re-open to continue troubleshooting with you. Many thanks!

Happy listening!

1 Like