USB Headset (with Realtek HD) not working

We did that to and the behavior is the same; no difference. Nothing will play through the headset.

Hi @Gary_Cardinale ----- Thank you for your continued feedback and more importantly, thank you for your patience. Both are very appreciated.

Moving forward, this feels like a driver issue to me and in light of this I have enabled diagnostics on your account so we can have a closer look into this behavior. If I may very kindly ask you to please reproduce the following “failures” and note the times when the observations are made:

  • "We originally used the headset driver but when we do, Roon does not play any music, it just skips from one song to the next, never playing any of them. So that is when we tried the Realtek audio "
  • “So that is when we tried the Realtek audio which does not work at all.”

Furthermore, just to confirm (re-confirm), no issues when using the G35s with other applications and when the G35s are unmounted, no issue using the “system output”, correct?

-Eric

@support

We went ahead and did this. Here are the times…

12:40 PM G35
12:41 PM PC System Output
12:42 Realtek

Thanks, Gary

@support Your last question was if there were any issues with the headset with any other applications and the answer is no. Gary

Hi @Gary_Cardinale ----- Thanks for the follow up and providing me with the requested timestamps. Very appreciated!

Moving forward, I just checked our servers and it looks like the diagnostics report didn’t make it over to us. In light of this, I have flipped diagnostics “off and on again” on your account to reinitialize the transfer.

I will continue to monitor our servers for the upload and once it reaches us I will be sure to confirm with you that we have it.

-Eric

@support
OK. We did it again and here are the times from today:

1:51 pm Realtek
1:52 pm G35
1:53 pm PC System Output

Gary

Thanks for that, @Gary_Cardinale! Looks like we got what we needed :thumbsup:

I will let you know what the team comes up with, your continued patience is very appreciated!

-Eric

Hi @Gary_Cardinale — Thank you for your patience while our techs have been evaluating the information in the received diagnostics report.

According to the the team’s update, based on the traces found in your logs, the issue appears to be related to the driver(s) on the mentioned remote device (i.e “my son’s PC”). I have seen some instances in the past where the RealTek driver has caused playback problems (example #1, example #2, example #3).

Moving forward, can you please try disabling the RealTek driver on the remote PC and confirm if this action triggers a change in behavior here? You may need to also test with the driver fully uninstalled, but let’s start by disabling it first and see where we land.

Looking forward to your feedback!
-Eric

@support
Eric, We disabled the driver and there is no change in behavior. Gary

Hi @Gary_Cardinale ----- Thank you for touching base with me and sharing the results of the proposed test.

Moving forward, I know @Rugby had asked about any potential firewall settings or active antivirus applications running on the remote PC early on and you had mentioned that the audio devices were recognized by the machine. It is important to note that an active security setting could very well indeed disrupt the ability play content via the application despite the fact that the headphones are appearing in the “audio” tab.

Rugby: “Also, does Roon recognize any endpoint on the remote PC, like the Realtek Audio? If not, then the issue might be anti-virus or firewall running on the remote computer is blocking the Roon Server from discovering audio devices on the remote machine.”

You: “Audio devices are recognized on this machine.”

Before we try completely uninstalling the RealTek driver, can you please confirm that the remote PC does not have any active firewalls on it.

-Eric

@support
We have Bitdefender installed and it has a firewall. I am not going to operate a computer without a firewall. Do you just want this temporarily disabled? Gary

1 Like

Speaking for Eric I know, but yes this would be temporary, just a quick test to help track down where the problem lies

1 Like

Thanks @Carl!

Yes @Gary_Cardinale, please disable these functions temporarily to verify if there are any changes in behavior with the G35s :thumbsup:

-Eric

@support
We disabled the firewall and the result is no different. Gary Cardinale

Thank you @Gary_Cardinale for sharing your observations with us after having performed the proposed test. The update and feedback are both very appreciated!

Moving forward, may I kindly ask you to please completely remove the RealTek driver from the mentioned laptop and confirm if this action triggers a change in behavior with the G35s.

-Eric

@support
We removed the RealTek driver from the computer and it did not change the behaviour of the headset. Still no sound through the headset. Gary

Thanks for getting back to me @Gary_Cardinale, the update is appreciated!

Doing a bit more research into the G35s after having read your latest and I see that the head set can be used for multichannel playback. When the device is being used with Roon is it set to receive stereo or multichannel? If it is the latter, I would recommend configuring the headset to receive stereo content and verify if this action triggers a change in behavior.

-Eric

@support
Well we tried that also to no avail. Still no output.

Thanks for the update @Gary_Cardinale.

I am going to re-enable diagnostics on your account, so the next time that Roon is launched on your core machine and the remote device with the G35s, I can attach an up to date diagnostics report (i.e v1.4 b294) to your ticket for the tech team to evaluate. I will be sure to follow up with once it has been received.

All the best to you and your family this holiday season!
-Eric

A post was split to a new topic: Issue with Logitech G935 headset