USB Headset (with Realtek HD) not working


We have set up a Roon Core on one PC and have numerous zones. One zone is my son’s PC and he has some Logitech USB headsets. We cannot get the headsets to work with Roon. We have configured his PC using Realtek High Definition Audio which is what comes on the Asus Z170 motherboard.

Have we missed the setup parameters somehow? Any help is appreciated. Gary

Moving this to the support thread. adding @support.

Ok. Thanks.

USB headsets do not use the on motherboard audio chips, like the Realtek. The OS should load drivers for the headset and it should show up as a separate option other than the realtek audio. What is the model number of your headset.

Also, does Roon recognize any endpoint on the remote PC, like the Realtek Audio? If not, then the issue might be anti-virus or firewall running on the remote computer is blocking the Roon Server from discovering audio devices on the remote machine.

Just broke out my USB headset to see what happens,

With my Sennheiser USB headset in Windows 10 they automatically set themselves as the default output, but you can select them manually if needed.

In ROON, Settings-Audio, under the “connected to this PC” section I select the “System Output” Zone or in my case the “Sennheiser USB headset zone” either zone works for me and my headset.
Just need to remember to "enable the zone for the headset.

Audio devices are recognized on this machine. The model number of his headset is Logitech G35. We originally used the headset driver but when we do, Roon does not play any music, it just skips from one song to the next, never playing any of them. So that is when we tried the Realtek audio which does not work at all. Not sure why it just skips from song to song and does not allow playback with the headset driver.

We did this and all we get when using the Logitech driver is the Roon system skipping from song to song and never allowing us to actually play a song. The Logitech driver works with all other programs that are used on that computer, just not Roon. Very strange behavior.

Hey @Gary_Cardinale – can you drop us some screenshots of the audio configuration for this zone?

Will get this to you on Tuesday since my son has his computer locked and is at school all day. Thanks.

Here are some screen shots. If he goes to an album and tries to play it, the system will look at each track and when it cannot play it, it will go to the next track and all the way like that to the end of the album. Thanks for reviewing.

Mike- I sent you screen shots several days ago and had not heard back… Any advice? Gary

In your screen shots, you have the output set to PC System Output which would not be the headset. The output should be set to G35.

We did that to and the behavior is the same; no difference. Nothing will play through the headset.

Hi @Gary_Cardinale ----- Thank you for your continued feedback and more importantly, thank you for your patience. Both are very appreciated.

Moving forward, this feels like a driver issue to me and in light of this I have enabled diagnostics on your account so we can have a closer look into this behavior. If I may very kindly ask you to please reproduce the following “failures” and note the times when the observations are made:

  • "We originally used the headset driver but when we do, Roon does not play any music, it just skips from one song to the next, never playing any of them. So that is when we tried the Realtek audio "
  • “So that is when we tried the Realtek audio which does not work at all.”

Furthermore, just to confirm (re-confirm), no issues when using the G35s with other applications and when the G35s are unmounted, no issue using the “system output”, correct?



We went ahead and did this. Here are the times…

12:40 PM G35
12:41 PM PC System Output
12:42 Realtek

Thanks, Gary

@support Your last question was if there were any issues with the headset with any other applications and the answer is no. Gary

Hi @Gary_Cardinale ----- Thanks for the follow up and providing me with the requested timestamps. Very appreciated!

Moving forward, I just checked our servers and it looks like the diagnostics report didn’t make it over to us. In light of this, I have flipped diagnostics “off and on again” on your account to reinitialize the transfer.

I will continue to monitor our servers for the upload and once it reaches us I will be sure to confirm with you that we have it.


OK. We did it again and here are the times from today:

1:51 pm Realtek
1:52 pm G35
1:53 pm PC System Output


Thanks for that, @Gary_Cardinale! Looks like we got what we needed :thumbsup:

I will let you know what the team comes up with, your continued patience is very appreciated!


Hi @Gary_Cardinale — Thank you for your patience while our techs have been evaluating the information in the received diagnostics report.

According to the the team’s update, based on the traces found in your logs, the issue appears to be related to the driver(s) on the mentioned remote device (i.e “my son’s PC”). I have seen some instances in the past where the RealTek driver has caused playback problems (example #1, example #2, example #3).

Moving forward, can you please try disabling the RealTek driver on the remote PC and confirm if this action triggers a change in behavior here? You may need to also test with the driver fully uninstalled, but let’s start by disabling it first and see where we land.

Looking forward to your feedback!