Music Sources Disappear in Roon After Startup [Resolved - Realtek driver]


I have recently started to have an issue where everytime I try to open Roon all my audio sources and devices disappear. I am unable to see my Dragonfly Red even though I can still see it in the Windows sound settings and the Tidal Desktop App. Within the Roon app, I use my Dragonfly Red Dac with my Audeze iSine10 earphones. I have my Tidal HiFi account linked.

I have read some of the other support conversations and have tried many different options. I have tried to reinstall and update Roon. I have tried to disable the Windows Firewall, but there was no difference. I have tried to restart the computer, but no difference.

The only temporary solution I have been able to find is restarting Windows in safe mode by disabling the driver signature enforcement. However, whenever I turn off the computer, this option is no longer an option. I have been trying to find a another solution since this does not always work, only sometimes.

My computer is running Windows 10 64 bit. The specs of my computer are an i7-7700HQ, GTX 1060. The laptop is an Alienware 13 R3. My DAC is the Dragonfly Red, which has been updated to the latest firmware. My headphones are the Audeze iSine10 running the Audeze sound profile in Roon.

I have uploaded screenshots of when I open Roon and what happens after a few seconds of the application running.

Thanks in advance for your help. I looking forward to hearing from you soon.


Hi @Ashton_Holderness ---- Thank you for the report and sharing your feedback with us, the insight is appreciated!

Moving forward, I understand that you have tried disabling the Windows firewalls (:thumbsup:) but can you also confirm that you are not making use of any antivirus applications as well? If you are I would recommend disabling that function also.

Lastly, I have seen some instances (example #1 and example #2) where the Realtek audio driver has caused this behavior for others. Can you try to uninstall and let me know if you see a change in behavior?


Hi Eric,

Thank you for responding. When I uninstalled the Realtek audio drivers, the issue went away.

Thank you for all of your help.


1 Like