Unable to play track "Nothing Playing" message with Dragonfly Red DAC

Core Machine (Operating system/System info/Roon build number)
Roon v1.7 build 511 stable 64 bit")
Sony Laptop (Windows 8.1 64 bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Audioquest Dragonfly Red USB DAC.

Description Of Issue

I recently loaded Roon on my Sony music server currently running iTunes (ver

My music files are stored on the laptop’s internal hard drive in Apple Lossless .m4a files. Running iTunes everything works fine. I want to try Roon software for a possible upgrade.

With the Roon software and the Dragonfly selected as the output device tracks will not play. The message “Nothing Playing” is display in the bottom field of the sofware. When the first track in an album is selected, all of the tracks in the album quickly load into the queue, but than the queue empties and nothing plays.

If I switch to the Sony internal RealTeK High Definition Audio output device music tracks will play and I can hear the audio through the internal Laptop speakers.

The Sony Laptop is on a wireless network but this is not the issue. Even with the wireless off, music files should play on the laptop (but do not) as a stand alone device.

Any suggestions would be appreciated as I would like to evaluate the Roon software for my music server. If necessary I can send some screen shots.


Hi @Russell_Jung,

Can you provide some additional details for your Core machine?

Can you share a screenshot of Device Setup for the Dragonfly DAC?

Here are three screenshots for the setup.

Hi @Russell_Jung,

Is the behavior the same if you reboot your Core machine and unplug + plug in the Dragonfly again? Can you confirm you have the latest firmware version installed on the Dragonfly Red? You can use the AudioQuest Manager to confirm this.

Hi, Yes the problem still exists. I powered down the laptop, unplugged the USB DAC, rebooted and than plugged the USB Dragonfly back in the the problem still exists. Attached is a screenshot of the Audioquest Manager.

Hi @Russell_Jung,

Thanks for confirming you have the latest Dragonfly firmware.

Just to check, when you are trying to use Roon, the iTunes application is not open, correct? I am wondering if iTunes is using Exclusive Mode and is taking control of the Dragonfly, preventing Roon from using it.

I would quit out of all your background applications, reboot the Core and only open Roon to test the Dragonfly, can you give that a try?


I tried what you suggested but that did not work and I only run one music application at a time.

I also tried installing Roon on a different computer running Windows 10 ( it also has iTunes installed on it) and with the Audioquest Dragonfly DAC plugged into a USB port. The installation was simple and flawless and music tracks played with the Dragonfly selected as the DAC. No problems at all with the same music database stored on that computer.

I than tried uninstalling Roon on the Sony laptop (with Window 8.1) and reinstalling the application as a fresh install. The first time I selected a track to play, it played for several seconds before stopping and displaying the “Nothing Playing” message. After that, each time I selected a track it did not play at all. Obviously some setting is blocking tracks from playing in Windows 8.1.

Do other users have problems with Window 8.1?

Hi @Russell_Jung,

I wonder if the RealTek drivers are causing an issue with Roon in your case, it has happened in the past:

If you try uninstalling the Realtek drivers completely, is there any change in behavior? If the behavior is still the same, does using the latest driver change anything?

I tried what you suggested by opening Device Manager and disabled the RealTek drivers and than restarted the computer but the same problems still exist. Do I need to use Control Panel to completely uninstall RealTek? I do not want to make irreversible changes to the computer.
Any other suggestions?

Hi @Russell_Jung,

In the previous threads I’ve seen, it was necessary to uninstall the RealTek drivers completely using Control Panel. You should be able to reinstall the drivers if this theory doesn’t pan out, I suspect the drivers are interfering with Roon’s ability to properly communicate with other audio gear in this case.

Hi, I uninstalled the RealTek drivers, rebooted but no success. I also tried uninstalling and reinstalling Roon to see if this may help, but still no success.

I am ready to abandon trying to get Roon to work on this Windows 8.1 laptop. It should not be this difficult, especially since iTunes runs on the same computer.

Hi again,
I finally got Roon to run. After re-installing the RealTek drivers so that the internal speakers functioned, I found on the speaker properties window (image attached), the exclusive mode. With the “Allow applications …” function enabled, I reloaded Roon and the sofware functions fine with the AudioQuest Dragonfly DAC.
This seems to be the solution to my problem.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.