No Internal Audio Device Found

Hi Dylan,

Yes,that is correct!

Sometimes at next start of Roon the internal devices appear for a few seconds and disappear witout a chance of any configuration.

Volkmar

Thanks for the information here, @Volkmar_Sitte!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please let me know when this behavior occurs again and note the time at which the problem occurs (i.e. you notice these devices missing). Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Hi Dylan,
Thank you for your engagement.

Please, find here the list of internal devices I get, when RAATServer is deleted/renamed before start of ROON:

October,14th, 2018, 22:44 (German time):

  • start of ROON with internal devices missing

October,14th, 2018, 22:46 (German time):

  • RAATServer renamed to RAATServer_old13

October,14th, 2018, 22:47 (German time):

  • start of ROON without listing internal devices

I do hope, this is the information you were asking for.

Regards,

Volkmar

Hi Dylan,

I have to revise time of restart of ROON without listing internal devices:

October,14th, 2018, 23:14 (German time):

  • start of ROON without listing internal devices

Sorry,

Volkmar

Thanks for the timestamps @Volkmar_Sitte!

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Hey @Volkmar_Sitte,

I spoke with the team about what you’re seeing, and they’ve proposed a test that should give us some more information. If you use Roon with a new database, does the same behavior occur? See steps below:

  • Make a backup
  • Shut down your Roon Core
  • Locate your Roon database according to these instructions
  • Rename the entire Roon (or RoonServer) folder to roon_old
  • Relaunch Roon, sign in, and configure a new install

Let us know if there is any change after this. Thanks!

Hi Dylan,

I followed your instruction, renamed the roon folder (not the RAATServer folder) to roon_old and relaunched roon.

During relaunch roon asked to restore a backup, which I did.

In Settings/Audio internal devices show up, however, the enabling process does not finish.

When I disabled the process, all internal devices disappeared:

Regards, Volkmar

… by the way. I often renamed the RAATServer folder and relaunched roon, with no better result.

Volkmar

Thank you for giving that a go for me @Volkmar_Sitte , the insight is appreciated.

It seems like you are doing everything right here so we appreciate your patience during this process of troubleshooting the issue at hand. While I understand that the drivers were updated have seen some instances (example #1 and example #2) where the behavior was resolved by uninstalling the drivers completely. Can you try to uninstall and let me know if you see a change in behavior?

Furthermore, when you update the drivers where did you grab the update from?

Hi Dylan,

First update of Realetek drivers came from Realtek downloadpage. Didn’t resolve the problem.
Second update was from msi support. Didn’t work either.
After that, I went back to drivers from Windows update.

I haven’t uninstalled the realtek drivers yet. I’m not shure about the procedure. Is it the same as uninstalling the device (In German: Gerät deinstallieren)?

I’ll appreciate your answer.

Volkmar

Hi Dylan,
for the time being, I’ve disabled Realtek High Definition Audio. and relaunched Roon without renaming RAATServer or Roon folder.
As it can be seen from the screenshots, again, only Networked devices are listed.

Regards,

Volkmar

… When I delete RAATServer folder, the following screen appears after relauch ing Roon:

I’ve enabled one internal device after the other, however, none worked with the headphone output of the notebook.

Volkmar

Hey @Volkmar_Sitte,

Yes, the first screenshot you shared above is where you can uninstall the drivers. You can read more about uninstalling drivers in this article. Can you give uninstalling a go and let me know if there is any change in behavior here.

Thanks!

Hi Dylan,

I have several times uninstalled the Realtek driver, including deleting driver software.
At first Windows restart, there is no Realtek driver listet in device manager:

Relaunching Roon without deleting/renaming RAATServer or Roon folder results in: No internal devices!

Relaunching Roon after deleting RAATServer results in listing internal devices, incl. Realtek!?:

Device Manager shows also Realtek drivers:

After a second restart of Windows (without a Roon relaunch between the two Windows restarts) the Realtek drivers also appear again:

Trying to configure the internal devices shows that there is no device setup possible for the unnamed devices and, hence, no headphone signal on the notebookis available.

I have the feeling, it’s getting more complicated.

Volkmar

Hey @Volkmar_Sitte,

As shown in the first method in the article I shared above, go ahead and try uninstalling the Realtek driver from Control Panel > Uninstall a Program. Once you’ve done this is there any change?

I’d also like to recommend changing the drivers you use here so we can see if there is any improvement. Take a look at this article about using Microsoft HD Drivers. When using different drivers is there any improvement?

Thanks!

Hi Dylan,

Sequence of steps:

  1. After Windows start I’ve followed your instruction and installed the Windows driver.

  2. After relauching Roon, the internal devices were listed.

  1. Notebook headphone output was working.

  2. Closing Roon.

  3. Relaunching Roon -->> no internal devices!

  4. Closing Roon and deleting RAATServer.

  5. Relaunching Roon -->> internal devices are listed as shown above.

What’s next??

Volkmar

PS: Thank’s anyway for your help!

Hey @Volkmar_Sitte,

I’ve passed along your recent troubleshooting results to the technical team for additional feedback on next steps here. It definitely seems like something is amiss with your drivers here and they may have some additional suggestions for what to try next.

Just to verify, in the last steps you followed above (installing Microsoft HD Drivers) did you also ensure to uninstall the Realtek drivers from Control Panel > Uninstall a Program? Are the Realtek drivers still showing there at all?

Thanks!

Hi Dylan,
I Have checked the control panel again, and there was still a Realtek driver (?), which I’ve uninstalled again.

When I rebooted the notebook an errormessage appeared regarding Nahimic 2 driver(??).

Shall I also uninstall this Nahimic driver?

However, when I relaunch ROON, the internal devices show up. And the enabled Headphones appear in the Zones window.

I’ll wait and see now what will happen after a view more shut downs and start ups of ROON and notebook.

Volkmar

Nahimic is a 3-d and surround audio software that comes from MSI for use with their motherboards. Used for gaming.

Daniel,
Thank you for this information. Obviously, the Nahimic driver got also uninstalled (?). I’m uncertain, however, whether I should reinstall it again. Can you give an advice?

With the present configuration, Roon runs as it did, before the trouble with the internal devices came up.

Hence, for the time being the issue can be considered as solved.

Thank you very much to the team again, for the great help over the last few weeks!

Regards,

Volkmar