Database/Tidal issues [Resolved - Removed corrupt Tidal file]

Roon Core Machine

Mac Mini Late 2012 2.6 GHz Quad Core Intel Core 7
16GB Ram
OS Catalina 10.15.7

Networking Gear & Setup Details

Ethernet connection to Mac mini from unidentified router supplied by internet provider. (Have had the router for 6 months.)

Connected Audio Devices

USB to Chord Qutest Dac, latest version of Roon on all devices.

Library Size

Description of Issue

I went away for the weekend and turned everything off before leaving. On return Roon would hang at the first load up screen and not progress.

  • Deleted Roon and reinstalled - same problem.

  • Reset the pram on restart of computer - same problem.

  • Loaded an older database - Roon starts, all physical media available to play. I was prompted to log into Tidal again. After logging in only about 50% of Tidal albums previously in the library loaded. When I tried to add the remaining albums back into my library it would say that they were being loaded but they were not.

Question is how do I get all my Tidal albums back into my library?


Hi @Craig_Fenemor

Can you try this?

Hi Dylan,

That’s fixed it. Oddly I dumped the tidal file in the bin, restarted roon and everything was there without even logging back into tidal. Main thing though is it worked.




This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.