Denon AVR 4700 optimal settings

Roon Core Machine

Intel NUC Mini PC | Intel Quad-Core Turbo 4X 2.30GHz, 512 GB SSD, 16 GB DDR3, Intel HD 500 graphics, 4K resolution, WLAN, Bluetooth, USB3.0, HDMI, VGA.
Windows 10 Pro.

Networking Gear & Setup Details

Connected Audio Devices

Denon AVR 4700

Library Size

Description of Issue

Hello dear friends. I have been using Roon for a year now and will be extending it too. Please help me with the settings. It is not there in the configuration to detect my device.

What do I do best I can? Is the NUC a decoder and renderer?

Thank you in advance.

Hi @Dirk_Stoiber,

The AVR 4700 is listed on Denon’s site as Roon Tested, but it’s not listed on the
Roon Partners Site which is a yellow flag.

Roon Tested devices are typically connected via USB to Roon, not to be confused with Roon Ready which may be connected via ethernet.

Could you confirm how the Denon is connected to Roon?

1 Like

Not sure what you are up to. The NUC is the core, in which the Roon software resides either as single purpose ROCK server or as a Win app. Your AVR is the endpoint that should be connected to your core via ethernet or WLAN. If it is ‘Roon Tested’ or ‘Roon certified’ settings show up in Audio setting on the Roon core software. It appears the 4700 is not on either list. You could try a little trick and select a similar, but Roon Tested Denon AVR as your endpoint and try from there.
How have you been running Roon so far?

1 Like

Thanks for the answers. My Nuc is the Core and this is connected to the 4700 with HDMI. I use the wasapi intel setting and it works fine. I control everything with my notebook. Roon does not recognize the Nuce and therefore I have to configure it manually, and I just wanted to know which settings are optimal. e.g. Decoder and renderer etc. The Roon app is also installed on the Nuc and it is the server.

Denon/Marantz receivers and processors are Roon Tested and they are certified only via Airplay.

If you do not use MQA, set ‘No MQA support’ on the AVR settings page and disable MQA on the Roon server.
If you play MQA, set the AVR to renderer and enable MQA on the Roon server. AFAIK the 4700 is not MQA certified.
And there is no DSD support via HDMI no matter how hard you try.
You could use a RPi 4 with a HAT as a Roon bridge that provides a digital output to the AVR and you have the best of both worlds

1 Like

I took two pictures what the playback with my Nuc shows connected directly to the 4700 via HDMI. Isn’t that a good result? Could a Node 2 as an example do more?


So I’m using my Denon with very satisfying results in my second system using Qobuz. It is set up like this: Nucleus to Windows 10, HDMI to media player hdmi input (set to stereo). This way I can use the tv and a wireless mouse to control Roon. I have not changed anything in Roon except no MQA. Happy listening.

1 Like

Although that is correct, I’d like to clarify that since the majority of Denon Marantz AV receivers do not provide USB DAC input, Roon Tested for Denon Marantz AV receivers can only mean HDMI or AirPlay. In these setups usually HDMI is preferred.

2 Likes

No, the Denon 4700 does not have a USB-DAC input. I can only connect it via HDMI. Airplay is not an option in my eyes.

Have a look at a RPi 4 with a HAT that provides optical/coaxial out and use it as a Roon bridge. For some 130€ you can get a HifiBerry kit with RPi 4, casing, power adapter and Digi HAT. And there is a Topping D10 with USB input only and digital pass through connectors that can work in the same way for about 150€ if you can get one in these strange times.

Looks Ok for me.
You can disable Headroom management (Aussteuerungskorrektor) in DSP Settings to see “Lossles” in Signal Path (Signalweg)

1 Like