Device failed to initialize


I am at WS 2016 core on dual-pc setup. Right now Roonserver doesn’t show any audio devices at all except System output. And when I eneble that, it says “Device initialization failed”. Same with Roonbridge.

Any ideas?

Hello @Johs_Gjela,

Thanks for contacting support, I’d be happy to assist here. Can you please post a screenshot of your Roon Settings -> Audio tab? Do you have any active firewalls on that system? I would check to make sure that both Roon and RAAT are allowed through your Windows Defender Firewall and any other Antivirus firewalls you may have.


Is this relevant?

Not quite the same. I ran the WASAPI-injector an I am connected to Roonserver on my Android phone.
It is the AUDIO tab that is showing “could not initialize…” on system, and all audio devices (ASIO, WASAPI) are not showing up in that tab.

I should mention I have the new JPLAY 7.0a installed, which sounds great, and it would be exciting to incorporate its ASIO-driver with Roon.

Has anyone here got Roonserver working with new JPLAY 7 btw?

I have disabled firewall, and removed Windows Defender by AO.

Hello @Johs_Gjela,

Thank you for posting the screenshots. Hmm, I am wondering, has the system previously worked before you installed JPlay 7.0a? I have tagged @Marcin_gps (a Jplay dev) in case he has any thoughts regarding JPlay 7.0a and if it needs any special settings made. A few other follow up questions:

  • Have you tried rebooting your Core and all networking gear?
  • Can other apps access your audio outputs as expected?
  • What other DACs are supposed to be listed in Audio Settings that are failing to show up?
  • I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis. I will be sure to let you know once our system has received them and I have taken a look.
  • I kindly ask you to try enabling one of your zones again and let me know the local time in your country that you receive the “Device Initialization Failed” message so that I can check around that timestamp.

Please let me know the above information when possible.