DietPi + Allo Web GUI: Now available


(John) #182

I’ve got to the password portion in Terminal, but it won’t let me enter the password, it just shows a key symbol - don’t know what to do?

johncarrigan$ ssh root@192.168.0.087
root@192.168.0.087’s password:

Edit - it seems that if I don’t type in the password within a few seconds it won’t accept it, now I’ve managed to get in


(Scott Houston) #183

So looks good, yes? Type “reboot” and you’re in business?


(John) #184

You’se guys/gals are amazing, thanks for all the help :+1:

I even managed to load Roon Extension Manager Software (not sure if I’ll use it, but thought worth loading while in Terminal)


(Mark Edwards) #185

Great to see you got the update sorted John.

You have been here a lot longer than I have, I was two years into an apprenticeship with Austin Rover as Toolmaker back in 88. Wow, where has life gone.

I came over by myself back in 2002, bummed around for 10 years between Adelaide, England and Sydney before buying a house in Adelaide.

Where abouts are you?


(John) #186

Mark

Sorry getting backing to you late.

I live in Perth (Ocean Reef) and have been here since I arrived in '88. I’ve worked all around Aus and Asia, but now an office jockey so no more travelling for work (except the odd site visit). Meet my wife when I got here so just stayed in Perth (she’s originally from Sydney, but moved to Perth when she was about 11).

I’m a lifetime Roon member, and think it’s great for what it does. Off course everyone would want it to have additional features, but the continuing evolution additional features are great, and a big drawcard.

I got a DigiOne, along with a couple of Boss V1.2’s, and a Mini Boss last week hence my questions above. I got the Allo’s as wanted the gear round my house to be able to joined into the one zone, and eventually when Devialet Expert’s become RAAT compliant I can join them all to the one zone (I’ve a 1000Pro in my main room, along with a pair of Mike Lenehan ML5 Ref speakers).

Cheers
John


(Simone Ratti) #188

Hello Dan, I have messed up the Allo GUI changing the root password. I have followed your instructions:

  • Change thw pwd back to dietpi
  • dietpi-software uninstall 159
  • dietpi-software install 159
  • systemctl start mysql
  • mysqladmin -u root -pdietpi drop allo_db -f
  • dietpi-software reinstall 160
  • reboot

which did not work. When I try to reach the GUI I get “404 - Not Found”.

How can I reset it to normal working?


(Dan Knight) #189

Hi Simon,

As of DietPi v6.10, the Allo GUI has its own limited user account, changing the root password will have no effect.

Please verify the version of DietPi you are running?

Regardless, please do the following to remove Allo GUI (as unsure what state it is now in), update DietPi and reinstall Allo GUI:

dietpi-software uninstall 159 160
dietpi-update 1
reboot
dietpi-software install 159

The above should resolve the issue, if problems persist, please let me know.


(Simone Ratti) #190

I have executed the first command but the 2nd gets stuck on this:
image

what do you recommend?


(Mark Edwards) #191

I know this is the wrong place but I’ve asked on Allo’s support page and emailed them directly and had no answer.

I would like an Australian two pin plug for the Allo power supply (and I’m Sure anyone else in Australia would as well). The power supply manufacturer definitely makes one but I can’t find out how to purchase one.

10

Please help @rahulkc_s @allo.com

Thanks in advance.


(bevan court) #192

It will cost some more money, but I’m using the IFi power to power mine. You get an improvement in will be quality and an international set of plugs.


(Mark Edwards) #193

I’m already using an iPower to power the USBridge side, I tried an iPower on the sparky side and it made the sound worse. In all honesty I’d like to try two of the Allo power supplies.

The point is that if Allo are selling to the Australian market then surely they should supply an Australian plug.


(Andre / ALLO / CMO) #194

@oneofmany
thanks for touching base again and please excuse the delay in reply.
Now China is closed for a week long holiday.
I will send your request and see if they can assist.
Please do check back with me early next week by email.
We will sort this out.

Regards
Andre


(Mr Fix It ) #195

I checked my Allo supplied wall wart and it too doesn’t have an AUST/NZ plug option…odd as China is basically this plug too IIRC. It does have a UK and USA one tho and the round pin often used used in asia/eur too.


(Mark Edwards) #196

Thanks very much Andre.


#197

Is the static IP function broken?
I’m trying to make the rock bridge dual ethernet work with the Allo GUI

Seems like clicking “save changes” after giving new IP Address, IP Gateway, IP Mask and IP DNS
changes the values back to what it was before.
In other words the IP adress it was given by the router.

After rebooting, the endpoint is no longer visible in the network.
I’m guessing it has assigend the old IP adress but changed it to static.
And thats why it’s not showing in the network.

Any suggestions on how to varify my hypothesis?


(Dan Knight) #198

Hi,

I was unable to replicate in local testing, changing the static IP is valid after reboot.
Please bear in mind, the ‘IP Address :’ line, will show the current IP address only. After saving changes you must reboot to apply it.

If the device is not available on the network after reboot, please verify the IP address entered is valid.
Ideally, on the system locally, log in and check the following command

cat /etc/network/interfaces

You should see following:

# Ethernet
allow-hotplug eth0
iface eth0 inet static
address 192.168.0.119
netmask 255.255.255.0
gateway 192.168.0.1
dns-nameservers 8.8.8.8

(Phil Active Audio) #199

Hi there

I setup my RPi 3 Model B+ with the DietPi Allo Web distribution and proceed with a full update using the internal function (bump to version is 6.19.5). The RPi is connected using WiFi, no LAN. It is connected to my DeqX HDP4 using its USB expansion card (RPi USB output).

ROON is working fine, so is GMRENDER using the MConnect HD application with QOBUZ (poor and limited interface, I am waiting for ROON integration).

But SHAIRPORT is not working. The service is up and running on the RPi, but as soon as I start an audio stream from the same iPad (YouTube, QOBUZ …), the service crashes after 1 or 2 seconds and no sound is coming out of the amps. I have to restart the SHAIRPORT service from the Allo Web interface.

My iPad is on IOS 12.1.

Thanks in advance for your help.

Philippe


(Dan Knight) #200

Hi Phil,

Unfortunately, I do not own a iPad to test locally, however, once the issue occurs, please send us a DietPi Bugreport:
https://dietpi.com/phpbb/viewtopic.php?f=8&t=499

Please reply with your reference code, then I can check system logs to hopefully find the cause.


(Phil Active Audio) #201

Hi Dan,

Thanks for taking care of my problem. I will do so this evening French time. What do you mean by Reference Code ?

FYI, I also did a test yesterday using Roon on my PC desktop as I was able to see the Shairport device. Same problem on the RPi side: Shairport daemon crashes. Unfortunately, I was not able to find the log to analyze (just start Google in how to…).

Last, I setup a new install using the standard DietPi distro with only Roon, GMrender and Shairport soft. Same issue…


(Dan Knight) #202

Hi Phil,

When sending the bug report, you will be provided a reference code (unique for your system, allowing us to ID bugreport to your system).

You can also run the following command to debug only shairport (however bug report is preferred, contains full logs)

systemctl status sharport-sync -l