DietPi + Allo Web GUI: Now available


(Richard Thorpe) #82

Pawel,
I was doing that as you wrote I downloaded the DietPi software without the Allo

GUI software directly from the DiePI site, with the same result and interesingly it says the is newer software avaliable, very strange. I include a screenshot from the Terminal. BTW I went to the URL mentioned in the Terminal and downloaded the software, no help.


(Pawel Walczak) #83

Well. Ask someone smarter than me:) I am lost :slight_smile:


(Richard Thorpe) #84

Pawel,
Thank you for the effort its all very confusing. Dan Knight is working on it so are people in India at ALLO. The annoying part is that the Ropiee/ Digione combo works flawlessly, type in the IP and the GUI pops up. Thanks again I will post if an answer is found.

Richard


(Dan Knight) #85

@Richard_Thorpe

I’ve checked all our downloads, and they are correctly version v6.x.

The only thing that I can think of is:

  • Do you have both SD and EMMC connected at the same time? This may cause the device to boot off the EMMC only, ignoring the SD.
  • Which image write tool are you using? Have you tried Etcher? https://etcher.io/

If problems persist, please verify the extracted .img file version, it should mention DietPi_v6.x-***


(Richard Thorpe) #86

Dan,
Thank you for your reply, I did have both installed and the unit was booting off the eMMC. I removed it flashed the SD and now we are cooking. Cheers

Richard


#87

I have put together an RPi 3 B+ and a newly flashed card with DietPi and Allo, however, I am getting intermittent clicks.

17
This alarm has been raised but I’m not sure how to resolve it… Any help would be very much appreciated.

Oliver

[Edit: OK, so I have worked out how to increase the budget using <sysctl -w net.core.netdev_budget=600> however the clicks persist with negligible effect on the squeezed packets…

Perhaps, @Dan_Knight , you might be able to point me in the right direction]


(Dan Knight) #88

Hi,

Is this running over ethernet?

It may be worth updating the RPi kernel, to see if it offers any improvement to stability:

G_RPI_UPDATE
reboot

#89

Hi Dan,

Yes, operating over ethernet.

I have reflashed a new card and not deactivated or changed any of the settings this time (except usb-dac).

I have updated the kernel per your instruction and rebooted.

I now have an additional alarm:

Perhaps this might provided more info…


(Dan Knight) #90

Interesting.

If this does not occur on the RPi 3 (non +), could indicate a issue with the ethernet driver. It is new and may have some teething/stability issues.

Might also be worth trying WiFi to see if the same issue occurs.

If the issue is limited to ethernet only on the RPi 3 B+, I can only suggest contacting RPi with the issue.
If you do, make them aware you have tried both the current RPi kernel (via APT), and, also the latest rpi-update kernel/firmware.


#91

@Dan_Knight

I have successfully connected to wifi (5ghz) and everything seems to be working flawlessly!

I will flag the issue with RPi and see what comes back.

Thank you for taking the time to help me resolve this, much appreciated.

Best
Oliver


#92

Trying to set CPU Governor to Powersave but it returns to Ondemand. I have tried saving, rebooting, re-saving, etc. but Powersave does not take. Any ideas please? (latest dietpi/ Allo USBridge)
edit: using dietpi.local web UI


(Dan Knight) #93

Hi,

Thanks for the report. Confirmed bug, we’ll get this fixed for v6.8, should be available for install this weekend.


(Fernando Pereira) #94

I asked this on another thread but got no answer. I changed my USBridge’s name and added a password. What user name and password should I use for the Web GUI now? The default ones no longer work.


#95

This doesn’t work in DietPi unfortunately… see https://github.com/Fourdee/DietPi/issues/1211 for more details. Less secure, but you should change it back to use the Web GUI.


(Fernando Pereira) #96

I prefer to keep it secure and use ssh to update than to use an insecure Web GUI. Too bad that the Web GUI does not simply use the same login credentials as DietPi :slightly_frowning_face:


#97

Thanks for the fast reply. I’d like to check out if Powersave can have any audible effect on sound quality. Just made a donation, by the way. DietPi is a wonderful solution for me (no Linux knowledge). Looking forward to v6.8.


#98

Any plans to add the wireless configuration option to the Web Interface? Doing that makes it easier for folks who are not as technically savvy.


(Mr Fix It ) #99

@Dan_Knight is this web interface only available on the allo build or it’s it possible to use on the RPi and amd64 builds also? If so how does one enable it?


(Dan Knight) #100

@wizardofoz

Hi,

Currently, Sparky and RPi boards are only supported by the Allo web interface.


#101

New version 6.8 installed, and CPU Governor powersave setting bug is fixed for me (powersave now ‘takes’). Thanks!

I noticed that Swapfile size has changed from around 1/4 of the slider (don’t remember exact number) to left-most setting (number is 1). Is that as it should be?