DietPi + Allo Web GUI: Now available


(Dan Knight) #102

Hi,

Yep, swapfile slider was fixed in v6.8, its automatically set to 2GB - RAM. We recommend leaving at that setting for Allo GUI.


#103

After updating DietPi to 6.8 and Roon to the latest, I get no sound from USBridge although Benchmark DAC3 LEDs change to indicate correct word length/sample rate for different tracks. Had a hard time for the USBridge to be seen in Roon, too. I believe it was only seen when I changed CPU Governor back to On Demand (from Powersave). After that, it was also seen when CPU Governor was set to Powersave. But no sound. Also, no sound over Tidal/Shairport (although, again, DietPi can be seen in Tidal settings). I also tried an Audiolab M-DAC, over which I get distorted sound. Non-USBridge zones work as expected. I have spent two hours rebooting/changing settings. Any help will be very appreciated.


#104

There’s an ALSA mixer issue.

Quick fix(es):

a) ssh into your USBridge

then e̶i̶t̶h̶e̶r̶:

b̶1̶)̶ a̶m̶i̶x̶e̶r̶ ̶c̶s̶e̶t̶ ̶"̶$̶{̶x̶}̶"̶ ̶1̶0̶0̶%̶

or

b2) alsamixer -c 1 , rightarrow to each vertical bar and uparrow to bring the volume to 100%


USBridge and Squeezelite not working with Roon
#105

b2) worked perfectly!

b1) did not work for me.

Got error:
root@DietPi:~# amixer cset “${x}” 100%
Wrong control identifier: “”

(something to do with the quotes? I also used non-curly quotes, but got error:

root@DietPi:~# amixer cset “${x}” 100%
Wrong control identifier:
(without anything after the semicolon)

Back to listening - thank you so much @Xekomi!


#106

glad it worked !

(also, checked b1, it’s not just the quotes, it’s idiocy on my part (it does work if you nano /var/lib/dietpi/postboot.d/sparky_unmute.sh , but what’s the point, really ? :wink: )


#107

Just to confirm please @Dan_Knight, this is the correct setting? Shouldn’t it be set to 2048GB?


(Philo Melos) #108

Here too! Managed with my non-linux-skills and your b2 solution to fix it.

This is why i love to see ropiee working with Allo USbridge. Simple working great symplicity.


(Magnus) #109

I solved this by uninstalling alsa linux sound system :slight_smile:


(Philo Melos) #110

@Magnus Are you willing to share the commands you used to do that? I now have to run putty every time I start Allo USbridge which is very annoying.


(Fernando Pereira) #111

Yes, please tell us how you did it! I don’t want to have any DietPi DSP on the Roon path, the fact that in 6.8 ALSA mixer seems to be getting in the way concerns me. It’s not clear to me what drives the USBridge USB port, actually. What you said suggests ALSA plays no role there, but I thought ALSA was needed for USB audio on Linux… Shows what I know :confused:


(Fernando Pereira) #112

Figured it out, thanks @Magnus for the hint. SSHed into my USBbridge, issued the command

dietpi-software

selected the uninstall option, and there it is, select ALSA to unistall, and continue from there. Actually, I uninstalled a lot more that I don’t care for (MPD, SqueezeLite, Shairport, …). Also uninstalled all the Web server stuff, as I cannot use the Web GUI in my more secure, strong password setup. Maybe it is placebo effect, but it sounds cleaner now than since the 6.8 upgrade. ALSA is obviously not needed for USBbridge, the usb-dac output is still available, I guess through the Allo package that is still installed.


(Magnus) #113

I am from Barcelona, I know NOTHING :slight_smile:

I used the dietpi-software command (I think) and uninstalled the ALSA linux audio mixer.

I only have SSH software and Roon Bridge, everything else is uninstalled.


(Fernando Pereira) #114

Anyone from Barcelona knows more food, music, architecture, and good living than the great majority of us. Linux shell command mojo is just a bonus :wink:


(Rene Bouwmeester) #115

Hey Fernando,

While it probably is placebo – if you don’t care for the WebGUI, why not install the clean-as-a-whistle basic version of DietPi and add only Roon Bridge?


(Fernando Pereira) #116

I don’t think you can only add Roon Bridge, you also need the Allo package and some version of ssh at the very least, right? I’d like to have a Web GUI, but not until it handles custom server names and passwords correctly.


(Rene Bouwmeester) #117

It’s easier: flash DietPi for Sparky and let the bugger update itself. After reboot, you’ll be presented with a menu where you can configure DietPi and install additional software (after installation, these are accessible by typing dietpi-config and dietpi-software).

In config, set usb-dac in 2. Audio Settings and change Hostname and root password in 6. Security Options. From optimized software, install Roon Bridge.

That’s all, really. DietPi has DropBear installed by default for light-weight SSH. This is all that’s running:

Sounds great. :slight_smile:


(Fernando Pereira) #118

Thanks for the guidance, but I’m stumped by the following: if I remove ALSA, RoonBridge is up, but Roon fails to see it. If I reinstall ALSA, Roon sees it again, but the 6.8 alsamixer bug still happens :confused:


(Rene Bouwmeester) #119

Setting a (any) soundcard automatically installs all ALSA components needed for audio playback.

The ALSA option in software additional installs all tools, etc. I believe (I never installed it).


(Fernando Pereira) #120

It doesn’t seem to be working that way for me. If I uninstall ALSA, RoonBridge can’t be seen. If I install ALSA, the muting bug happens reliably. When I originally installed RoonBridge after installing the bare Sparky DietPi, it automatically brought in ALSA. But I’ll uninstall RooBridge and ALSA, and reinstall RoonBridge again, just to double check. Update: Confirmed, the alsamixer bug is present after reinstalling RoonBridge from scratch. :frowning:


(Rene Bouwmeester) #121

To be clear: you need ALSA for audio playback.

It’s just the entry in dietpi-software that does not need to be installed separately. On my Sparky/USBridge, it’s not:

I’m not sure which packages are linked to the DietPi install option in additional software, but you should not need anything besides what’s installed automatically after selecting a sound card.

For me, it’s mostly the overhead of GUI/web server I’d like to avoid – and I have no need for audio software other than Roon Bridge on my USBridge.