DietPi + Allo Web GUI: Now available


#142

I downloaded the Allo GUI image from
https://dietpi.com/phpbb/viewtopic.php?f=8&t=2317&p=8869#p8869
Version of dietpi is 6.6
Allo GUI loads up fine and reports that an update is available.
Run the update and the GUI becomes a garbled mess with update still pending.
Numerous reboots and power cycles. Same.
SSH’ed in and ran dietpi-update. Update is stuck at ‘NTPD: Waiting for completion of systemd-timesyncd (x/60)’. Repeats 60 times then offers to retry. Fails repeatedly.

It appears that an update from 6.6 to 6.7 occurs but the subsequent update to 6.9 bombs with the NTPD time out.

I successfully updated an Allo GUI from 6.8 to 6.9 a few days ago on another Pi and DigiOne and a USBridge.

Anyone else having issues or does @Dan_Knight have any thoughts?




DietPi update 6.7 > 6.11 fails on Sparky/USBridge
DietPi update 6.7 > 6.11 fails on Sparky/USBridge
#143

Allo support offered this workaround;

@Dan_Knight is there a patch/fix in the works?

Thanks


Allo DigiOne board
(Dan Knight) #144

Hi,

I’ve created a ticket and will look into this today:

In the mean time, we suggest our users avoid updating their AlloGUI installations, until this can be resolved.


#145

For anyone else who faces the issues of USBridge disappearing in Roon, or the need-to-unplug even after clicking Reboot in the WebGUI:

I updated USBridge to latest 6.9 (same version number as earlier version – should it be called 6.9.1?) through the WebGUI. RoonBridge still did not work (no USBridge in Roon).
Airplay worked perfectly.
I then changed CPU Governor from Powersave to Ondemand, and RoonBridge worked (USBridge appeared in Roon). I’ve done this twice (with reboots), it’s reproducible.
While on Powersave (Roonbridge not working) there is a CPU spike in USBridge Netdata (don’t know if it’s related).
I also received a Netdata UDP send buffer error (don’t know if it’s related).

The need-to-unplug even after clicking Reboot in the WebGUI also continues with latest 6.9 (6.9.1?).

I’m waiting for @rahulkc_s to respond in an ongoing private thread in Allo Support about these issues.
Perhaps @Dan_Knight should take note of these as bugs?

I’m worried that having to often physically unplug might cause SW corruption or HW damage?


Allo USBridge board
(simon arnold) #146

My new USBridge was set to performance by default so I have left it and no issues here with it. Works flawlessly.


#147

@Dan_Knight,
Is it possible to leverage DietPi as Chromecast end point?


(Roel) #148

That would be a very nice addition to the software. Mainly i use ROON but sometimes i use other streaming services and it would be very nice to use the Allo streamer in stead of a Chromecast Audio. But i wonder if it would be so easy to implement.


(simon arnold) #149

Qobuz does not work on anything other than official chromecast clients. I have tried it using a chromecast emulator and it would not see it.


(Sean) #150

Hi @Dan_Knight - is this possible at all? And being looked at?

I know about PiCast and have seen your comment about that (below), but is a Chromecast Audio solution being looked at for DietPi?

In short, PiCast is not Chromecast, or in any way compatible. Its current abilities are playing youtube videos from a URL link, that must be inputted via a browser. Its essentially a highly glorified youtube video player, with no relation to Chromecast.


(Philo Melos) #151

There was today a new update, so i updated. Unfortunately it “bricked” my usbridge. What is it, that there are so many faults with the updates?
And of course I don’t have a sd-cardwriter that can’t write the special card inside the usbridge. Grrrrrrr!

Hm, sometimes it shows in Roon and then it disappears. When I try to log in I get a fault: 500 Internal server error. Anyone experience the same? My Pi just shows up with the same networkcable.


(Dan Knight) #152

Hi all,

We’ve made some changes to the update procedure for the Allo GUI images.

To prevent future issues with a failed update, and, to ensure stability, updates must now be completed via the command line using:

dietpi-update

This ensures updates are completed in a controlled manner. The update button still exists, however, it will now link you to a webpage with the information to update the system.

This change has been applied to the v6.11 update and latest images (see below)

If your device is “bricked”, please download and re-write the updated Allo GUI images, which contain the above fix:
https://dietpi.com/phpbb/viewtopic.php?f=8&t=2317&p=8869#p8869


(Philo Melos) #153

Putting a hdmi cable is showing the usbridge is in a bootloop.


(Mr Fix It ) #154

I thought that the USBridge units ship with a EMMC to USB reader? if not then I guess you could use a normal micro SD card and burn an image to that and remove the EMMC … but as my USBridge is somewhere between Allo and Singapore right now I can’t confirm.

Failing that maybe get one ordered from Allo - or maybe they will post one FOC


(Philo Melos) #155

I burned a fresh image (with Etcher) to a normal micro sd-card, but then nothing happens at all. I remeber trying it before, but it never seems to work with my usbridge. Maybe there is a jumper to remove or replace to get a normal sd-card working?


(Mr Fix It ) #156

I think you have to remove the EMMC module as that is the default boot device IIRC


(Fernando Pereira) #157

Not current, at least on my USBridge. I never touched any jumpers. The instructions from Allo are here. If you insert an SD card with a DietPi image into the Sparky SD card slot, and power up the USBridge, the USBridge should boot from the SD card, and be available on your local network. Connect to it via ssh to make sure it’s alive and well. Then use scp on the computer where you have the image you want to put into the eMMC card (maybe the same as you imaged on the SD card) to copy that image to /home on the USBridge (SD card). Finally, follow the instructions linked to above to dd the image from /home to the eMMC card, and proceed as the instructions indicate.


(John Aiello) #158

I used Etcher to burn the image to a microSD card and then inserted it into the USBridge and was able to boot just fine. There are no jumpers to change. The boot order is microSD card first and then the eMMC. If no microSD card is present then the device boots from the eMMC. Perhaps you did not insert the microSD card in all the way? It goes in with the pins up and had to be seated firmly.


#159

Hi, like @PhiloMelos and according to ALLO instructions to update by copying from SD to EMMC without removing / reflashing EMMC i’ve successfully flashed DietPi image on SD and then tried to boot from the card: No joy !

SD card correctly inserted, SD card contents readable, but SPARKY always boot from EMMC. Odd …


(Magnus) #160

I still run DietPi 6.6 I think, is there any reason, from a sound quality perspective, to update? My USBridge is rock solid, haven’t restarted it in weeks, so I feel reluctant to touch it.

Btw, I have uninstalled everything except Roon Bridge and some SSH server so I can connect to it.


(Scott Houston) #161

I have the same problem: Roon Extension Manager now included in DietPi (v6.10)

I think a reflash is going to be most straightforward answer – I spent time last night looking for a way to interrupt it (e.g. analogous to windows safe mode), but nothing.