Difficulty changing library to new computer - have tried all listed processes

I have been attempting to move my Roon library to a new computer, changing the core location. I have read through the topics and followed the directions, including making sure that the Roon files are in the proper location. Now, after installing Roon, the software asked me to “log in.” Which I did. The message “logging in” has been proceeding for the last two hours. What do I need to do differently?

Hi Michael,
I know it sounds lame, but have you tried rebooting the computer?
If that does not resolve it can you give us some more information about your setup as detailed in this topic:
[I’m having a problem with Roon – where do I report it?]
(I’m having a problem with Roon -- where do I report it?)

Thanks, Carl. I’ve rebooted after each attempt.

I was previously running Roon 1.2 on a MacBook Pro, circa 2011 and El Capitan. Files were stored on an outboard hard drive. I also use Tidal. Everything worked fine previously.

I bought a Mac Mini circa late 2014 with 8G RAM, and have been trying to move the core to the new computer (the MAC Mini) so I can eventually use the other Mac as a Roon Bridge. I migrated my system to the new MAC Mini using a Time Machine backup, which included the Roon library files and the Roon application. Since then I have not been able to get into Roon - the software asks for my username and password, which I provide, then the system say “logging in” for hours at a time. I’ve retried a few times. I’ve also tried deleting Roon, re-downloading it from your website, and starting over. Same thing happens.

Note that I’ve checked the library Roon and RAAT server files, and there is no application file present.


[quote=“Michael_Bush, post:4, topic:9933”]
I migrated my system to the new MAC Mini using a Time Machine backup,
[/quote]I suspect this is the problem, I suggest downloading Roon and reinstalling over the top of the present copy.

EDIT: just read you did that …

Would another option be to delete the Roon files in the library and start over? I know I’d lose the metadata but I’ve only been a subscriber for a few weeks. I have a backup just in case.

If you don’t mind losing your manual edits, that’s probably the fastest way to get you up and running again.

The other thing that springs to mind are the file permissions of the restored folders. So that’s worth a quick check first.

OK - would I delete the “Roon” folder and the “RAAT Server” folder? I assume so but just want to make sure.

Yep, but do check the file permissions first just in case.

That got it going again - thanks.

1 Like

Hi Michael,

Glad you got it up and running.

Just so you know, Time Machine is not supported to backup your Roon library database. That was likely the problem you encountered.

Read this over to see the best method to backup your Roon files.

Cheers, Greg

1 Like