Display Flickering - Adaptive Sync

Not to resurrect an old thread, but I recently installed Roon on a new machine where I am now running into the same issue (144hz 4K HDR monitor on a DP cable with Adaptive Sync enabled, Windows 11, most recent GeForce drivers etc). Roon is currently the only program that’s causing the issue; it’s not a bad or generic DP cable or something like that. It looks OK, but then it’ll make the whole screen black out for a few seconds now and then, maybe 3 or 4 times a minute. Making Roon fullscreen makes the problem mostly go away, in Windowed mode it happens on it’s own (but more with mouse movement), when Fullscreen it seems to happen mostly on mouseclicks on buttons and whatnot.

Also confirming that turning off GSync causes the problem to go away. But that’s not really a long-term option to have to turn it on-and-off. So there’s something wonky with how Roon is handling GSync / Adaptive Sync.

Hey @Stevan_Brasel,

Ben here with the support team, I’ve made a fresh thread to ensure you receive the proper attention to your issue.

For next steps, please reproduce the issue, grab a timestamp and share it here. In addition to this, please use the directions found here and send over a set of logs to our File Uploader.

I’ll be on standby for your reply :+1:

Hi Stevan,

You should be able to set G-Sync to use Fixed Refresh Rate when using Roon through the Nvidia control panel.

NVIDIA Control Panel > Manage 3D Settings > Program Settings > Either select Roon or Add Roon > Monitor technology set to Fixed Refresh Rate instead of G-Sync

Okay, logs uploaded.

Tried the NVidia control panel option to force Roon to be at a fixed refresh rate, didn’t actually solve the problem unfortunately.

1 Like

Hey @Stevan_Brasel,

Thanks for submitting logs! If possible, we need some additional information from you.

  1. What specific monitor model are you using that is experiencing this issue?
  2. Are you running any other apps when the issue occurs?
  3. Do you experience similar issues when using Google earth?

4.Can you please open Windows Start menu and type in “System Information”. Then, share a screenshot of System Summary and Components → Display?

  1. If you’re able to share a video of the issue as well, that would be extremely helpful for our dev team.

Thanks for your patience here Stevan!

  1. It’s a Dell G3223Q (4K 144hz HDR “fast” IPS)
  2. It happens whether Roon is running by itself or with other programs running.
  3. Google Earth runs just fine.
  4. Screenshots:

  5. Don’t have a fullscreen video recorder at the moment, But basically the entire screen goes black for a few seconds, then comes back. I can’t fully tell if it’s being triggered by mousing over something or if it’s just happening randomly while Roon is open. But currently it’s the only program that’s causing the issue (Discord, Office, Ableton, Steam, Kontakt, etc all work fine). I guess I could take a phone video of the screen and upload that. Same place where the logs got uploaded to?

Have you tried turning off HDR as a test?

Turning off HDR seems to fix the problem, similar to disabling Gsync. Maybe that gives the tech team a vector to explore?

HDR has caused other issues with Roon’s GUI over the years (like invisible cursors). I just run with HDR OFF and purposefully turn it on when I want it.

Hey @Stevan_Brasel,

Thank you for the information above, and thank you @Rugby for the helpful workarounds! We released a fix for a very similar issue a few months ago, and so Stevan if you could please send over a screen recording of the issue happening (phone video works!) it would be helpful.

Please upload the recording here : https://workdrive.zohoexternal.com/collection/nqcgjac23027d90a441bda2c314de49d7958a/external

Got it, video uploaded. For what it’s worth, I’m on Version 1.8 build 1021 stable.

1 Like

Dear All,

same issue here and, more or less, te same configuration of @Stevan_Brasel: Samsung G7 monitor and with g-sync or hdr activated the screen flickers several times, then the image is desaturated and greyish.

Thank you @Stevan_Brasel for sharing this with the team. I’ve passed this information on to our dev team and will check in on them for next steps :pray:

Thanks for your patience here!

Hey @Stevan_Brasel,

After chatting with the team on next steps, we’d like you to run a command line flag to test running roon on a different spec. Please follow the steps laid out here and run the command line -nodeepcolor and let me know if you run into the same issues.

With that, if you could try to get more detailed logging (grab timestamps of when the blackout is happening specifically) and share it here, that would be helpful.

Lastly, do you by chance have over-clocking enabled on your GPU?

I’ll be monitoring this thread for your reply :+1:

Adding the -nodeepcolor commandline tag seems to solve the issue.

(I don’t have overclocking enabled, it’s running at stock speeds)

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.