Display issues on 1.8 B778 [Resolved - B783]

Thanks. I think the ones that doesn’t work is older Intel integrated graphics. My laptop has HD Graphics 3000 which is one of the non-working cards.

GPU Intel HD Graphics (HP)
CPU Intel Core i5 520M @ 2.40GHz

HD 4000 works for me. The HD 3000 had some issues previously that were cured by using the 32 bit version of Roon. Has anyone tried that?

Yup, and no different


CPU - Intel Core i7-2600
GPU - Intel HD Graphics 2000
GPU - Driver -

There are no updated drivers available from Intel or Windows update
No issues with any other software

Of course. I’m just suggesting a temporary workaround, not that it is a solution.

As above, I saw that you had tried going back to 1.7 but Roon was updating automatically back to 1.8. So I suggested the settings to use to stop the update.

This issue seems to have appeared after Roon resolved this issue in Build 778:

So sadly maybe the solution will be subject to a longer QA process, so not to impact further GPU configurations when fixing this issue for Intel integrated GPU users.

Reinstalled version 1.7, all problems gone, both graphics and DAC recognition
Intel HD 3000, i3

Core Machine (Operating system/System info/Roon build number)

Windows 10 home. Running roon minimum requirements. 1.8/778

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Running on Ethernet. I pad Air as remote with current Apple OS

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB to icron 2224 fiber extender to dac about 50 feet in another room.

Description Of Issue

Haven’t fired up the system in about 3 weeks. Roon has been running fine, absolutely no issue since last update which was 1.8. Saw an update was available so I performed it. And now I get this:

Everything works perfect with iPad as remote. I’m at a loss here. Please help!

Just as a FYI - there are some responses from Roon on the issue:

Thank you. I’ve been lurking all evening, just noticed the other thread upon posting mine. Will try the recommended fixes and report back.

1 Like

Tried recommended fixes. All drivers up to date, Issue still persists.

Sorry to hear that, I would suggest also posting in that topic so Roon have a better idea of the number of users effected.

I have same issue here. Looks this is a generic issue for many users. ROON team, please check this. And I would recommend to allow users to download build 764. Now only build 778 can be downloaded.


I have the same issue. Windows 10, ethernet, build 778. iOS apps on phone and iPad are unaffected

Still having the same issue after checking drivers.

Next problem: how to get the old app back, the new remote can’t connect to the old (working) core?

Thanks for all the information, everyone!

Our team has managed to get hardware in-house to reproduce this and our team is working to get this solved ASAP. You have our apologies for the ongoing trouble, and rest assured we’ll be sure to keep everyone here updated as soon as we have more information.


As now roon is almost unusable… i think we all would like to temporaly go back to previous build.
Is that possible?


Same problem for me. I have an older Windows 7 i3 machine. Totally unusable. I am really getting tired of these problems.

Yeah I’m not updating for a while, this is why I’m afraid of updates.

1 Like