Downgrade to 1.8 Legacy on QNAP


MacOs 10.14

How can you release a new version of Roon and disable ALL users who don’t have MacOs 10.15?

Moreover, how dare they provide us with instructions that are difficult for any computer neophyte to understand?
Personally, I don’t know how to get Roon to work on my 10.14 Mac. I don’t understand the instructions. Yesterday I asked you for personalized help and you haven’t bothered to answer me.

Also, what happens if we have Roon on more than one computer and they do accept version 2.0?

And in my case, I have Roon installed on a QNAP 873 that does support version 2.0. So I don’t understand where the downgrade is done (or how), on the NAS or on the computer. Does this affect other computers that support 2.0?

It is not fair that you release an update and leave users without service. We are paying (a lot) for a service that then does not even bother to answer and solve our doubts and problems.

I ask for an immediate solution.

By the way, hasn’t it occurred to you to make a video explaining how to downgrade to 1.8? It’s the least they could have done.

I’m sorry for my English. I use Google Translator.

95628 tracks

1 Like

Hi, @J.A, sorry for the trouble. I sent a question to our dev team about QNAP downgrade flow.

Apologies for the inconvenience.


Please tell them to hurry up and reply.

Roon Core Machine

NAS QNAP TS-873A Quad core 16GB RAM

Networking Gear & Setup Details

not relevant to the problem

Connected Audio Devices

not relevant to the problem

Number of Tracks in Library

not relevant to the problem

Description of Issue

In the help center article it is not explained how to downgrade from version 2.0 to 1.8 on a QNAP NAS server or similar. Version 2 on many clients is not installable and had to be specified well before proposing the core upgrade.

Urgent help is required from the ROON staff.

this is the mentioned article:

Hi, @Fabio_Polo, I moved your post here because there is a similar request. We are working on getting an answer for you.

Sorry for troubles.


An update here.

You can download the “Legacy installer (1.8)” from Under each download button is a small text to download the 1.8 version.



Thanks, but I don’t understand why I have to downgrade my QNAP to version 1.8 if it supports 2.0.

I have the problem with my Mac 10.14 computer. My other two computers do support v2.0.

Have you not taken this into account: that there are users who have more than one computer at home?

If I install v1.8 on QNAP I will not have support for it in a few months.

What you offer me does not seem to me a solution, but a “patch”.

So keep the Nas on 2.0 and buy a new Mac.

1 Like

So keep the Nas on 2.0 and buy a new Mac.

If you pay me, I have no problem doing it.

Sorry, @J.A, this page is not owned by RoonLabs and default language is German. Nevertheless, there is a language switcher on this web page at the bottom.

As for macOS version requirement. In the latest release we moved macOS builds to use .NET and moved away from using Mono. This might be a benefit for a lot of users, especially those running devices with M1-chip, because it provides a better support for these devices. To sum up, macOS minimal version is a compatibility requirement from .NET side.

Apologies for troubles.


I still think the same as I said at the beginning. You have not taken into account those of us who have computers that are a few years old.

That it is not possible to use version 1.8 on a computer and 2.0 on a NAS is a major handicap.

So since yesterday I will never be able to use Roon on my Mac…
It doesn’t look good to me…

Roon Core Machine

QNAP TS-473 version

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I don’t know how to do port stuff. I Looked at this:

and it makes no sense to me.

Can you please tell me how to remove Roon 2.0 from my QNAP and install 1.8 Legacy.


Hey @Steven44,

I’ve merged your thread to this existing thread involving migrating your QNAP to 1.8 legacy. We’re still investing this and will follow up with more information as soon as possible :pray:

Well I’m obviously not alone, using Windows 10 and QNAP TVS-1282T3 x64, QTS latest version.

Tonight after a long and hard work week I wanted to relax and listen to music. I turned it on and… ok, an update needs to be installed… What? No compatibility with QNAP? Tried again, same result. Even the tablet and phone have been upgraded to Roon 2 without any notice.

Then I checked the internet, found something but not really an explanation why it doesn’t work on QNAP.

Anyway, there was a way to downgrade. Unfortunately, not to the version I used before, no, there is another new version 1.8 Legacy. Ok, I installed the PC version first, no problem. But for the server version I had to uninstall the previous version….

And since then everything stucks… all network paths are lost, backup paths are lost….

I was finally able to use a backup, it took a while… restart Roon, ok, then log in again!!

And everything was gone. The backup is gone. Tried it on different ways… Same result.

Restart Roon on windows… the system says my core is ready, connect…. Have to register again… and so on…

I spend now about 3 hours to find a solution….

Long story short: The downgrade is not really working

Honestly folks, this is far from professional. You release a new version and when half done, a message pops up with compatibility issues!!! Then you offer a downgrade option which doesn’t work.

When I have to import all my music again because the backup has obviously too a compatibility problem with the new version, it takes days and my NAS will run on 100% for this time.

How it is possible that the software starts an update without checking the compatibility?

There are lots of problems to be solved. The question is by when and how will this be resolved? I mean Roon is not for free.

1 Like

I tried to do the port forwarding advised by a member and I lost my QNAP. Did a manual reboot. The IP address had changed to something on the internet, not my network. Managed to recover my QNAP.

Now I try to open Roon on my laptop and get this. Can anyone tell me where to get 2.0 so I can use Roon from my laptop?

Hi Steven,
for me it was the other way around. I guess the 2.0 version was removed because it caused some problems.

I’ve stepped back to Roon 1.8 Legacy on NAS, PC, phone and tablet. No problem, can use a backup, everything is fine, but after the backup is complete, none of the devices can connect to the server.

Everthing looks fine. I can’t login, the system says I’m already in, I can choose a backup

After the Backup is done…


There is no way to get ahead. When I restart the software, all information, network paths, restored backups are gone…

The system doesn’t recognize the old server paths

I played this a few times over the weekend with different parameters, but the result is the same: I can’t use Roon.

Obviously, there is some information within the backup that doesn’t match with the software.

1 Like

Really sorry to hear your roll-back has not work. I just won’t trust it.

I have vital business data and Roon Core on my QNAP. I shall be getting in a QNAP expert at some point soon to do a clean reinstall of the QNAP with Roon 2.0 and get the security set up properly, limited to my home network. This will cost me some money.

There was a moderator post that their informal advice by members on complex networking issues can be more harmful than good.


It is surprising that NO Roon Technician gives a solution to the problems that those of us who have devices that do not support version 2.0 are having and that we cannot use because their update has left them unusable.

I remind the gentlemen of Roon that those of us who have this application pay for it, so giving us a decent service is the least that could be expected.

Totally agree with you. Two years ago I had a problem (it was also an update issue) and it was solved within a couple of hours.

Nowadays things have changed. No one is in charge. There is no information available. Don’t know where the compatibility problems came from. Even older devices seems working according to the statements within the community.

I can’t not even go back to he previous version which was working (with some limitations).

Even Microsoft let you run a compatibility program and you have information about a “Go” or a “No Go”. And you get an idea where it stucks.

1 Like

Add me to the list of Roon users who is waiting on detailed instructions on how to downgrade to 1.8 Legacy on my QNAP NAS. I do not want to blow away 2.0 until I know for sure that 1.8 Legacy is going to work. The comments in this thread indicate that it doesn’t work yet.