Downgraded from 2.0 to 1.8. Roon Client on iOS and MacBook won’t connect to core on Win7 PC

Roon Core Machine Win7 PC. Worked great until the upgrade to 2.0.

Networking Gear & Setup Details

Connected Audio Devices

Did a blind upgrade (as usual) to 2.0. Found out that you no longer support Win7 for Roon Server. Followed steps on FAQ page to downgrade Roon Server and Clients to 1.8 (legacy)
Now Roon Client will not connect to Core. iOS just comes up and “spins” after I tried logging out.

Before that, the clients on MacBook and iOS were acting like I’m a new account; asking to add music (I’m using iTunes for the repository); did not see my Qobuz account, etc. Even after adding my iTunes directory, the music didn’’t show up.

Tried rebooting all machines. Made no difference. Help! Wi-Fi using eero. Core is connected directly to the router.

Number of Tracks in Library

Description of Issue

More info. iPad iOS client advertises Core on my windows machine. Version 1.8. When I click Connect, the client hangs…

Anyone paying attention to support tickets? My implementation is DOWN. Music is not available…

What version of Roon is your W7 Core running (is it 1.8 Legacy?), and what versions are your iOS device and MacBook running?

Robert- Roon Core Version 1.8 (build 1126) production1x. This is what my iPad version says is ready to connect to. Trying to connect causes client to hang.

iOS (iPad and iPhone8) is Roon 1.8 off App Store. Deleted Roon 2.0 from my iPhone and iPad. MacBook app is from the 1.8 link on your downgrade instructions page. Deleted the Roon 2.0 Mac app.

Thanks Glen. Are you running “Roon Remote (Legacy)” from the iOS app store on your iPad and iPhone?

Appreciate your help with this. It appears I am running Roon remote 1.8 Legacy. The app icon only says Roon 1.8. But when I go to the App Store I see “roon remote legacy” the text underneath says “ control for legacy roon 1.8.” I’m prompted to open the app, meaning it’s already on my machine…

Are all of your devices on the same network? I am assuming so but it would be useful to confirm what your router is seeing. Also, have you reconfirmed that your W7 firewall is configured to all for both RAATServer and Roon?

Yes. Checked that all devices are on the same network. Also, I’ve disabled all firewalls to get this working.

Am wondering if I should uninstall and reinstall Roon on my W7 machine. Your thoughts?

Can’t guarantee that will work, but it may. Have you performed a backup recently from within Roon to ensure all of you history, changes, etc. are saved?

No. No backups within Roon. I do automated backups to a Cloud repository every night. I don’t have any playlists, etc. I’d just have to reconfigure like a new install.

Will uninstall remove all Roon programs? RAAT, Roon appliance, etc? And when I pick up Roon Server off your downgrade page, will RAAT and all supporting programs be loaded in the process?

Anything else I should be thinking of?

firewall on windows…turn it off to troublesoot, if that works you know you need to redo the firewall settings for all the roon components RAAT/ROON*

Another reinstall question, Robert. Are there two 1.8 Roon cores? One labeled Roon 1.8 and one labeled Roon 1.8 (legacy). When all this started going haywire, seems I remember a point where the system complained that a client was at 1.8 and the core was at 1.8 (legacy). If there are two 1.8 cores, how do I ensure getting the right one?

Mr Fix It, all firewalls are down for troubleshooting…

Yes, there are two recent versions of the 1.8 Cores: 1.8 Build 1105 and 1.8 Legacy Build 1126.

If you’re wanting to stick with 1.8, you should install 1.8 Legacy on all your devices. Links are given here:

1 Like

Thanks to everyone trying to get my Roon implementation working again on 1.8. Instead of uninstalling and loading from scratch on Windows, I did the following…

  • Restarted my eero network.
  • Checked that there are no ports forwarded. I have two static IPs reserved for Airplay adapters.
  • Reconfirmed all firewalls are off.
  • Rebooted Win machine.

Got a little farther. Roon client asked me to login this time. After login the client hangs.

All clients are 1.8. Server is 1.8 build 1126.

Really don’t think I should need to reinstall unless there are incompatibilities between Roon server and the other Roon services on Windows. Any other suggestions?

By “hangs” - what are you seeing? the Roon icon on the client screen and nothing else?

What build number are your 1.8 clients at?

Goeff- I see the animated logo with a half circle on the left.

But I am starting to think there is a problem with my annual subscription; appears to have been charged to an expired card, although I’ve seen no notice other than a successful payment receipt. Have sent a message about this to Can you escalate this internally to get your accounting department’s attention? Thanx…

All the contributors to this thread so far have been community members. Not Roon staff.

Right, so since you have an accounts-related query, I’m paging @accounts for you, and unlisting this topic as we do for all accounts-related queries. A member of the accounts team will respond to you here.

1 Like