Downloaded And Installed Roon Remote to my Android Phone

Doesn’t work. I want to be able to use my phone to control my Roon Nucleus. Evidently Roon is not recognizing my phone, or vice versa. It just says…“Waiting for remote core”… and, “Select a different core”.

There should be a help button on the screen you see. Click that and a screen allowing you to put an IP address should come up. Enter the IP address of the server. If that doesn’t work try
I am assuming that your phone and nucleus are on the same network address range.

No…nowhere to enter an IP address. Are you talking about the iPad or Android phone? I’ve tried and I can’t locate the IP address on my Galaxy S 9+. How do I find it?

Hi @Thomas_Williamson,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Are you able to connect to the Nucleus from other remotes?

Just got my Roon Nucleus back from a repair and it’s working just fine. My main controller is my (relatively new) iPad. However, I’d like to also be able to use my Android cell phone as a controller. According to a few posts here all you have to do is enter where the IP address is. But I can’t find the IP address anywhere on my cell phone.

My router is supplied by our local telephone office (Citizens Mutual, Bloomfield Iowa) and there is no brand name anywhere on the router. We have fiberoptic cable and a fairly fast internet.

Besides the Roon we have two smart TVs and four computers and two Blue Ray players on our network/router. And, yes, we are able to connect our Nucleus from other remotes (my iPad).

Normally when the Android device can’t find the server it times out and gives you a message screen. There is a selectable Help on that screen which will take you to where you can enter the IP address.

Hi, Ged…yeah, on my Galaxy S 9+ Android phone the “help” page shows up for about 5 seconds then the screen switches to …Remote Connection, and below that…“Waiting for remote core”… There is no “Help” on this page. You can click “Remote connections” and “Support Page”. “Help” does show on the first page for about 5 seconds. But when I try to click it nothing happens and then it quickly changes to the second page described above. Can’t seem to navigate to the page showing the IP address so I can enter


Hello @Thomas_Williamson, can you send me a screenshot of what you’re seeing? Also, do you have an option on the screen that says “choose a different core?”

Yes, it says “Choose a different core”. Don’t know how to send a screen shot?


Just so you know, I’m communicating with you on my Windows 10 laptop. I control Roon with my iPad. But I would also like to be able to control Roon with my Android phone. When I open the Roon app on my phone it says…“Remote Connection” then… “Waiting for remote core” and "Roon is still trying to connect…etc. etc. Then there is a window where it says…“Select a different core” followed by…“Need help?”

Maybe I need to wait longer for the phone to time out??

Hey @Thomas_Williamson, so when it says “Waiting for remote core” go ahead and hit “Choose another core” then wait about 60 seconds. While its searching for a core, a “help” option should show up, which should let you enter the IP address of your core. Try entering there and let me know if that gets you connected.

It worked!! I selected “Choose another core”, then “Connect”. I didn’t have to use the other IP address. Both my Android phone and iPad work as controllers. Thank you so much for your help!


Awesome @Thomas_Williamson, thanks for reporting back! Please let me know if you require further help in the future.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.