Dropouts streaming to Chromecast Groups

Core Machine

HP EliteDesk 800 G2 with i5 and 16GB RAM, SSD
Running Windows 10 Pro as a headless

Network Details

Google Nest Wifi Mesh with 3 Google Wifi endpoints
Core machine connected to 1 Google Wifi endpoint with ethernet

Audio Devices

Chromecast audio connected to receiver (coaxial connection) - AKA “Stereo”
Chromecast audio connected to powered bookshelf speakers (analog connection) - AKA “LR Main”
Google Nest Audio stereo pair - AKA “Kitchen”
Google Cast Group including Kitchen and LR Main - AKA “Main Floor”

Description of Issue

I have an inconsistent problem with dropouts when streaming to Google Cast Groups. I can stream to a single set of Google Nest Audio speakers or Chromecast Audio device with no issues. However, if I’m streaming Google Cast Group, I have about a 70/30 chance that there will be intermittent dropouts and skipping at one or more of the speaker endpoints.

For example, I can stream in the Kitchen, transfer to “LR Main” and the stream is solid. But if I try to stream to “Main Floor” there’s a pretty good chance (but not always) that the stream will skip or drop out.

Casting to the Google Cast Group using Plex or another app consistenly works.

Wondering if anyone has similar setup or experience with Mesh networks. I do not regret my Roon purchase, but am missing the whole-house audio. Any suggestions for troubleshooting/testing would also be welcome.

I have a somewhat similar setup, but with Eero mesh wifi devices in my house. I’ve read here they can cause problems, but they’ve been so good for my non-audio streaming uses in the house that I could not give them up. I have 2 Chromecast pucks connected to powered speakers via analog, and a Google Nest speaker (with the creepy microphone turned off!) all in a group. I was having frequent dropout problems, but I saw something here about turning off MQA for the group in Roon. I did that (easy decision, since I ditched Tidal for Qobuz anyway) and that for me has solved the problem.

1 Like

Thanks! Turned off MQA for the Chromecast Audios and that seems to have resolved the issue.

(I’m afraid I couldn’t give up the WiFi mesh for the same reasons.)

EDIT: Nevermind, the dropouts came back in force tonight.

Well, that turned out not to be the solution. Hmmm…


Unfortunately, I also have dropouts in connection with cromecast. But I only use one endpoint, not a group … :frowning:

JBL Control XStream with Chromecast built-in dosent work flawless with roon - Support - Roon Labs Community


1 Like

When I was still using Chromecast, I had a trick:
Disconnect all Chromecasts from Google Home once and set them up from scratch.
In a way, that the first chromecast is really close to the Wifi router or is connected to it via ethernet adapter. That’s the master. For that purpose I used a Chromecast puck not even connected to a speaker. But added it as a master to each individual Chromecast group. Next set he other chromecasts from scratch, in any order.
I have to say that I no longer use Chromecast for a while and do not know if the trick still works.

1 Like

Interesting. I’ll have to give that a try. Thanks for the suggestion.


Peter, do you have issues if you stream only to the JBL? My experience is that a single Chromecast stream works flawlessly, it’s only when I try to send to a group that I have a problem.

Yes, only one.

That’s frustrating.

not sure if any of your chromecasts that are having issues are connected to an ethernet cable, but there’s a thread out there that suggested simply using wi-fi would fix the issue.

I have a few Chromecasts throughout the house, and only one was having dropouts. It was one that was connected to ethernet. I disconnected it and went to wi-fi, and the problems stopped. (The others that are connected to ethernet have no issues.)

No idea why.

Thanks Chris. These are all wi-fi connected.

My current mesh is a Google Nest Wifi Router with three Google Wifi’s, but I’ve ordered two more Nest Wifi Routers (because they have ethernet connections) to replace two of the Google WiFi’s. Hopefully that will increase the quality of the mesh and maybe address the issue?


Sorry - I forgot that I did more than just turn off MQA. I also used DSP to do sample rate conversion. I saw somewhere the CCA is limited to 48kHz anyway, so I set up a custom preset that reduces it for higher-res tracks. (Click volume at lower right, then DSP, and enable Sample rate conversion at upper left.). Don’t know if these changes I made are a placebo, but I have banished the dropouts.

Sometimes I wonder, though, looking at other people’s comments here, if it actually has more to do with time of day and what other people in my household are doing on the network …

Thanks Brian. I’ll give that a try too.

Best regards,

The CCA will run up to 24/96.
Mine all run at this limit.
I think it’s Chromecast built into something like a TV that is limited to 48.

However if that is working for you then that is an excellent result!

I did the same thing yesterday. At first there were no more dropouts. Time will tell if it helps …

Thank you.

The dropouts are back… :frowning:

So yesterday I disconnected the Google Nest WiFi mesh and installed an Orbi RBK53s Wi-Fi 6 mesh system. What a huge difference. Still get an occasional dropout (once in three hours of streaming last night) but it’s much better.

At the same time, I’m just ordered a Raspberry PI and DAC HAT to see if that’s a route I want to go down for main endpoints.

Hello @Timothy_Huber

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

It looks like the new Orbi Router/Mesh configuration may have solved your issues. We’re hoping that’s the case. Our customers have had good experiences with Orbi Routers. We recommend an additional router setting change detailed in this article if you’d like to take a look.

The tips in this article may also provide some additional optimization that will improve your listening in experience in Roon.

If you encounter any other issues please don’t hesitate to reach out to us, we’re happy to help. And, as you’ve seen, or Roon Community has a wealth of knowledge and advice to share as well. Happy listening! :loud_sound: