DSD not showing in settings

I have a Resonessence DAC and a Sonicorbiter SE. I have DoP selected in the DAC RoonReady settings but when I go to Settings > Audio in Roon, there is no option for DSD playback. There is also no option to select DoP anywhere in Roon settings. I can playback DSD without issue in HQ Player. What am I missing in Roon? Here are my options:

Thank you for your help

Hi @Robin_Carmack ---- Thank you for the report and sharing your feedback with us.

If you navigate to your “audio tab” in settings, select the gear next to the desired zone, and choose “device setup”. Under the “playback” tab is the “DSD Playback Strategy” set for DoP?


Thank you Eric. That option is not there. I have a SonicTransporter i7 with Roon coming today. I am going to delete Roon totally on my MacPro and start fresh. I will post as soon as I get it set up and report back.

@Eric I have received and set up my ST i7 with Roon DSP and the DoP option is not there under settings > audio. I only have the choice of PCM. I double checked the settings in the SOSE and definitely have DoP enabled there. DSD shows in HQ Player though so I will use that for now. Here are screenshots if that will help:

Hi @Robin_Carmack ---- Thank you for the follow up and confirming that DoP is set on the SonicOribter SE as that was going to be my next question :clap:

You’ve mentioned the following in your most recent post and I just want to be 100% certain that you are looking in the right place.

“I have received and set up my ST i7 with Roon DSP and the DoP option is not there under settings > audio.”

Using a PS Audio PerfectWave DAC:

  1. checking my DSP setup first, you’ll notice that I am seeing the same thing:

  1. Next, checking my device settings, DSD playback is set to convert to PCM. Which I change to DoP:

  2. Navigating back to my DSP setup, I am given the option for DSD:


Thank you Eric. My Veritas is not an option under devices. I only have the SOSE and HQ Player. The Veritas DAC shows up in the SOSE settings but not in Roon as an endpoint. It does if I use my MacPro but I am using a SOSE

It is a DAC not a streamer?

@Roony: The SonicOribiter SE is his streamer, with the DAC connected to it via USB.

@Robin_Carmack: Can you post of screenshot of the RoonReady settings for your DAC on the SOSE?

1 Like

Hi @Robin_Carmack ---- Can you please post a screenshot of the “DAC Diagnostics” page on the SOSE?


Hmmm… That looks right. Is volume set to 100% (both in Roon and on the SOSE)?

Perhaps @agillis or @Jesus_Rodriguez has an idea?

Yes it is. I emailed Jesus but he didn’t know either. I can use HQ Player for DSD as it shows up in DSP settings. I am using the SOSE until the Ultrarendu is available but have not been able to use Roon for any DSD playback. I am stumped for sure. Thank you guys

That output looks super strange.

Usually for a USB Audio 2.0 connected DAC, I expect to see something more like this in the top box:

brian@nucbuntu ~ $ cat /proc/asound/card2/stream0                         [ 1 ]
Resonessence Labs Resonessence Labs HERUS P at usb-0000:00:14.0-2, high speed : USB Audio

  Status: Stop
  Interface 1
    Altset 1
    Format: S24_3LE
    Channels: 2
    Endpoint: 2 OUT (ASYNC)
    Rates: 44100, 48000, 88200, 96000, 176400, 192000, 352800
    Data packet interval: 125 us
  Interface 1
    Altset 2
    Format: S16_LE
    Channels: 2
    Endpoint: 2 OUT (ASYNC)
    Rates: 44100, 48000, 88200, 96000, 176400, 192000, 352800
    Data packet interval: 125 us

It looks like the system was unable to dump that info at all, or something. This is a lower level problem than Roon/RAAT–the DAC is not associating with the OS on the SOSE properly, or something like that.

maybe you were playing audio when you loaded the page? If so, do a hard stop (press Ctrl/Cmd-T, or pause and wait 10 seconds) and then try loading the diagnostics page again.

I think you should still get sane results like what I pasted above regardless of whether playback is happening (but given how ALSA works, I wouldn’t count on it 100% of the time).

The DAC that I used to dump that info is not exactly the same as yours–it’s the closest thing we have, also from Resonessence, with the same set of playback capabilities. It is doing DSD fine for me.

1 Like

Following your suggestion, i get this:

I forgot to add that I was playing audio when I loaded the page. This morning, Jesus had me to do one playing and then stopped and he didn’t know so he suggested I post in the Roon support forums.

I switched from HQ Player to RoonReady out of curiosity:

If I connect my Mac instead of the SOSE, it shows all settings including DSD and I can use the DAC as an endpoint as well but I really like these streamers and LOVE the STi7 with Roon. I can just use HQ Player for DSD playback

Hm, ok. Same result, basically. Still unable to do the format probe properly.

I think until you’re getting output like I pasted above with a complete list of sample rates, etc, this is probably an issue with the OS on the SOSE (or this device + Linux) or something like that.

I will make sure we contact Resonessence and see if they can send us a VERITAS. They have sent other gear in the past, so they might be game. Then at least we could look and see if this is reproducible here and get a really conclusive answer.

1 Like

I had this also with a microrendu and aurender DAC/amp.
After a few times power off/on the microrendu DSD did show up.