DSD128 upsampling is turning off my DAC (Teac AI-503)

Hello there

I tried this morning upsampling DSD128. I don’t have the “audiophile knowledge” but I had a feeling the sound was better: more nuance, more space in the stage and “detailed bass”. Or maybe it is just a placebo effect.

It worked for an hour. Then, the connection was lost with my DAC: it felt like it was put in standby mode.

I was wondering what could be the cause of this issue. I’m thinking:

  • MacBook Air: it’s old from 2011 and I’m thinking of replacing it with a Mac mini

  • The USB cable: I bought the cheapest I could find: 2 SGD. I wonder if I buy expensive USB cable, it would work better.

  • My DAC: it’s new but I hope I don’t need to change it. It’s a Teac AI-503

Is there a way to know what could be the cause of this issue and how could I fix it?

Thanks in advance for your help

DSD upsampling is processor intensive you can check if Roon is keeping up by checking your signal path whilst upsampling. To do this where you see now playing click on the blue/purple dot. Hear you can see how quickly its processing if your above 1 X you should be ok, anything lower your cpu is not upto it, you can turn on paralize sigma delta and this will use allmyour cores rather than one and cannhelp with older slower processors. Also the core wired to your network or wireless? You will run into issues if wireless core is best on a wired connection.

It says 2.2x so it should be fine, no?

It happened again. Could someone from @support have a look, please?

How is the MBA connected to network? Are music files local or on the network

Hi @Gigatoaster ---- Thank you for the feedback and report! The insight is very appreciated and sorry to hear of the troubles.

Moving forward, may I kindly ask you to please provide the following information (see below) to help in our understanding of this behavior:

  • You had mentioned some concerns about the USB cable being used between the MBA and the DAC. Have you tried testing with another since making this observation while upsampling to DSD128?

  • If you have another DAC that is capable of handling DSD128 have you tried testing with it mounted to the MBA while using the same USB cable and media?

  • If you have access to any DSD128 content is the experience the same when you are not using the DSP engine?

  • Are you able to confirm that the same exact setup has no issue playing DSD 128 content outside of Roon?


Hello there

In order of appearance:

  1. The DAC is connected via USB on the MBA. I use the iOS app to play the songs as a remote.

  2. I don’t have another USB cable, unfortunately. I was just making an assumption.

  3. I don’t have another DAC to try

  4. I do have some DSD128 or DSD64, I can confirm they play correctly when not using DSP Engine.

  5. You mean not using Roon but another player?

Great, thanks for the feedback @Gigatoaster! Very appreciated! A few things moving forward…

“5. You mean not using Roon but another player?”

  • :+1: Yup this is exactly what I am looking for.


Hello @Gigatoaster,

I wanted to check in with you here and ask if you have had a chance to run @eric’s test regarding using another player to stream DSD128 content? Is the other app working as expected or is the other app also experiencing issue trying to stream the DSD128 content?

You mentioned that DSD128 content plays correctly when not using the DSP Engine, can you please post the Signal Path when it works as expected? I would also try using another USB cable for you setup, you don’t necessarily need to buy the most expensive one but those types of USB cables are relatively inexpensive so I would try another one just to make sure that the cable is not damaged.

Please let me know your findings when possible.


Hello @noris

I’m getting a new Mac mini next week, so I’ll try your suggestions next week. Thanks for following-up

1 Like

I have the mini since this WE and got some HDD issues on Sunday. Although on Saturday I did notice my DAC to turn off by itself. I’ll test more but do you mind activating the diagnosis to find a solution? I’ll note the time if it happens again this week.


It just happened today at 7:05 PM SGT (11:05 AM GMT)

Hello @Gigatoaster,

Thank you for letting me know the timestamp. I have just checked our diagnostics system and I have not been able to find any new reports for your account. I have re-enabled diagnostics but if they still do not come in, can you please manually send us the Logs from your machine so that we can take a look? The best way to get the logs over to us would be through a shared Dropbox link or shared Google Drive link. Please let me know if this is possible.


Thanks @noris . I don’t have Dropbox, do you have another way?

Hello @Gigatoaster,

I will PM you shortly regarding another upload method.


Thanks. I followed your instructions. It happened again just now 1:03 PM SGT.

Happened again just now (1:34PM SGT), this time was when I turned off/on my TV, on which the mini is connected. Weird!

Hello @Gigatoaster,

Thank you for sending us your logs. I have reviewed them and as far as I can tell, I am seeing that the connection to the TEAC device was lost and Roon attempts to reconnect but is unable to do so for a few seconds - a minute. The reason why it is disconnecting is not clear yet and I have asked QA to take a look at the logs to see if they can provide some more insight.

With this said though, I think we should take a closer look at the TEAC itself. Can you please try replacing the USB cable with another one or possibly trying the TEAC drivers for Mac from their website? My initial impression is that the USB cable you’re using does not support enough bandwidth to stream DSD content properly. I will be sure to let you know once QA has provided me the full analysis for your logs but if you can replace the cable & check those drivers in the meantime, that would give us a great troubleshooting starting step.


Thanks. I’ll go to the shop and get a better USB cable. I bought the least expensive one (2SGD) so that may be the reason.

In your own opinion, is to worthwhile to put 100s of SGD in the cable or something more affordable would suffice?