DSP upsampling in Roon not correlating to streamer/DAC

I have a HiFi Rose RS150B streamer/DAC as a Roon endpoint and is recognised by Roon. The HiFi Rose RS150B is capable to upsample to 768kHz and to DSD512.

When I use the DSP in Roon the maximum upsample setting is 192kHz and DSD64.
Why can’t I use higher upsampling rates in DSP in Roon for my HiFi Rose RS150B?

Post some screenshot of how you have it configured in Roon.

Here are my configuration:

Try fix volume

What do you mean by fix the volume?
Is the volume setting restricting the sample rate conversion?

With my Marantz HD-DAC1 it was only possible to Upsample to DSD when Volume Control was set to FIX… Try and see what it brings…
With the Naim Atom it doesn’t matter…

Because you were using USB input.

Because you’re using Roon Ready network input.

No, the volume control setting doesn’t affect that Roon is limiting the sample rate conversion to DSD64.

Hi @sgb,

The HiFi Rose RS150B is listed as a Roon Ready device, so Roon should be reflecting the devices capabilities.

I’m moving your topic over to #support that Roon’s @support team can advise.

To aid them to better assist you, can you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they have a clear understanding of how your devices are connected.

Hello @sgb,

A) Make sure that you are running the latest firmware on the RS150.

B) What output(s) do you have enabled on the RS150? If you have one of the digital outputs active it may limit format support on the device.

I would expect that the RS150 Roon Ready integration supports 384kHz + DSD512 when using the analog outputs exclusively.


I have the latest firmware, Ver 3.8 (Rose OS 3.8.13). I got the RS150B on saturday and downloaded the latest firmware before I started to use the RS150B.

I am only using the analog (XLR) output direct to my poweramplifier.

A thing to remember is that that RS150 uses Asahi Kasei VERITA AK4499EQ module and the RS150B that I have uses ESS ES9038PRO module.

A picture of my configuration:

Hello John,
I just checked the digital outputs and there were some that was activated. I deactivated them and now I can get DSD256.
So problem solved even if I can’t get DSD512.
You can close the problem.
Thanks for all the help to everybody

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.