ELAC Discovery Z3 not connecting anymore

I switched my Wifi mesh from Orbi to Linksys Velop. I have all of my devices connected to the new mesh but I cannot get the ELAC Discovery Z3 to connect. I believe I did have it working with Velop at one point but it has stopped working.

I can bring up the Z3 app and put in the password for the Wifi and the light on the ELAC Z3 goes solid white in the front which means it is connected but the device never shows up in the Audio tab on Roon. I have tried to rescan with no luck.

I have even tried a hard wired connection from a Velop node to the ELAC, and it shows a solid white light, but again, does not show up in Roon.

I try to update the firmware on the ELAC but it says that the speaker does not have an internet connection.

I’m at a loss as to what has gone wrong. I tried the factory reset without any luck.

Any thoughts?

Hello @Lawrence_Kellogg,

Are you able to play to the Z3 using iTunes and Airplay?


I’ll try that. I’ve never tried AirPlay with it, just Roon.

I’m stuck, I can’t get Roon to see my Z3 no matter what I do. It’s been working for a long time. Sigh.

Hello @Lawrence_Kellogg,

I would recommend connecting the Z3 to your router via ethernet and then updating the firmware. If you are unable to do this, or if you are unable to get the WiFi setup on your ELAC Z3, I recommend reaching out to the ELAC support team as they will be in the best position to get this issue resolved.


I tried plugging in the Z3 with an Ethernet cable but that doesn’t work either. The firmware updater in the Z3 app does not see the internet connection.

I posted on ELAC’s board but nobody has responded yet. I’ll try to call.

I loved that little speaker and I miss being able to listen to it in the kitchen.

Thanks for updating us here, @Lawrence_Kellogg.

If the Z3 isn’t seeing any network connection this is likely the reason that Roon cannot see the device. Once that is sorted out let us know if you’re still having issues and we’ll be happy to help!

This is a year old thread but I wonder if the OP tried a factory reset of the speaker

Many, many, times. Eventually, ELAC sent me a replacement speaker and said there had been changes with some of the network drivers. The new speaker worked.

Just received mine, and it tells me I need a firmware update, but under the “About” area, there is no update upon which to click. Their online tech support did not have an update error.

I’ve moved. Big mistake. The ELAC has lost its network and its mind.

I try to go through the Bluetooth pairing process, I can connect to it from my iPhone, but when I select it from the Z3 app, it just shows a wait timer and never shows me the device settings.

I tried a factory reset and that did not help.

I hardwired it to the router and got the same result. This thing is beyond frustrating. If it did not sound so good, I would throw it in the trash.

What else can I do to it?

I got it, don’t ask me how. Plug, unplug, reset, eventually it latched onto the Bluetooth and I was able to configure the WiFi and it seems to be working well. Roon can sometimes take forever to find itself on the network. I guess I need to research fixes for that.

The solution for us was to enter the setup by going to the IP address of the Discovery Z3.

The app for the unit does not work for us.

It then took two updates and appears to be working fine.

The people at ELAC tech support tried to assist but one decided to go to their software person to determine if you “can set up the speaker and not use the App.” It was he who recommended that we use the IP address of the Z3 as shown in Roon/Settings/Audio

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.