Error authorizing with TIDAL: MissingMethod."

Core Machine (Operating system/System info/Roon build number)

Machine = Apple Mac mini (mid 2011)
OS = High Sierra (10.13.6)
CPU = 2.3 GHz Intel Core i5 (dual core hyper threaded for a total of 4 logical processors)
RAM = 16GB
OS drive = 100GB Viking SSD
Music Library drive = 500GB Samsung EVO SSD
Roon Core Version = 1.7 (Build 537)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Roon core on Mac mini has a WIRED network connection via Cat6 RJ45 Ethernet to my UniFi Dream Machine Pro router.

My router is wired (via RJ45 Ethernet cable) to my Arris DOCSIS 3.0 cable modem.

My ISP is TDS with 600mbps down and 20mbps up.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

TIADL > Roon core > MacOS on Mac mini 2011 > USB > Schiit Audio Yggdrasil DAC

Description Of Issue

I recently change my TIDAL password at and of course Room now can’t login. So I went to…

Settings > Services > TIDAL “edit”

…& instead of allowing me to edit the login credentials the only option I was given was “logout” “done” or “retry”. I think “logout” is a bit heavy handed just to have to change the login credentials, but whatever. So I logged out just so I could login again with my updated password.

HOWEVER, when I clicked “login” I get an error…

“There was an error authorizing with TIDAL: MissingMethod. Please try again.”

Yet no matter how many times I try I get the same error.

I even closed the Roon app & re-launched it & I still always get the same error.

So for now I’m relegated to using the TIDAL app directly which means I have to manage what’s playing via a remote VNC session to my Mac mini until this gets fixed.

A post was split to a new topic: Issues Authorizing TIDAL

Hello @the1010boy and thanks for the details! So you’re trying to log into TIDAL on the Mac Mini and you’re getting this issue, do you get this issue if you log into TIDAL on a remote? Also, if you set Chrome as your default browser and let Roon open the TIDAL login screen through there does it work?

@nuwriy I get the same error regardless of which device I try it on.

My Roon core is the Mac mini running Roon Server.

I have tried to login to TIDAL via Roon app on my iPad, iPhone another MacOS device. All get the same error.

I just downloaded & installed the Roon desktop app on the Mac mini running the Roon Server app & even from there I get the same error.

The error doesn’t change. It’s the exact same every time from every device.

Hello @the1010boy and thanks for testing that! I took a look around the community for this “MissingMethod” error and it seems like other cases ended up being users on previous versions. I know in your original post you said your core was on 537. Could you please give that a quick double-check on your devices (especially the core) and verify that your core is running 537? Thanks for your patience, let me know!

Since filing this ticket a newer version of Roon has released. However, when I tried to update my core it never completed (don’t remember what the error was, if any).

So I decided to just create a new admin user account on my Mac mini, install the latest roon core software as a fresh install, then restore my roon database to the new core instance via my latest Roon backup. I was then able to login to TIDAL again & all is now working well …finally!

You can mark this as resolved.

Hey @the1010boy, will do! Please let me know if you need any help in the future.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.