Error Codes 502 and 504 in Arc on Zen WiFi AX Model T8 in AP Mode, UPnP Setting Missing (ref#QOT0XJ)

Network Setup

· I use my ISP's router alongside a personal router.

ARC Status

· ARC is *Not Ready*

Roon Error Code

· “natpmp_autoconfig”: {“status”:“NotFound”}, “upnp_autoconfig”: {“status”:“NotFound”} }

Have you successfully located and enabled the UPnP or NAT-PMP settings in your router's web UI?

· UPnP is not listed in my router settings

· How would you like to continue with the network configuration?
I would like to try and find a solution for UPnP/NAT-PMP on Roon Community

Describe the issue

Please help with Arc on Zen Wifi AX Model T8. I am getting this error code:

{
"ipv4_connectivity": {"status":"NetworkError","status_code":502,"error":"error: Error: connect ECONNREFUSED 70.aaa.bbb.ccc:55000, response code: undefined, body: undefined"},
"ipv6_connectivity": {"status":"NetworkError","status_code":504,"error":"error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined"},
"external_ip": {"actual_external_ip":"70.aaa.bbb.ccc","actual_external_ipv6":"2600:iii:jjj:kkk:lll:mmm:nnn:ooo","router_external_ip":"null"},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"status":"NotFound"}
}

I switched my Zen WiFI AX to "AP Mode", which I believe is "Bridge Mode". Now that it is in "AP Mode", though, there is no setting to enable UPnP. That is under the "WAN Settings" but the WAN settings disappeared when I enabled "AP Mode". I called Asus and they were not able to help, suggesting that I undo "AP Mode". So, I am stuck.

Can you please help?

Describe your network setup

ISP is AT&T broadband. The modem is Arris BGW210. I called ATT and they put it into bridge mode for me.

My router is ZenWifi AX model T-8;

The two are linked to each other via ethernet cable.

The Roon Server is running on a Nuc with Windows (I think it is Windows 11).

@Steffan_Dye, if AT&T put the BGW210 into bridge mode, then your ASUS router needs to be placed back into the Wireless Router Mode in the Administration tab and then see if activating UPnP on the ASUS router corrects the ARC error message.

Thank you, @Robert_F, for your help. The reason I switched to AP Mode is because I was getting a multiple NAT message. If I tell the Asus to switch back to the default wireless router mode, it asks me to select from: Automatic IP, PPPoE, Static IP, DS-Lite - and there is a check box for DHCP Option. Do you know which of those I should select?

@Steffan_Dye, I am not sure what setting to use given the tiered nature of how you have configured your network and are using your VPN. For what it worth, I am using the Automatic IP setting for my network, which has an ISP router in front of my ASUS router, but in a much simpler configuration compared to your network. My ASUS router is set to be a router with a second AiMesh node attached to it, with all my home networking connected to the ASUS system on a separate subnet, and not the ISP router.

I put my Asus router back into wireless router mode and selected for automatic IP. Now Roon says this:

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 70.aaa.bbb.ccc:55000, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“70.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“192.168.1.236”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.50.1”,“found_upnp”:true}
}

Any ideas about where to go from here?

Given that error message I don’t believe AT&T is able to change the BGW210 into bridge mode (AT&T requires their home gateways to be connected as routers).

You will most likely need to deactivate UPnP on the ASUS router and create a series of port forwarding rules:

  1. From the BGW210 to the IP address of the ASUS router using the ARC port number
  2. And then from the ASUS router to the IP address of the computer running Roon Server, again using the same port number shown in Roon ARC.

Thank you, @Robert_F, for your help. Unfortunatley, your new suggestions are over my head. Could you help me with more detail about what to do.

  • I can deactivate UPnP on the router
  • You said I should create a port forwarding rule from the BGTW210 to the IP Address of the ASUS router using. I don’t know how to do this. Should I call AT&T and ask them for help on this part?
  • You said to create a port forwarding rule from the ASUS router to the IP address of the computer running Roon Server. How do I do that, exactly.

Apologies as I am not a networking expert (or computer expert, either.) I would like to get ARC to work, however.

I do appreciate any help you can provide.

Hi @Steffan_Dye,

Thanks for taking the time to write in about your issue, and thank you @Robert_F for providing excellent support so far!

Steffan, the first step you’ll want to take is to review the provided IP addresses for your BGTW210, your ASUS router, and the machine running Roon Server. Write down each IP on a note. You’ll also want to write down the port number that shows up in your Roon Settings>Roon Arc.

Then, access the ASUS network settings and add the first manual port forwarding rule: from your BGTW210 to the ASUS router (this is where you’ll input the specific IPs for each).

After you’ve completed that, follow the same procedure in creating another manual port forwarding rule, but this time using the IPs from your ASUS router, and the machine running Roon Server. :+1:

Let me know if that helps kickstart the process for you!

1 Like

Hi Benjamin,

Thank you for your help. The BGTW210 lists two IP addresses. One says “Broadband IPv4 Address” and one says “Gateway IPv4 Address”. Which of those is the one I use?

I found the port forwarding area in the Asus Router. For the first manual port forwarding rule you mentioned:

  • It asks me for a protocol: TCP, UDP, Both, or Other. What do I put there?

  • It has an optional field for “Service Name”. Do I put something there?

  • It has a field for “External Port”. Do I put the IP Address for the BGTW210 there?

  • It has an optional field for “internal port”. Do I put something there?

  • It has a field for “Internal IP Address”. This field has a drop down menu that shows different devices. Do I select one of the devices I see there?

  • It has an optional field called “source IP.” Do I put something there?

Then, I have all these same questions for your next suggestion, too, which was to create another port forwarding rule from the ASUS to the NUC that is running Roon Server.

Thank you for any help you can provide. I really would like to get this to work.

Kindly, Steffan