Every album imported is duplicated

After updating to the new version of Roon, albums I had imported the night before disappeared. I went into the setup menu and entered the location of the music files on my computer again. I was thinking it would find the missing albums and import them; however, what I ended up with were duplicates of every album! It has continued duplicating each new album I add, so I have no idea how to resolve this issue. I would greatly appreciate any assistance.

This is what’s causing the duplicates.

What does your “Settings->Storage” screen look like now. Can you post a screenshot?

1 Like

I went into the Storage area and the path for my music files was repeated, so I removed the extra one. That however doesn’t help with the mess I have now. Not only are there duplicate albums filling the space, but Roon often divides up one album into multiples with different tracks on each one , so now I have double that! Would it be better to remove Roon from my computer and reinstall it? Please advise.

Hey @Mark_Miles – have you done anything in Roon you want to preserve? This would be things like editing, creating playlists in Roon, marking favorites, etc.

If there’s nothing you want to save, you can just delete your database (located here) and then reinstall.

That said, I don’t know if a fresh install will help with all the issues you’re describing here: [quote=“Mark_Miles, post:3, topic:20749”]
That however doesn’t help with the mess I have now. Not only are there duplicate albums filling the space, but Roon often divides up one album into multiples with different tracks on each one , so now I have double that!
[/quote]

If you’re having any more issues, just let us know.

1 Like

Mike, I was concerned about deleting Roon completely and starting from scratch, but every single album I import continues to be duplicated. This has been a major problem, but I can’t seem to see anything in the settings that will correct this issue. I can’t imagine that others haven’t experienced this recently, but please let me know if there is an option other than deleting it all.

Hi @Mark_Miles ---- Thank you for touching base with us and providing an update on the situation you reported here.

Moving forward, just so I have a better sense as to what you are working with, may I kindly ask you to please provide the following information:

  • A brief but accurate description of your current setup using this link as a guide.

  • Please provide me with a screenshot of your “storage” tab highlighting all of your active watch folders.

Additionally, other than starting with a completely fresh DB the other potential option here in addressing this behavior would be to try and restore from a backup that was created before the issue occurred. However, my concern with this approach is that you had reported this issue a year ago so trying to restore from a backup is basically going to bring your setup back to where it was a year prior.

-Eric

Hello Eric,

I’ve attached a screen shot of the storage tab for you and I hope this will help.

Please let me know if it offers any insights.

Thanks,
Mark

Hi Eric,

As for my set up, I simply have Roon and all of my high Rez audio files on my iMac computer.

Thanks,
Mark

Eric,

I am still having every album I download duplicate on your site. This is so frustrating and has created such a mess. Here is a screenshot of the path of one recent album I’ve added.

Mark

It seems to me that, as you surmised earlier, you are duplicating your file locations. One of your earlier screenshots showed 3 locations and the total number of tracks imported from This Mac was 4226 which equals the 2025+2201 from the other two locations.
Your last screenshot implies to me that your Music and iTunes locations are indeed covered by the This Mac location.

A simple, non-destructive, test is to go to Settings > Storage and, via the 3 dots_ disable the other two locations (Music and iTunes). This is easily undone by selecting enable afterwards if you wish.

EDIT I see you are using the old way of importing iTunes. This has changed (see KB article). I don’t use iTunes myself, so am unsure whether your folder location needs to be specified separately. If so, then try disabling the This Mac location instead.

Hi @Mark_Miles – Can you share an updated screenshot of Settings > Storage?

Hi Dylan,

Here you go:

Dylan, I wanted to make sure you received the screenshot of the following (please comment, as I’ve got to get this resolved):

If I can somehow get the duplication of albums to stop, how do I then get rid of the large number that I now have? Mark

As others have suggested, you need to disable (via the three dots) the duplicate storage location (which seems to be the second one listed), or as BrianW said, disable the first and third locations.
When you nest file locations like this, Roon interprets this as “Okay, you want me to import the same file from the first location AND the second location”. Hence your duplicates.

Settings>Library>Library Maintenance>Clean Up Library>Clean up 4723 files that are associated with disabled storage locations (or whatever that large number is)
This should allow you to remove the duplicates from being displayed.

When you disable a location, nothing is deleted. Roon just isn’t paying attention to that location anymore. So don’t be reluctant to stop watching those folders. Once you’re convinced you’ve solve the problem, you can delete those file locations in Settings>Storage (which also doesn’t touch your files)

Hi @Mark_Miles

As mentioned by others previously, it looks like you have some duplicate watched folders. Here’s what I suggest:

  1. Make a backup
  2. Disable the first and third folders
  3. Reboot your Core
  4. Let us know if this resolves the issue for you

Thanks!