ExFat drives aren't accessible from ROCK in case of mounting via SMB [Fixed, B156]

I’m running the latest Roon Core s/w on an Intel NUC. My Macbook Pro also is running the latest Roon Remote s/w on a MacBook Pro on the latest MacOS.

I additionally listen to Podcasts. My approach is to download using iTunes on the MBP, convert to FLAC and copy to the remotely connected (SMB) storage/Podcast folder on my USB SanDisk stick connected to my Core.

This approach has worked from day one. Nothing has changed on my network or hardware. Honestly!

I can still drop the flac files onto the Roon application but I do prefer to connect to the Data server using SMB as a Guest.

I have rebooted the Core and Remote devices

Any ideas?

This is new…simply wanted to copy to the music drive but access denied. Any clues as to why?


@Powered_Two_Wheeler and @Wdw ----- Thank you both for the feedback and sorry to hear of the troubles here. Warren, I moved your post over to this thread because it sounds like you are experiencing the same issue.

Moving forward, I had a chance to discuss this behavior with the team today and as per the conversation we would kindly like to ask you both to please unmount ROCK on the OS level and then using the “connect to server” feature, re-establish the connection and verify if this action yields a change in behavior.


Hello Eric, In Finder I ejected ROCK so assumed this is the unmount. Then used “connect to server” as requested, logged in as “Guest” but once re-established the drives are still flagged as locked. See screen shot below.

Just updated Rock, MacPro (remote) to latest, rebooted all, and tried to attach Rock to MP. It was successful, but both drives in Storage “can’t be opened because you don’t have permission to see its contents.” MacOS system message.

I’m stumped. Any ideas? Thx

Hi Eric,

Me too.

Cheers, Greg

Eric, Thank you for picking this up. Unfortunately after de-mounting and remounting the drive I still get the same error.

All ---- Thank you for the feedback and giving the proposed test a go.

Just to bring everyone up to speed, our tech team is currently looking into this behavior to try and understand what may have happened here. I will be coordinating with the team so I can keep everyone up to date on their progress.

Please rest assured that this is on our radar and as always we will do our best to get this sorted as quickly as possible. Thank you for your patience while we conduct our investigation.


Hi Guys,
This is my first post in this community.
This issue is connected to SMB protocol. Please try to type cifs://rock in Connect to Server… option in Finder - this is workaround, but this connection is slower (SMB ver. 1). From the last Rock version we have faster SMB protocol ver 2. But in my case I have this issue too.
Than when you try to connect to rock server in ordinary way, through Shared area in Finder everything starts working in good way.
I will come back home in Saturday and will check more posibilities,


He’s right! Over to you Roonies

Hi @Eric
FYI, same issue here. If I’m not mistaken, this issue started after the update to Roon OS 1.0 build 153 in Rock
Hope we’ll find a turnaround

I’m running ROCK on a Nuc, with a WD MyBook USB drive attached. The Nuc is connected via ethernet to a WiFi access point. I use a Macbook to access the MyBook for adding files, etc.

ROCK OS: Version 1.0 (build 153) stable
Roon Server Software: Version 1.4 (build 298) stable

This morning I went to add files and received a message that I don’t have permission to access the folder: The folder “My_Book_WD_My_Book_25EE_3753475532583743_2A27-BFEB-p1” can’t be opened because you don’t have permission to see its contents.

I verified in Finder that I do have the required permissions, and spent about 30 minutes on the phone with Apple support. They are stumped and we have a follow up call tomorrow morning.

Any ideas? Music plays just fine, so Roon is able to access the data. I just can’t access the data to add/move/delete, etc.
I’ve never had an issue accessing the Nuc’s attached USB drive through Finder. All other folders on the Nuc are accessible. If I connect the MyBook directly to my MacBook I have no problem accessing my files.

@support I believe that SMB2 support was added to ROCK and maybe there is something causing your drive access to be different?

How are you accessing it? Via a favorite link? If so maybe it’s time to remap the connection and see if that helps.

Prior to today, I’ve accessed the drive by navigating to ROCK in Finder (it shows under “Shared”), then Data/Storage/Mybook. Now when I try to follow that path, I receive the error. It not an SMB connection to the best of my knowledge.

Hi Robert,
In the first step you have to connect to Rock server using SMB protocol ver 1. In this case use not Shared, but manual way of connection - in Finder go to Go than Connect to Server… command cifs://rock in my case smb://rock doesn’t work. Than check if you have access to your hard drive in Storage. If everything works fine, disconnect and connect again, this time using rock server in Shared. In this moment you should use SMB2, but I’m outside my home till Saturday and I can’t check. It is easy to find out using command “smbutil statshares -a” in Terminal after connection to server.
I have ROCK OS: Version 1.0 (build 153) and on my MacBook Pro High Sierra 10.13.3, but on my two Macs with older High Sierra version is the same. Everything change with update to Rock OS ver 153 or I’m wrong and the problem lies in MacOS and exactly Apple’s SMB version.

Greetings from Poland

Thanks Piotr. When I open Finder, Rock shows up automatically. When I select it, it connects automatically and I see a folder called “Data”. Attempting to connect via SMB://rock or cifs://rock has no effect.

I just updated to the newest OS build 155 which was released a short time ago (today). Now I can’t access the root “Data” folder at all. . .it can’t be found.

00 PM

@Robert_Siegel ----- Would you kindly try the following and let me know if it yields a change in behavior with the “data” folder. See below.

  • In “finder” select “GO” and then, “connect to server”

  • Once the “connect to server” window is open please use the following to connect the share:

    cifs://IP of your ROCK machine/data


Hi Eric,

I just tried that and while it looks like something happened, the Finder display does not change. When I select Rock, I see “Data” but still receive the message that “Data can’t be found”.


I shut down my Nuc, and rebooted my Macbook. Went to finder and followed your suggestion. All seems to be working now. I no longer receive the error when attempting to access “Data” and I can now access the MyBook.

If I reboot both the ROCK and my iMac as per your advice the fix “cifs://IP of your ROCK machine/data” works for me but when following Piotr’s second step to initialize with SMB2,

“If everything works fine, disconnect and connect again, this time using rock server in Shared. In this moment you should use SMB2”

the drives are, once again, locked down.

Obviously a software issue from the last update.