Export uses a "comma" delimiter for artist name rather than a "semi-colon" [Ticket Open]

On export roon uses a “comma” as a delimiter in the artist field instead of the “semicolon” I have in my tags. It also puts a “forward slash” as a delimiter in the album artist field. My tags also have a “semi-colon”.

It also doesn’t keep the folder structure. In this example it is a double disk so in my directories I have a CD1, CD2 structure but roon has made a flat single CD structure. This is awkard enough but it becomes a problem with a big box set.

When I re-import into another roon for travel, which was the whole point of the exercise I get a long concatenated artist name because the delimiter is wrong. Means I have to re-tag the files to get separate artist names. Have I missed something? Should roon be doing this?

Thanks for the report and sharing this observation you have made with us @tripleCrotchet , very appreciated!

Moving forward, I have passed your feedback over to our tech team for evaluation/testing. Once I have an update on their progress I will be sure to follow up with asap.

Your patience is appreciated!
-Eric

Thanks for taking a look @Eric. Appreciated.

I have raised a few support tickets that are related to this, although it might not look like it, as it is all about travelling with roon. One important thing is DLNA for those that prefer not to carry a bunch of stuff around. DLNA is often available on many consumer devices. Things like a modern smart TV in a hotel room or a simple stereo at a non-audiophile colleagues apartment. I know roon is not interested in supporting DLNA but JRiver does and it is also possible to get chromecast working this way using JRiver as an intermediary, much like HQPlayer.

Roon detects the JRiver ASIO so this in principle is a simple solution for those who still have JRiver licences. I have the impression from old threads this worked at some time. Is that still the case or have I missed a configuration step? I raised a separate thread here:

Hi @tripleCrotchet ----- Touching base to let you know that our tech team has reproduce this behavior you’ve reported when using the export function in the application. A ticket has been opened which is currently with our DEV team.

I will be sure to update this thread again once I have some feedback from the team on their progress. Your patience is very appreciated.

-Eric

Note: In regard to your other post I am discussing with the team and will be making my way over “there” shortly :wink:

Thanks for that.

On the second point. I only mentioned JRiver ASIO initially because by default that is all you see as a discovered device in roon. I had not realised that has changed since roon’s initial experiments from 2015. WDM is no longer on by default in JRiver and there are other issues so you only see JRiver WDM in roon after first enabling it in Jriver.

From those old threads from 2015, I don’t think there was RAAT, and it seems to have been hit and miss. Some reported success playing around with the buffers and got this working:

a) roon -> WDM -> JRiver -> DNLA

I have actually got this working (playing around with the buffers)

b) roon -> RAAT -> WDM -> JRiver -> System Out

So I can for example browse with roon and listen on good headphones to JRiver DSP

I have also got this working:

c) JRiver -> BubbleUPnP -> DLNA -> Chromecast

So now I browse with roon but then do a search on JRiver to actually play. What I would really like to do is:

d) roon -> RAAT -> WDM -> JRiver -> BubbleUPnP -> DLNA -> Chromecast

What I see when I do this is that everything seems to be working normally. Roon waveform is normal, roon plays the queue normally. An LPC stream arrives normally at JRiver, there is just no sound. It is the same behavior with another DLNA device I have lying around (a Toshiba BDX3400SE Blu-ray player).

I know roon is not interested in DNLA and I totally get that but if this could be got to work as it appears to have in the past it provides an option that would be very interesting to those continuing to use JRiver (a bit like those continuing to to use HQPlayer which is what I do at home).