Facebook and Twitter access suddenly stopped [Resolved]

@Support. After yesterday’s update to Roonserver 1.3 (build 234) 64Bit the social media functions have stopped working.

Linux is 16.10 Ubuntu Server (amd64)
MSI Cube N Booting on 128GB MSATA card
Music stored on (900 or so LPs – all FLAC) duped oover 2 x 1TB USB Drives - No Tidal.

Client/Remotes are Android 4.4.4 HP 17" Slate and Android 5.0 Moto X Style Phone – both on Roon 1.3 (Build 233 - 32Bit)

I see no way to re-request authorisations as the Authorizations View button under extensions reveals nothing but a “Done” close button and the “Get a new PIN for Twitter” underlined section doesn’t work so I cannot reauthorise it if I wanted to. I cannot even download the link to the Imigur…

Links to Dropbox work, however.

Get Shared Link to Imigur gives this:

Twitter “I Need a PIN” link does not work.

Nothing I can do with Facebook. Just Try again. Repeated attempts all end here.
Tried Removing Roon as Authorised on Facebook (and Twitter) and does not change this box.


Sorry if this is a n00b error or discussed elsewhere. I like spamming my feed with music listenings. Roon has been flawless but I always gulp a bit when I see the updater popup these days.

“Save to Downloads” works…

Hi @PunkPonyPrincess ---- Thank you for the report and sharing your feedback us, both are appreciated!

We are going to be taking a look into this behavior, to see if we can reproduce in house. Once my QA team has updated my report with their thoughts/findings I will be sure to update this thread accordingly. Your patience is appreciated!


Hi @PunkPonyPrincess — Thank you for your patience.

I wanted to provide you with an update as our QA team has been able to reproduce this behavior and a ticket has been take out, which is currently with our developers who be continuing the investigation from here. As I receive more feedback I will be sure to keep you up to date with our progress.


That’s good news (well not good, but glad my experience is validated)

Is there any interim fix that can help me regain social media postings? Such as deleting an authentication file or altering a configuration file to return it to setup state?

Hi @PunkPonyPrincess ---- Thank you for the follow up and touching base with me, both are appreciated.

Our developers are on the case and understand what the issue is here. Once they have a fix set into place I will be sure to update this thread promptly.

In the meantime, this feature is still working on IOS, OSX, and Windows. If possible I would recommend (temporarily) doing any social media sharing from a non Android based device.

We appreciate your understanding and most importantly your patience while we work through this issue.


Can’t seem to share on Facebook anymore. I keep being asked to Re connect. I have supposably done this three times but still no success. Just round and round the loop. Copy link works fine as does Twitter.

You still having problems here @Chrislayeruk?

@PunkPonyPrincess – we believe this should be fixed for the next release. Thanks for your patience.

Just tried it and it is working. Thanks.

1 Like

I wouldn’t know. I left Twitter and Facebook shortly after logging my discovery (binning all of the other “social media” services) remembered what life without it was like. Still like Roon as a media player but there are so many conduits to be surveilled via one’s hardware, I’ve all but stopped using phones and tablets.

1 Like

This topic was automatically closed after 29 hours. New replies are no longer allowed.