Failed authorise connect to Synology NAS


I’ve just dowloaded Roon, set up my roon server on a MacBook and have stored music on a Synology DS216+
I’ve entered the smb path : smb://SynoJP/music
My user name and Password which, I have verifed work
Even put the workgroup just in case even though it’s the default
And when I hit “Add network share”, all I get is a failed message “unable to connect, unauthorised”

I went to my NAS to check folder permission and then seem to be ok for my user.
I’ve upgraded the smb range to smb3 as I saw recommended on this forum ( if I read properly )
Is there any settings in smb or whatever permission that I should look into to solve this ?


Have you tried doing the same thing from your MacBook, i.e. connect to that share using ‘Connect To Server’ in Finder?

Yes of course
It’s been connected for a while and can access the file in there from the finder

Have you already seen this post?

Does Mohammed’s solution work for you?

Just in case : I’m using the same user/pwd I’m using to connect to the NAS through the web interface
Should be the good one, right ? :slight_smile:

When I type \\SynoJP\music, it says unauthorized
When I type \SynoJP\music or \\192.***.*.***\music it says “There was an un-expected error: UnexpectedError”

Have you tried \\SynoJP.local\music?

I had, and just did again : unauthorised :roll_eyes:

Unauthorized normally means: The client could reach the server, but he doesn’t let him access the share because he’s not allowed to.

Any permission or preferences in the NAS I should change ?
In shared folders, file services or external access
My config is pretty much default ( just plugged the NAS and sarted using )

Hi Jean-Paul,
I’ve moved this over to Support so they can help you. There have been several problems with connecting to Synology lately as @BlackJack mentioned. Support may have more insight into how to get you going.

Thanks mate !!

Hi @Jean-Paul_GAUTIER,

Thanks for reaching out to us here. Hmm, it is strange that Roon was unable to connect to the share via IP address, have you made sure to add Roon as an exception to the Macbook firewall? I would use these instructions from Apple to double check, as well as allow Roon past any other application firewalls you may have (Bullguard/Little Snitch/McAFee have all caused similar behavior in the past).

Are you sure the MacBook is using smb to connect to the NAS? I had a similar issue, with another NAS brand. I think Macs prefer to use apfs or something like that.

  • two backslashes server\share
  • smb://server/share
    did not work for me
    Although the Mac could see the NAS, Roon could not.

Thanks for the tip
Apple firewall is set up to allow Roon
Will have to check my Intego software though ( when I reach home tonight )

1 Like

Have you checked the logs on the Synology itself? Does it report the user attempts? Perhaps that will give a clue why it thinks the login is unauthorized.

Hi @Jean-Paul_GAUTIER,

One other thing that came to mind here other than checking the firewall - if you create a new folder share on the NAS as a temporary test, does that folder also display similar behavior? It would help clarify if there is a permissions issue with just the \music share.

No logs in the Synology Log center :confused:

I did check to connect to the video folder, same behaviour

Doesn’t seem like I can create an new folder outside the Home folder
I have no admin user ( it’s disabled ). Is that an issue ?
When I do access the music folder via the finder, I do see a log that I accessed it with the user JP Gautier … so the above should not be an issue, right ?

Not sure wether it is relevant, but when I put afp://SynoJP.local/music , it returns "unexpected error "