No longer connecting to SMB shares on Synology via Hostname

@support

Yes I’ll try adding some shares using the method above tonight and will report back

1 Like

Sorry, no joy

Also “We have reviewed the diagnostics and it appears that the behavior of the NAS failing to connect via Hostname occurred before your ROCKs have been updated”; I’ve had a few weekends away recently and usually switch of the NAS drives but not always the ROCK. It could be that the fail to connect that you see in the log files are while I’ve had the NAS drives switched off.

Hi Noris,
I just tried and it works. I haven’t added any specific music folder but \MusicNas.local\music does show as a valid network share and all the subfolders show up.
Regards,
Mario

1 Like

Thank you for confirming @Mario_Bucco.

@Mohammed_Samji/@Daniel_Blount - Can you please give this a try when you have a chance?

@Phil_Jeremiah - Is the behavior the same if you try smb://Synology_Music.local/HD Music?

Thanks,
Noris

No access for a week. Will try when I return

1 Like

@support

Here is today’s testing.

Setup

  • Roon ROCK on my INTEL NUC. No changes outside of upgrading to Build 175
  • Synology NAS - with the latest update
  • Both are WIRED and on the same UBIQUITI Switch

SMB Shares

  • The two shares I connect to are:
    \MSamji-NAS\Music
    \MSamji-NAS\HiRezMusic

As a starting point:

  1. I deleted these from ROON since I had to use the IP Address to connect

Now let’s try to reconnect so you can get the logs from my device.

Today’s Steps

  1. Remove the shares from the Roon

  2. Confirm the SMB Shares work via HOST NAME

  • From a Windows I can successfully connect to:
    \MSamji-NAS\MUSIC
    \MSamji-NAS\HiRezMusic
  1. NOW let’s add them in ROON
  • From Roon I try to ADD
    \MSamji-NAS\Music

  • It fails. The error is “There was an un-expected error: UnexpectedError”

  • Then I try to ADD
    \MSamji-NAS.local\Music

  • THAT WORKS INSTANTLY!

I repeat the process for the other share
\MSamji-NAS\HiRezMusic

  • It fails
  • Then I try to ADD
    \Msamji-NAS.local\HiRezMusic
  • THAT WORKS

To Summarize with Roon

Previously I could always Connect with:
\MSamji-NAS\Music

That no longer works. BUT I CAN CONNECT WITH
\MSamji-NAS.Local\Music
\IP Address\Music

Hi @Mario_Bucco/@Mohammed_Samji,

Thank you for confirming that the .local address works as expected. I have reached out to QA regarding this update and they have suggested that we take a look at a few surrounding factors to see if we can get the original hostname to work again:

  1. We have done some research and this issue may occur when NTP time servers are out of sync. Can you please verify the following aspect?

Navigate to “DSM> Control Panel> Regional Options> NTP Service” then enable NTP. Then in the same window go to the “Time” tab and set the server address to your domain controller (DO NOT use any of the pull-down options!!!) click Apply then click “Update Now” to synchronize with the NTP server.

  1. There is an option to clear SMB cache under ‘File Services > SMB/AFP/NFS > SMB > Advanced Settings > Clear SMB cache’. Can you please give this a try and let me know if you are able to connect via regular hostmane after clearing this cache? Note: Do not use the .local share name but rather the original one after performing this cache clear.

  2. After both of the above tests, can you reboot your NAS and verify if rebooting the NAS triggers any change in behavior?

Hi Noris,
I’m not sure what you mean by “set the server address to your domain controller”. To be honest I don’t know what the domain controller is.

Since I use this NAS with things other than Roon and everything other than Roon works fine with using the hostname, I’m reluctant to make changes that could adversely affect that. At this point I’ve restored my library using the IP address and Roon is working fine now.

Regards,
Mario

Hi @support

Here is what I did tonight.

  1. IN ROON -> I removed one of my SMB Shares
    Specifically I removed in ROON -> \msamji-nas.local\music

  2. IN SYNOLOGY -> I cleared the SMB Cache
    Specifically -> ‘File Services > SMB/AFP/NFS > SMB > Advanced Settings > Clear SMB cache’

Now, I tried adding the SMB Share back

I tried -> \MSamji-NAS\Music
AND it failes just like before

I tried -> \MSamji-NAS.local\Music
AND it works

So no difference by clearing the SMB Cache

Ideas? Everything worked with no issue pre-Build 175 :frowning:

Hi @Mario_Bucco/@Mohammed_Samji,

Thanks for confirming.

@Mario_Bucco - If you don’t wish to troubleshoot this further and everything is working, I can’t force you to.

@Mohammed_Samji - Can you please take a look at the NTP time aspect?

For clarification: The server address to your domain controller would be the IP address of your primary router in this setup. Thanks!

Hi Noris,
Ok, now that I know what the domain controller is I tried it following your earlier directions. In the NAS when in TIME when setting the server address to my router’s address I received a message from the NAS that there was an error. I went ahead and followed your directions and completed all the steps. I was not able to add ||MusicNAS\music in Roon storage. It came up unexpected error. I rebooted the NAS as you requested and again was not able to add \MusicNAS\music. I got the same message in Roon, unexpected error.

I’m willing to try to help you folks resolve the issue but I don’t want to brick my NAS.

Regards,
Mario

@support

Since Mario tried ntp fix and it didn’t work, I assume I don’t need to.

I did try clearing the SMB cache and that didn’t work.

Im general, like Mario I don’t want to tweak my NAS. It works with every other device in my home outside of my Roon Rock. I really would love to see a fix from Roon… Since this didn’t repro before build 175.

We have been patient :slight_smile:

Mohammed, you might try the NTP fix, that I got an error message from the NAS when entering the router IP as the server address doesn’t mean you will also. It’s also easily reversible.

Noris, I forgot to add I also cleared the SMB cache after resetting the NTP.

Regards,
Mario

4 posts were split to a new topic: Folders from 2nd NAS backup not showing up

@support Any updates? I’d love to see any potential fix for this from Roon is possible?

I am not seeing a repro from any other device in my house that connects to the Synology. They all work fine with \name\share

My Roon is currently humming along with the work around of \name.local\Share

thank you!
-Mohammed

Hi @Mohammed_Samji,

Thanks for your continued interest in this issue. There is an active ticket with the QA team but no additional updates at this time.

One key piece of information here is if the .local workaround works for everyone affected by this behavior. I know that you and @Mario_Bucco have confirmed that it works, but if @Phil_Jeremiah & @Daniel_Blount can confirm it would be a useful data point to have. Thanks!

Back from holiday. Tried “smb://Synology_Music.local/HD Music” and “\Synology_Music.local\HD Music” and got “Invalid path specified” back.

Just to confuse matters further, my library increased in size and it appears that the “\Synology_Music\Music” link reconnected all on its own (I’d left one of the folders in place just in case). Unfortunately when I try to add the “\Synology_Music\HD Music” back in it doesn’t get accepted and as you can see from the above I can’t reconnect to the address.
Stranger and stranger…
Regards

Hi @Phil_Jeremiah,

Thanks for confirming that the .local address did not work.

This would seem like some kind of permissions issue to me, do the two shares have the same permissions? If you try to create a new folder, does that get added to Roon properly?

Is WS-Discovery enabled by default? If not, does enabling it help?

'> Is WS-Discovery enabled by default? If not, does enabling it help?
It wasn’t. It is enabled now. No, it doesn’t fix it.