No longer connecting to SMB shares on Synology via Hostname

(Mario Bucco) #23

Hi Noris,
The router is a Verizon Fios Quantum and I’m using a Verizon Fios Network extender and Motorola MM1000 moca adapter. Both of these are connected to the Quantum router via the same coax cable run and are on the same network.

The NAS and Roon Rock are using 2 different switches. Both are connected to the switches via ethernet cables. The NAS switch is connected directly to the Fios Network extender and the Roon Rock switch is connected directly to the moca adapter.

I am able to access the NAS shares via Hostname from computers, both Windows 10 & Ubuntu 18.04, connected to both switches and via WiFi. I can also use J River MC25 to play music with no problem and it’s library access the NAS using Hostname rather than IP address.

I am also seeing frequent problems with the ROCK losing connection to the Windows 10 pc on the same switch as the NAS. The Windows 10 pc is also connected via ethernet. I’m working on rebuilding the Roon database for my music and as a result have not been doing much listening to the system connected to the same switch as the ROCK, so I don’t know if there are instability issues there as well.

Prior to the most recent Roon update my system worked flawlessly. To say I am disappointed with Roon at the moment is an understatement.

Regards,
Mario

Issues accessing ROCK (OS175) from Windows 10 Remote
(Daniel Blount) #24

1 - Router: UniFi Security Gateway
2 - NAS and ROCK are direct Ethernet to the same switch
3 - Yes, the rest of the network can see the NAS folders with //diskstation/

(Mohammed Samji) #25

@support

I’m identical to @Daniel_Blount

  1. Router - UniFi Security Gateway (latest firmware. Firmware updated about 2 months ago)
  2. Switch - Unifi 8 port switch (atest firmware. Firmware updated about 2 months ago)
  3. Synology - Updated to 6.2.2 Update 2 (on the same day as my Roon Rock with to Build 175)
  4. Roon Rock - Version 175

Both my Synology and Roon Rock (on an Intel NUC) are on the SAME Unifi 8 port switch with wired connections.

The Synology actually has 2 Ethernet Connections from it to the UniFi in a BOND

Windows Explorer can access the SMB Shares on my Synology with:

  • \MSamji-NAS\Music

Roon Rock used to work. NOW

  • \MSamji-NAS\Music is no longer accessible.
  • I deleted the share and tried to add it back. no go.

BUT on the Roon ROCK, I was able to add back the SMB share with the IP Address
\192.168.1.178\Music

Roon Rock -> Synology has worked for over a year with no issues.

The only changes this week were:

  • Roon Rock - Went to Build 175
  • Synology also took an update to 6.2.2. Update 2
(Phil Jeremiah) #26

noris, please see answer in new post that addresses all of these points. Thanks

(Noris) #27

Hello All,

Thank you for providing that information. I have gone ahead and activated diagnostics mode for your accounts and what this action will do is automatically upload a log set to our servers for analysis.

I have submitted these to QA for review and when I have any new information to share I will be sure to update you here. If connecting via IP address is working as expected, I would suggest to use this method for the time being.

(Mario Bucco) #28

Hi Everyone,

In a separate thread Noris was helping me get my files back into Roon with my original edits. Something Noris said clicked and I tried something that worked. You will have to relink your NAS to Roon using the IP address but before you import the files by adding a folder remove the old folder/file location from Roon storage. For example, belore adding the folder CD’s using the IP address of your NAS remove the hostname version of the folder \MusicNAS\music > CD’s. It’s worked for me to get all of my metadata edits back. As a caution make sure you do a backup before trying this.

Regards,
Mario

1 Like
(Noris) #29

Hello All,

I appreciate your patience while QA has been reviewing the diagnostics from your Cores.

@Mario_Bucco/@Daniel_Blount/@Phil_Jeremiah - We have reviewed the diagnostics and it appears that the behavior of the NAS failing to connect via Hostname occurred before your ROCKs have been updated to the latest OS, so it is possibly not related and a red-herring.

@Mohammed_Samji - We have diagnostics mode activated but your Core seems to have not delivered any log set so we cannot confirm if this is the same surrounding factor.

In either case, QA would like to perform a test here to gather some other useful information. Can I please ask you all to try to add the share via a .local hostname and let me know if this works?

Please keep in mind that this would only be a test to hopefully gather some more information surrounding this issue, and this is not suggested to be a permanent workaround if it works.

From what I have gathered in the case notes it would be as follows:

@Mario_Bucco - \\MusicNAS.local\music
@Daniel_Blount - \\diskstation.local\music
@Phil_Jeremiah - \\Synology_Music.local\HD Music
@Mohammed_Samji - \\MSamji-NAS.local\Music

Can you try adding these storage locations as the share to Roon and let me know if the NAS is accessible this way?

(Mohammed Samji) #30

@support

Yes I’ll try adding some shares using the method above tonight and will report back

1 Like
(Phil Jeremiah) #31

Sorry, no joy

Also “We have reviewed the diagnostics and it appears that the behavior of the NAS failing to connect via Hostname occurred before your ROCKs have been updated”; I’ve had a few weekends away recently and usually switch of the NAS drives but not always the ROCK. It could be that the fail to connect that you see in the log files are while I’ve had the NAS drives switched off.

(Mario Bucco) #32

Hi Noris,
I just tried and it works. I haven’t added any specific music folder but \MusicNas.local\music does show as a valid network share and all the subfolders show up.
Regards,
Mario

1 Like
(Noris) #33

Thank you for confirming @Mario_Bucco.

@Mohammed_Samji/@Daniel_Blount - Can you please give this a try when you have a chance?

@Phil_Jeremiah - Is the behavior the same if you try smb://Synology_Music.local/HD Music?

Thanks,
Noris

(Phil Jeremiah) #34

No access for a week. Will try when I return

1 Like
(Mohammed Samji) #35

@support

Here is today’s testing.

Setup

  • Roon ROCK on my INTEL NUC. No changes outside of upgrading to Build 175
  • Synology NAS - with the latest update
  • Both are WIRED and on the same UBIQUITI Switch

SMB Shares

  • The two shares I connect to are:
    \MSamji-NAS\Music
    \MSamji-NAS\HiRezMusic

As a starting point:

  1. I deleted these from ROON since I had to use the IP Address to connect

Now let’s try to reconnect so you can get the logs from my device.

Today’s Steps

  1. Remove the shares from the Roon

  2. Confirm the SMB Shares work via HOST NAME

  • From a Windows I can successfully connect to:
    \MSamji-NAS\MUSIC
    \MSamji-NAS\HiRezMusic
  1. NOW let’s add them in ROON
  • From Roon I try to ADD
    \MSamji-NAS\Music

  • It fails. The error is “There was an un-expected error: UnexpectedError”

  • Then I try to ADD
    \MSamji-NAS.local\Music

  • THAT WORKS INSTANTLY!

I repeat the process for the other share
\MSamji-NAS\HiRezMusic

  • It fails
  • Then I try to ADD
    \Msamji-NAS.local\HiRezMusic
  • THAT WORKS

To Summarize with Roon

Previously I could always Connect with:
\MSamji-NAS\Music

That no longer works. BUT I CAN CONNECT WITH
\MSamji-NAS.Local\Music
\IP Address\Music

Failed authorise connect to Synology NAS
(Noris) #36

Hi @Mario_Bucco/@Mohammed_Samji,

Thank you for confirming that the .local address works as expected. I have reached out to QA regarding this update and they have suggested that we take a look at a few surrounding factors to see if we can get the original hostname to work again:

  1. We have done some research and this issue may occur when NTP time servers are out of sync. Can you please verify the following aspect?

Navigate to “DSM> Control Panel> Regional Options> NTP Service” then enable NTP. Then in the same window go to the “Time” tab and set the server address to your domain controller (DO NOT use any of the pull-down options!!!) click Apply then click “Update Now” to synchronize with the NTP server.

  1. There is an option to clear SMB cache under ‘File Services > SMB/AFP/NFS > SMB > Advanced Settings > Clear SMB cache’. Can you please give this a try and let me know if you are able to connect via regular hostmane after clearing this cache? Note: Do not use the .local share name but rather the original one after performing this cache clear.

  2. After both of the above tests, can you reboot your NAS and verify if rebooting the NAS triggers any change in behavior?

(Mario Bucco) #37

Hi Noris,
I’m not sure what you mean by “set the server address to your domain controller”. To be honest I don’t know what the domain controller is.

Since I use this NAS with things other than Roon and everything other than Roon works fine with using the hostname, I’m reluctant to make changes that could adversely affect that. At this point I’ve restored my library using the IP address and Roon is working fine now.

Regards,
Mario

(Mohammed Samji) #38

Hi @support

Here is what I did tonight.

  1. IN ROON -> I removed one of my SMB Shares
    Specifically I removed in ROON -> \msamji-nas.local\music

  2. IN SYNOLOGY -> I cleared the SMB Cache
    Specifically -> ‘File Services > SMB/AFP/NFS > SMB > Advanced Settings > Clear SMB cache’

Now, I tried adding the SMB Share back

I tried -> \MSamji-NAS\Music
AND it failes just like before

I tried -> \MSamji-NAS.local\Music
AND it works

So no difference by clearing the SMB Cache

Ideas? Everything worked with no issue pre-Build 175 :frowning:

(Noris) #39

Hi @Mario_Bucco/@Mohammed_Samji,

Thanks for confirming.

@Mario_Bucco - If you don’t wish to troubleshoot this further and everything is working, I can’t force you to.

@Mohammed_Samji - Can you please take a look at the NTP time aspect?

For clarification: The server address to your domain controller would be the IP address of your primary router in this setup. Thanks!

(Mario Bucco) #40

Hi Noris,
Ok, now that I know what the domain controller is I tried it following your earlier directions. In the NAS when in TIME when setting the server address to my router’s address I received a message from the NAS that there was an error. I went ahead and followed your directions and completed all the steps. I was not able to add ||MusicNAS\music in Roon storage. It came up unexpected error. I rebooted the NAS as you requested and again was not able to add \MusicNAS\music. I got the same message in Roon, unexpected error.

I’m willing to try to help you folks resolve the issue but I don’t want to brick my NAS.

Regards,
Mario

(Mohammed Samji) #41

@support

Since Mario tried ntp fix and it didn’t work, I assume I don’t need to.

I did try clearing the SMB cache and that didn’t work.

Im general, like Mario I don’t want to tweak my NAS. It works with every other device in my home outside of my Roon Rock. I really would love to see a fix from Roon… Since this didn’t repro before build 175.

We have been patient :slight_smile:

(Mario Bucco) #42

Mohammed, you might try the NTP fix, that I got an error message from the NAS when entering the router IP as the server address doesn’t mean you will also. It’s also easily reversible.

Noris, I forgot to add I also cleared the SMB cache after resetting the NTP.

Regards,
Mario