No longer connecting to SMB shares on Synology via Hostname

(Mohammed Samji) #1

Roon ROCK on Intel NUC

Upgraded to the new Build 175 CORE

Now my ROCK will no longer connect to the SMB Shares on my Synology.

Rebooted the synology
Rebooted the Rock

Deleted the SMB shares

and now trying to add them back. Now I can add them. I get an error.

I get “There was an un-expected error Un-expected Error”

But my ROCK can successfully use TIDAL and QOBUZ and stream. Just no SMB. Both the synology and ROCK are sitting side by side on the same switch.

@support please help

Nucleus won’t see/reconnect to NAS
Roon not recognizing NAS Drive or Computer Hard Drive
Setting up NUC as ROCK
Nucleus won’t see/reconnect to NAS
(Mohammed Samji) #2

ok, I finally managed to add the SMB shares back, but had to use the IP Address of my Synology

Normally I can use \msamji-nas\Music from the ROCK

From my Windows PC I can:

  • Successfully resolve \MSamji-NAS\Music

But from the Rock, the only way I could get it to resolve was to use the IP address -> \192.168.1.87\Music

Weird since nothing changed on my network

(Mr Fix It ) #3

is your router listed in the DNS settings?

(Alfred van Hoorn) #4

Have you recently updated to DSM 6.2.2 Update 2? This update has a bug with SMB. See this link an this one

(Noris) #7

Hi @Mohammed_Samji,

Can you please confirm if you have DSM 6.2.2 Update 2 installed?

This is the first I am hearing of an SMB issue, so it would be good to figure out what exactly happened here (thanks for sharing those links @Alfred_van_Hoorn).

If it was just the ROCK OS that was updated to the newest build, and you’re still running an older DSM version, that would be good info to know.

(Mario Bucco) #8

Hi Noris,

I woke up this morning to the same issue. My Synology NAS DS218+ was updated to DSM 6.2.2 Update 2 on Monday morning. On both Monday and yesterday Roon Rock was performing normally. I believe that sometime last night the Roon Rock updated to the current build and this morning Roon Rock no longer could connect to \MusicNAS\music. Like Mohammed it will connect to the IP address.

Regards,
Mario

(Mohammed Samji) #9

Yes I just confirmed my synology took an update to 6.2.2 update 2.

This looks like it’s related to the synology update.

(Alfred van Hoorn) #10

This morning there were new posts in the Synology forum. It is not a bug in the firmware update, but a erratic line in a config file. See this link

(Mario Bucco) #11

Hi Noris,
I’ve been in touch with Synology support & they had me run some tests. I used a Windows 10 pc, a pc running Ubuntu 18.04 and J River on a Windows pc. All of them were able to access the Synology DS218+ using \MusicNAS\music with no problems. For me the issue appears to be limited to the Roon ROCK. The Synology NAS and Roon ROCK are both using wired connections.
Regards,
Mario

(Mohammed Samji) #12

I’m the same as you Mario. Only the Roon Rock can’t access the share.

But if I use the ip address it works on the Rock.

(Mr Fix It ) #13

I have roon rock and while neither nas nor Nuc have been restarted since the ds update I have no issues accessing shares on the nas. Backups are done to another synology nas and also no issues. I only ever use Ip addresses for my share access.

(Noris) #14

Hi @Mario_Bucco,

Have you tried rebooting your Core, NAS and Network yet to see if there is any change? I would give this a try. Also, has connecting via IP address worked for your or does that still exhibit a similar error?

(Mario Bucco) #15

Hi Noris,
Yes I’ve rebooted everything a number of times. I’ve also used a saved backup from before the most recent Roon ROCK update but that didn’t work either. Using the IP address does work, I’ve already uploaded some music folders from the NAS and am starting to rebuild my data base in Roon. That’s the biggest pain in the butt, having to rebuild the data base.

On another note, today Roon ROCK has started randomly disconnecting & reconnecting on my Windows 10 pc. In addition it has shutdown on the pc a couple of times. ROCK is installed on an Intel NUC from the approved list, I don’t have the specific model at the moment.

The most recent contact I’ve had from Synology support is that the problem appears to be at the ROCK end since I’m able to connect everything else to the NAS using \MusicNAS\music. I looked at the link Alfred van Hoorn posted in this topic a day ago & wonder if the configuration in ROCK’s /etc/samba/smb.conf may be the issue.
Regards,
Mario

(Mohammed Samji) #16

I have the exact same problem.

I have rebooted the Core, the Synology, and clients

My synology was auto updated to 6.2.2

All my pc clients can access the SMB shares.

The Roon Rock can only access the SMB shares if I use the Ip address - \192.168.1.151\music

It used to work with the friendly name

(Mr Fix It ) #17

Sounds suspiciously like a dns issue

(Daniel Blount) #18

Same issue here, was able to make it work with the IP address, which is static, so no huge deal once I found this thread!

DSM 6.2.2-24922 Update 2

(Phil Jeremiah) #19

Same here. Room updated this morning and all NAS links dead. Unable to EDIT the NAS links, can only delete and add new. How do I EDIT the location so that I don’t have to rebuild from scratch? Mac can see all NAS locations so it’s only ROON that’s having the problem.
Just checked and I’m still on Synology DSM 6.2.1-23824 so blaming it on Synology is a red herring

(Phil Jeremiah) #20

Alternatively is there a way to go back to the previous OS that worked? The only thing new in #175 is CD ripping in ROON which I don’t need. If I could reload the previous OS I could load the library from the backup.

I’ve spent countless hours adjusting rips within ROON; all gone. (Lesson learnt; adjust in iTunes and FLAC software and then import into ROON. I honestly thought that ROON was more stable…).

(Noris) split this topic #21

A post was split to a new topic: Issues accessing ROCK (OS175) from Windows 10 Remote

(Noris) #22

Hi @Mario_Bucco,

I am discussing this issue with our technical team but I should mention that rolling back Roon versions is Not Supported at this time as it can cause compatibility issues.

To those affected by this issue (@Mario_Bucco/@Mohammed_Samji/@Phil_Jeremiah/@Daniel_Blount) can you please let me know the following:

  • What is your router model/manufacturer and how the Core and NAS are connected in the setup?

  • Is the NAS and the Core on the same switch or are both plugged directly into the router via Ethernet?

  • Are you still able to access the network share via Finder or Windows Explorer when connecting via Hostname?