Failed authorise connect to Synology NAS

I had, and just did again : unauthorised :roll_eyes:

Unauthorized normally means: The client could reach the server, but he doesn’t let him access the share because he’s not allowed to.

Any permission or preferences in the NAS I should change ?
In shared folders, file services or external access
My config is pretty much default ( just plugged the NAS and sarted using )

Hi Jean-Paul,
I’ve moved this over to Support so they can help you. There have been several problems with connecting to Synology lately as @BlackJack mentioned. Support may have more insight into how to get you going.

Thanks mate !!

Hi @Jean-Paul_GAUTIER,

Thanks for reaching out to us here. Hmm, it is strange that Roon was unable to connect to the share via IP address, have you made sure to add Roon as an exception to the Macbook firewall? I would use these instructions from Apple to double check, as well as allow Roon past any other application firewalls you may have (Bullguard/Little Snitch/McAFee have all caused similar behavior in the past).

Are you sure the MacBook is using smb to connect to the NAS? I had a similar issue, with another NAS brand. I think Macs prefer to use apfs or something like that.

  • two backslashes server\share
  • smb://server/share
    did not work for me
    Although the Mac could see the NAS, Roon could not.

Thanks for the tip
Apple firewall is set up to allow Roon
Will have to check my Intego software though ( when I reach home tonight )

1 Like

Have you checked the logs on the Synology itself? Does it report the user attempts? Perhaps that will give a clue why it thinks the login is unauthorized.

Hi @Jean-Paul_GAUTIER,

One other thing that came to mind here other than checking the firewall - if you create a new folder share on the NAS as a temporary test, does that folder also display similar behavior? It would help clarify if there is a permissions issue with just the \music share.

No logs in the Synology Log center :confused:

I did check to connect to the video folder, same behaviour

Doesn’t seem like I can create an new folder outside the Home folder
I have no admin user ( it’s disabled ). Is that an issue ?
When I do access the music folder via the finder, I do see a log that I accessed it with the user JP Gautier … so the above should not be an issue, right ?

Not sure wether it is relevant, but when I put afp://SynoJP.local/music , it returns "unexpected error "

Roon doesn’t support afp.

From FAQ: I’m having trouble setting up my NAS:

  • Use SMBv3 when possible. Failing that, SMBv2 should also be ok, but do not use smb2 with large mtu as it has known compatibility issues with Roon. If you’re using a Synology NAS and running your Roon Core on OSX, you can find some more information about fine tuning your setup here
  • Don’t enable AFP or Timemachine if possible – some users may need this functionality for other applications, but they’re not needed for Roon. You can find more information about why AFP is not supported here.

Do you have enabled the Windows File Service on your NAS?

Hi @Jean-Paul_GAUTIER,

As @BlackJack mentioned, Roon does not support connecting via AFP, so I would make sure that your NAS has SMB support enabled (for the Windows File Service). If you are not sure, can you share a screenshot of your SMB settings on the Synology?

A few other thoughts:

  • Can you verify if you have OpenVSwitch turned on in the Synology? Sometimes this can cause strange behavior.
  • This might be part of the issue. If you create an admin user, do those credentials work in Roon?

Woohoo ! Seems like the admin account was the issue !
Importing music now !
Thanks a lot gents !

You might want to think a little bit about how to handle this. Synology advises removal of “admin” username as the system administrator as it can be a backdoor for ransomeware. Creating a new user (e.g. “TheBigGuy”) with admin privileges is safer. So you would have an ‘admin account’, but the user just isn’t named ‘admin’.
You may know this, but it could be helpful for others reading this thread.

Hi

Actually I didn’t know. So I looked into it
Thing is, the account I mentioned before had admin privileges already

Only thing is, it had a space in the user name. I renamed it removing the space, and it magically worked

Conclusion : The issue all along was that space in the user name :roll_eyes:
( Well, maybe the smb3 too )

Anyway, Lesson learned :slight_smile:

Thanks all for the assistance !

2 Likes

Hi @Jean-Paul_GAUTIER,

Thanks for the update here and glad to hear that the share is working with those changes!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.