24/88 + 24/96 + 24/176 music still stutters, stalls and won't play

My high res files will not play properly. Most tracks stutter and stall. Can never get through a whole album.

Files on NAS drive all connected through 1 gig switch.

Gordon

2 Likes

I have similar issue. Music on NAS, playing through 2011 Mac mini. Stutter at random intervals, like every 5 minutes.

Hey guys – can you let me know the following and we’ll figure out what’s going on:

  • What kind of output you’re using (default system output, USB DAC, network audio zone)
  • What the specs of your machine looks like (CPU, RAM, OS)
  • What you’re seeing in Signal Path (little light next to Now Playing – interested to know if conversions are happening, such as when you’re downsampling to AirPlay, or converting DSD to PCM)
  • How your NAS is setup (brand, model, configuration in Roon)

Feel free to PM me these answers or post them here, and we’ll take a look.

Thanks!

My 16/44 music is now stuttering too - although much less than high resolution files.

Same here.

Dropouts for both 16/44 and hi-res stuff since the previous build (16).

I’m,also having this issue!
With airplay it’s the mist problematic but even with usb connecred to my dac I have dropouts.
As a test I’ve copied some high res files (Dsd and aiff 24-96) to the roon folder on my mac and then I have no problems playing the albums! I guess this problem is connected with network storrage and the way Roon handles this. No other music software that I use has any problems with playback from the network drive

mac mini mid 2010, core duo something 8gb ram. usb dac xmos based and finally synology dj 413j NAS.

The signal path seems fine… Blue dot, lossless. The files were flac 24/96

I’m not sure if this will help but I had similar problems. Mac and NAS connected to router then from router to MAC airport via ethernet then from airport ethernet out to a Meridian MS200. Roon was crashing after stuttering and then required a reboot. This only happened on files above 16/44. When connected direct to the router the problem went away.

For those running Macs for Roon Core, and using a Synology NAS, you should check the setup in the Synology DSM settings. Go to Control Panel -> File Services.

Windows File Service should be enabled.

In addition click the Advanced Settings Button in the Window File Service section and ensure you have “Max Protocol for Windows File Service” set to “Enable SMB3”

This change from the default settings of “Enable SMB1” made a large performance difference for me in playback of high resolution and DSD files.

@bplexico I have a Lacie 2big NAS and can’t find the SMB settings (if there are any, can’t find anything on the internet either).

Are there by any chance any such settings on the Mac?

Otherwise I guess I’m stuck with Tidal for now. Not even 16/44 files will play uninterrupted.

:confused:

sete - your experience is something that I believe Roon needs to address. In order to get deeper adoption a product must be simple to use. Most buyers are not technically savvy and won’t engage someone that is. If the product takes an effort to use then the customer will pass.

Roon - please create a “how to set up a NAS for dummies” tutorial. What is SMB? How does one set up SMB on a Mac? Forget the windows folks - focus on how to use with Apple hardware first. Windows people know how to do this because owning a windows computer is like owning a vintage British car - you spend more time under the hood than in the seat.

I still resent having to use windows to setup my Meridian MC200. This hindered sales for Meridian. They should have made this product as easy to setup as an Apple product.

My two cents for the day.

@sete - I found the manual for your Lacie 2big NAS online. It looks like this section details how to enable/configure SMB as well as disable AFP if need be. I cannot tell how much control the Lacie allows over SMB from what I was able to read.

@bplexico The only setting available for SMB is on or off. And even turning off AFP won’t prevent the dropouts. Thanks for the help, anyway!

@gtaylor I agree there could be some more detailed info about these advanced configurations, but I really can’t blame the Roon guys. They’ve been very responsive and attentive so far. What puzzles me is that everything was working perfectly until build 16. I’m hoping for a fix soon, because it’s been a frustrating couple of days.

Hi-Res music stutters for me too. Anything above 44/16 and DSD to PCM has dropouts in average every 30 seconds I would say, and it’s very distracting.
It happens on 44/16 too, but very very rarely.
My DAC supports up to 96/24 so even when no conversion happens I still get stutters in 96/24.
All my files are local, nothing goes over the net (except of course anything from Tidal, but no Hi-Res there).
It would happen with no relation to CPU usage or HDD activity. Well, if my CPU is close to 100% it stutters a lot more, but it also happens when it’s < 10%.

I’m running on Windows 7 64bit, using ASIO4ALL v2 as output.
My DAC is a Schiit Modi.
CPU - Intel Core 2 Duo E8400 @ 3 GHz.
RAM - 4GB,

Thanks!

UPDATE: It appears that all stuttering is gone when I switch to WASAPI. ASIO was to blame. I will stick with WASAPI for now until ASIO leaves the “beta” stage :smile:

UPDATE: It appears that all stuttering is gone when I switch to WASAPI. ASIO was to blame. I will stick with WASAPI for now until ASIO leaves the “beta” stage smile

I would start by getting ASIO4ALL out of the pipeline.

ASIO4ALL sits on top of WASAPI/KS (which are the same infrastructure under the hood) and exposes a software ASIO “driver” to Roon.

There’s nothing to be gained by talking to WASAPI via an intermediary like ASIO4ALL–more machinery and moving parts is going to potentially increase the amount of work your computer is doing and also the potential for problems like dropouts. I suspect that if you use WASAPI directly, or use an ASIO driver for your device directly, you will get better results.

I had no idea that’s what ASIO4ALL did under the hood. But now that I think about it, it makes sense.
My DAC doesn’t have its own ASIO driver as far as I know.
For what it’s worth, using ASIO4ALL with Foobar2000 never produced any stuttering for me, so there has to be something with the way Roon interacts with it.

Anyway WASAPI works perfectly smooth and it also gives better performance in terms of latency/responsiveness of Roon so I will stick with that and try to forget any audible differences I thought I had heard with ASIO :blush: