Failing to flash Roon OS image to USB stick [Resolved]

Recovery didn’t work for me. It seems I’m having an error flashing the .gmz recovery file to my usb-stick.
I’ve tried 3 different usb-sticks, at the end of every “Flash Complete” message, I get the “1 Failed target” message “Checksum does not match for range …”.
Any ideas what I’m doing wrong and how I could do this better? The first USB-Stick was actually the one I used in january setting up my Rock.

I’ve, on other occasions and with other files, gotten those messages with Etcher.

Make sure nothing else is running at the time. Perseverance will pay off.

Or you can try Rufus.


Hi @bernardb50,

Do you happen to have a different USB stick you could try?

I’ve tried on 3 different USB-sticks. I’m trying @xxx option with Rufus first!
Okay, that seemed to have worked.
I can’t try it our right away, I’ll get back in 2-3h!
In the mean time @dylan @xxx, thank’s guys for helping me out so quickly!


Glad to hear that, @bernardb50. Thanks for the suggestion here, @xxx. Let us know how it goes once you run the recovery process!

“bad blocks” says bad usb drive to me.

@dylan it didn’t work. I flashed successfully using Rufus, see above pictures. @danny “bad blocks” are 100% ok after 2 write and read passes, so no bad blocks.
But when rebooting with the usb in the front of the nuc and pressing F10 I don’t see the usb, only the internal ssd.

@dylan @danny mea culpa! After updating the bios at first install I disabled USB boot​:exploding_head::see_no_evil:!
Roon works fine again now after running the recovery!
Many thanks for your quick support


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.