Fast-forwarding Roon Radio in Android App causes infinite skipping

When I use the Roon radio feature in the Android app (latest version; Samsung Galaxy Tab S3) and then try to fast-forward within a title (mostly because I want to skip a silent part in a title) by clicking on the wave form of the title, the app does not fast-forward but instead tries to start the next title. However, this is not successful, so the next title is selected, which is also not successful. This creates an infinite loop of selecting new tracks (several per second) without actually playing one. As soon as I am in this loop, I need to restart the app to make it stop.

It seems that this can also happen in the Windows app (Windows 10).

Have you rebooted everything.
Giving details of your installation as asked for in the support form will more easily allow people to help.

I regularly reboot the systems, but the issue is replicable. However, it does not occur every time.

My current setup:

  • The core is running on a PC (Core i5) with Windows 10. It’s my work PC, but when I run Roon, all other programs are closed and the PC is not used for anything else.
  • The work PC is in my office. It is connected via LAN cable to a FRITZ!Repeater 3000, which in turn is connected via wifi mesh to a FRITZ!Box 7490 (in a storeroom next to the living room), which in turn is connected to a 16-port switch (in the living room) via LAN cable, which in turn is connected via LAN cable to the endpoint (in the living room), an Onyko TX-RZ 3100, that receives the music via Chromecast.
  • The library with 19k tracks is stored locally on an hdd in the PC that runs Roon. I am not using any streaming service.
  • I use my tablet (Samsung Galaxy S3 running Android) and my laptop (Lenovo T570 with Core i7 running Windows 10) as controls.

I will change the setup in the next days because I will move the Roon core from my work PC to a PrimeMini4 (Core i7) that will run ROCK. The PrimeMini4 will be directly attached to the switch. The library will then be moved to an external hdd that will be attached to the PrimeMini4.

Hope that helps!

Hi @Rohangis_Mohseni,

Would it be possible to record a video of what you’re seeing? Is it something that happens reliably enough that you could capture it happening?

Tomorrow, I will try my best to provoke it on one of the Windows machines (either the work PC or the laptop) so that I can record a screencast.

1 Like

I tried to provoke it, but was unsuccessful. It seems that I have to run Roon radio for a longer time to provoke the issue.

However, I upgraded my system yesterday so that Roon now runs on a Prime4Mini that is directly attached to the same switch that the endpoint it also attached to.

Should I stumple upon the issue again, I will record a video with my smartphone.

Right when I did not expect it, the issue showed up and I recorded a video.

I was listening to Leftfield’s album “Leftism”, and when the last track had a passage at the end with no music, I tried to fast-forward to the part where there would have been music again. Right after clicking on the waveform, the issue appeared.

I also noticed that in very rare cases (like once per hour), I can hear a drop-out in a track (i.e., no music for a less than a second).

Thanks, @Rohangis_Mohseni!

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

1 Like

Thanks, that’s good to hear! I tried to provoke the problem today, but as last time, it does not show up when I try it. I will just wait again, and if it shows, I will note the time so that you can compare it with the log file.

Strangely, after moving to the PrimeMini4 and ROCK, I experience frequent drop-outs, especially at the beginning of a track. It’s strange because the PrimeMini4 does not run any other programs (while the other PC did), runs ROCK (instead of Win10), and is directly connected to the same switch that the endpoint is connected to (instead of using a meshed wi-fi repeater that wirelesly connects to a router that is linked to that switch). Therefore, I would have expected fewer drop-outs, not more. To solve the issue, I changed the LAN cable, but this did not help. Also, I raised the resync of the endpoint time step by step (now to 500ms), which seems to improve the situation.

The situation will hopefully improve when I switch to endpoints that use RAAT instead of chromecast, but this will have to wait until I can afford to buy the endpoints that I want.

The issue appeared on:
(time zone: Germany, clock already set to summer time)

Also, I had around three drop-outs in the first three track (one per track) where two of the were not in the beginning of the track.

Maybe the issue is caused by a buffer underrun or something that also causes the drop-outs?


I started Roon and continued listening to a track from Sting. Then I added Tears for Fears to Roon radio, which started a new track. But I wanted to finish listening to the track from Sting, so I clicked on the back arrow, and the issue appeared again.

The endless skipping can be stopped by disabling Roon radio.


Tried to skip a track, but the next track did not start playing. The display of the receiver wrote “connecting”, but seemingly could not connect. I tried to force it to start by clicking into the waveform, which made the issue appear again.


Tried to start playing music again, but the receiver got stuck. Switched to another chromcast endpoint, started playing music from there. At first, this did not work either and the issue appeared here as well. But after some tries, the music started playing. Then started to play music on my main endpoint again, but it just did not run. It always showed “Connecting…”, but when it started showing “Chromecast” again, the music did not play. Turned the receiver off and on again, which helped.

I ordered an 2.5 inch SSD for the music library to make sure that the drop-outs are not caused by the external HDD. However, the main issue with the infinite skipping will probably not be caused by the external HDD because it already showed when I used my work PC as the core.

I now also ordered a Hifiberry for testing purposes. Hopefully, it will be delivered soon so that I can do some testing during the weekend.

I noticed that starting the playback via Chromecast on the Onkyo TX-RZ 3100 takes more than half a minute. Also, if I skip a track, I have to wait another half minute each time. But if I just let Roon radio do it’s work, the music plays seamlessly (apart from the drop-outs).


Now the Roon radio function seems to be affected, too. Tracks need half a minute to start, I hear one second of music, and the track is interrupted by half a minute again.

After turning “Aussteuerungskorrektur” in the DSP on and off again and removing an unused filter, the issue with the delayes play went away. Maybe this was caused by the move from the work PC to the PrimeMini4 because I imported the database (comparable to when you flash your bios, but do not load the default settings).

I will now closely watch what happened to the original issue with the infinite skipping because I had that issue already before moving to the PrimeMini4.

After booting up the system today, I again have the issue with playback not starting after skipping a track. This time, it did not help to change the settings of the endpoint. Skipping a track even made it impossible to start any music at all. Restarting the Roon server via the browser at least helped to make the music start again, but I still run into problems when I skip a track. Whereas yesterday, this was no problem.