Fiio M11 upsample/downsample on Roon

Core Machine (Operating system/System info/Roon build number)

Roon Core Running on a DS718+ Synology in a SSD
1.7 on 610 Build

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router TP Link Archer C8

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Fiio M11

Description Of Issue

Roon upsamples/downsample every song not matter if it’s local or streaming, MQA or not.

It may vary the sample if I play on Tidal, or just turn on.
If I play a 44.1 song and return to roon(play a 44.1 song), the upsamples doest not happen anymore.
If I play a 96 song a downsamples happen to 44.1.
If I just turn on M11 then upsamples goes to 24/192.
So Tidal can tell with sample rate to DAC and stays like that, if I play a song that has the same rate on Roon, that does happen again.

The 44.1 and sample rate it’s just an example, could be 48, 96, 192. It has the same behavior.

I think it’s Roon because on Tidal it plays bit perfect.

The M11 has a option to display the playing sample rate.

Before turned on.

!
Play from Tidal
P_20200831_211651_vHDR_Auto|374x500 !
Exit from Tidal and came back to Roon
P_20200831_211819_vHDR_Auto|374x500

Hi @joaopmts,

Thanks for reaching out! I am going to consult with the hardware team regarding your report once I have more info, I will reach out again.

1 Like

Are you on the latest FiiO M11 firmware?

Yes, latest firmware.

Please post a screenshot of Settings -> Audio, see if there are any other audio devices other than the OpenSL ES you’re using.

Nothing about this option. Just high gain, filters and etc.

Hi @joaopmts,

Thanks for your patience while I had a chance to consult with the team regarding this one.

Can you please clarify the exact steps you used to get into this state?

Are you saying that you:

  1. Started playing 44/96/192kHz content in another app
  2. Went back into Roon
  3. Tried to play 44/96/192 content in Roon and Roon outputted to the last sample rate you played in other app

Is this correct?

Does this behavior only occur when using the TIDAL native app or do other music playback apps also exhibit this issue?

I’ve also enabled diagnostics mode for this device which should automatically upload a log set to our servers next time you open the Roon app on it. Can you please open the Roon app on it when you have a chance and let me know?

@noris , I made a video trying to demonstrate better what I’ve written. See if it clears better.

I don’t have another playblack app but I can try for shure.

Link to the video:https://photos.app.goo.gl/tB4c6TvwNQXMxx3o9

The video start when the M11 fisnish turning on. For you to see the 192k upsample.

Then I switch between roon and tidal to demonstrate my example.

I open roon but dont see any log upload, I assume is a background thing.

If you need anything more I’m here to help.

Thank

1 Like

Hi @joaopmts,

Thanks for this video, it is very helpful - please leave the video up so that I can also share this with the QA team!

It looks like the first set of Roon logs from your Fiio have been delivered to our servers, which is good, but, these logs look like they are from before you took the video attempt.

If you can just open the Roon app on the Fiio again when you have a chance, that should send the newer log set to us well and I can get that over to the team for review as well.

This is standard behaviour for Android daps and Roon you won’t get bit perfect playback. It will up or downsample based on what rate Roon thinks the OS reports to it. On my Hiby R5 the DAC is capable of 384/24 and DSD128 but Roon will downsample every thing to 44.1/24. Doesn’t matter if any other apps play bit perfect Roon is stuck with standard Android Audio path.

I’m opening right now. If you need anything more just tell me.

Didn’t know about this. But if Tidal that is a cheap streaming service can do a bit perfect streaming I hope Roon can solve this to all android devices. Let’s see, it’s not a killing problem or I will not use my M11 cause of it. But it bothers me.

2 Likes

@noris I have the same behavior on my FiiO M15, happy to share logs or whatever would help maintain forward progress on this issue. Like @joaopmts I was really looking forward to using Roon on my M15 but this issue is pretty unfortunate.

2 Likes

Thanks for the additional report @tretneo, the first set of logs from @joaopmts are currently pending review by QA. I noted on the ticket that you are also seeing similar behavior on the M15, let’s see what QA says regarding the logs and once I have their report, I’ll update the thread accordingly.

2 Likes

Sounds good, thank you @noris

2 Likes

Hi @joaopmts & @tretneo,

Thanks for your patience here while I had a chance to consult with QA regarding this report.

We have attempted to reproduce this behavior on non-Fiio Android Remotes and we have not been able to do so, at this time we suspect this behavior only impacts Fiio Roon Remotes.

Our team will reach out directly to Fiio to investigate this further, thanks again for the reports!

1 Like

Thank you @noris, I know FiiO is super responsive and customer-focused so hopefully we can get this one figured out quickly. Appreciate the update!

1 Like

Thanks @noris, hope get this solved.

A little sad about it.

2 Likes

@noris just a heads up, I pinged FiiO over on Head-Fi to make sure they were aware of this issue. They responded to let me know that they were aware and have sent an M11 over to Roon for troubleshooting/testing. Please keep us posted as things develop. Thanks!

3 Likes

Finally I find the forum where this problem is being dealt with.
I have a FiiO M15 and I really bought it to enjoy Roon in several rooms in my house.
I am pretty sure you imagine how disappointed I was when I saw Roon is struggling with Android/FiiO to get the signal directly transmitted to the 2 DACs…

There must be a solution to avoir automatic upsampling/downsampling… I hope

In the FiiO, there is an Android mode, a Pure music mode. Why don’t create a Roon mode?
Please keep us posted