Firewall settings on an Ubuntu desktop with Roon Core

Roon Core Machine

Ubuntu 20.04 Desktop computer. Intel i7, 16 GB RAM, 3 TB SSD’s
Latest Roon Core server installed on this machine

Networking Gear & Setup Details

Fritzbox 7490 router and fast glassfiber internet

Connected Audio Devices

Bluesound NODE and a Bluesound Node 2i endpoints

Number of Tracks in Library

12, only using Qobuz

Description of Issue

I am stil in my trial period. The Linux desktop is my primary computer. Roon works flawless in this setting. The thing is that is only works with a disabled (UFW) firewall. I have searched for answers, but can’t find the ufw settings for roon core on Ubuntu.

I have tried:
sudo ufw allow 9003/udp
sudo ufw allow 9100:9200/tcp
sudo ufw allow 9330:9339/tcp

thanks to the 9330:9339 will roon show on my remote (android phone and/or a Apple ipad) but no audio devices are found, so that’s not enough.

Normaly the firewall is enabled for other parts of my computer (KDE Connect, connecting a smartphone to my OS needs some firefwall rules)

So the question is: what firewall rules can I use for succesfully run ROON CORE on my desktop?


1 Like

Thanks for you reply. I just don’t know how to allow multicast and broadcast communication in the (UFW) Firewall. So I decided to buy myself a second hand NUC computer with a 256 GB m2 ssd and 32 GB ram, powered by a i5 cpu. I installed Lubuntu as OS and installed the Roon Core.Server package and that works beautiful. I manage the system on local ssh, so I’m happy.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.