Format badges missing from View More

here is what I show

But, when I click the “More” tab, the format disappears.

Hello @Neil_Russell,

Make sure you’ve updated your Roon Core as well as your Roon Remotes to build 763.


I did. That did not restore the badges, but in the expanded “Recent activity” page it now shows the format below the artist name.

I have updated everything, all four iPads, my MacBook Pro and my PC (I don’t have on my android phone), logged off then on, rebooted everything, and still not a badge in sight. I do get the text below the artists name showing the format, just as your screen shots show, but not even one badge.

Check this again. Maybe it got changed somehow.

Nope, and I keep checking it with each update, reboot, etc.

Hello @Neil_Russell ,

Can you please navigate to Roon Settings → About and share a screenshot of that page to make sure you are on the latest version of Roon? If you are on the latest, can you try to restart your Roon Core and check the Album Display settings as per @Jim_F’s screenshot?

764 stable, all remotes updated, all settings I want set to “on”, and I have restarted the core numerous times, tried logging out of Roon, shutting down everything, starting back up, logging back into Roon, Nothing gets a single badge to appear. The only improvement is that on the home page and album view it now tells me the format just beneath the artist’s name.

Hi @Neil_Russell ,

In the first screenshot you have “Show TIDAL badge” as off, are these albums from TIDAL?
You’ll have to turn that on to see the badge. If this is on please share a screenshot of the current settings and more info regarding your setup:

I do not use Tidal. My entire library spans two WD PR-4100 NAS units wired to a Netgear 16 port switch, which has an ethernet cable that connects the switch to my Dell XPS-8930 Desktop which is the Core, and feeds the files to my Cocktail Audio X45PRO via USB. I also use iPads and MacBook Pro as remotes, and everything is the 764 build. Everything worked perfectly with the badges until I updated to 1.8.

Hi @Neil_Russell,

Thanks for the screenshots and for the additional details. Can you please confirm - when the format badges are missing, are these single tracks added to the Roon library? Do the format badges show up properly if you add the entire album instead of an individual track?

The badges are missing for everything in my library, whether it was added as a single track, as an EP or as a complete album.


I have the same issue as has already been reported here

Not sure why that topic is already closed.

I can see the badges (but not all) in Album view.
However when doing a search and clicking on ‘More’, the listed albums show no badges.

I have both Tidal and Qnap services, so it would be quite useful to know which album is in my library and which is on Tidal or Qobuz.

I tried to unset all badges in the settings and then re-add them, but that had no effect.

This is on iPad client with Roon server on Qnap running latest build 1.8 (814)


It was autoclosed … I’ve reopened it, merged, and tagged @support.

Thanks @Carl
I’ve now tested also with Windows client and have the same issue. Only very few badges are shown. Behavior is the same as on iPad

In Artist->Discography the badges are shown. So I suspect this is the way how it’s designed for now.

But the badges are important also during a search, so we can understand where the found albums are.
I get it, that for example “in library” badge would show up on all albums if we are in ‘Albums’ view, but in search it’s not the same as we don’t know which albums are ours and which from streaming services.

All badges selected in settings should show in any view of albums, be It the artist discography, my albums, album search, the page for a particular album…anywhere.

Also, wouldn’t it be nice for parents with young children to always see the elicit badge no matter what page the album cover is showing up on?

1 Like

could you please confirm you now understand our issue and that a fix will be implemented at some time?

Hello @StefanK & @Neil_Russell ,

Thank you for those additional details! I spoke to the QA team regarding this behavior and we have an active investigation in this area. As per policy, I cannot comment on a timeline of when this will be resolved, but it is on our radar now, thanks again for the report!

1 Like