Frequent Pauses with Recent Roon Build 988

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Apple M1 Mac Mini (base model, 8GB / 256GB) running macOS Monterey 12.4.
Running Roon 1.8 (build 988) stable.

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

2x Asus RT-AC68U (AiMesh)

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

iFi ZenStream (WiFi, S/PDIF out) - Version 2.31.7, RAAT SDK 1.1.38
ProJect S2 Ultra (Ethernet, USB out)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Around 6,500 tracks (mix of local files and Qobuz)

Description of Issue

I’m getting a lot of those when trying to access my Roon server (full Roon 1.8 build 988 on M1 Mac mini with latest macOS 12.4) from my windows laptop (full Roon 1.8, build 988 on Windows 10 x64 20H2).
Most times the “connect” button on my server is grayed out. When the button finally becomes available I can connect to my server, but shortly after the UI becomes unresponsive and a pop-up comes up saying it lost connection to the server (“Uh oh, something’s not right”).

Like @Hao_Wu noted, I, too, love Roon’s UI and features but the recent releases have made the whole experience VERY annoying. I suffered from the recent issue where my Roon server would not initialize on Mac Mini so I could not backup my library to migrate to my new M1 Mini and now this…

Another thing that annoys me is that I’m unable to find which build I’m on until I either set up a server on my PC, or connect to an existing server (which I can’t)… This makes reporting a bug very cumbersome. You should add a link to see the build number on the “Connect to a Server” page.

Hey @Clement_Le_Barbencho

I’ve split this into a fresh thread in order to allow proper attention to your issue. In order to best assist you, we’ll need to you fill out the setup template I’ve copied into your first post.

Please be as specific as possible, this information is immensely helpful for the support team :+1:

I just filled out the form.

I tried to copy/paste my latest log, but it’s too long…

Clement, I’m just a user, but have installed many AiMesh systems over the past year. A pause may be the result of an issue with your network configuration. Have you separated your 2.4 and 5 GHz bands on your routers? ASUS typically uses the 5 GHz band for wireless backhaul, but the 5 GHz band also has more available bandwidth than the 2.4 GHz band.

I run a 2-node mesh network at home, but have slightly larger-capacity routers (it still amazes me how many devices are on my network, especially when family comes home). I have separated my 3-bands (1x2.4, 2x5) into separate SSIDs so I can control what is connected to each band. This may be something to look into so you aren’t using a lower-capacity (and crowded) 2.4 GHz band for Roon, which in many cases will resemble what you are experiencing.

2 Likes

If you are using Macs you need to enable bonjour on your router. That fixed my play issues.

I just want to note that the pauses while playing are only one of 2 issues.

The main issue that’s really irritating is the fact that since 1.8 my Windows laptop keeps disconnecting from my Core running on my new M1 mac mini…
After a few minutes I get “Waiting on your core…” pop up and soon after that the “Uh oh” message.
When that happens the core is still accessible from my phone so the issue is with the Windows build.

Hi Clement

I had this issue where my ios remote device did not pause, but the MAC remote did. If your core is on a M1 MAC Mini, your router needs to have bonjour enabled. That fixed my play issues. All the best, Ron

Hey @Clement_Le_Barbencho,

I wanted to follow up on this thread since a few days have passed. If you’re still running into issues with your audio pausing, please provide a few timestamps (date, time) of when the issue occurs. That way, our technical team will be able to pinpoint what might be going on after enabling diagnostics on your account.

We’ll be waiting for your reply :pray: