Frustrating issue again - There was an issue loading your database

Roon Core Machine

Innuos Zenith MK3 SSD

Networking Gear & Setup Details

Netgear Router LAN

Connected Audio Devices


Number of Tracks in Library

about 90000

Description of Issue

After Shuting Down the Innuos and turning on 1 week later the well kown message : There was an issue loading your database
Tried to reinstall Roon, Opening new connection to core (on Innous Zenith) - imported all the music-files and when I restore my backup (100% done) it wants to relaunch and after relaunch the same problems again (Issue loading database)
It seems it’s the second time (since June 21) I lose all of my album edits and tags and playlists. And as I see here in the forum, it is not related to the Innuos, it’s related to miserable program code. We have 2021 and situation is: when I have a backup it does not help, that’s ridicolous. And obviously no way to repair the corruption. Can’t even tell how p***ed i am. So is there really now way to look into these backup files to squeeze out any information (like playlist,.) ? Really would appreciate getting help form anyone who is more skilled in software development than me.
Puh, somehow for my mental health this had to be written.
still hoping, regards Michael

1 Like

Probably not, but apparently Roon are working on the problem …

Hopefully Support will have something a bit more useful to add.

Hi @Michael_Krpec, I’m sorry to hear about the trouble here.

Corruption happening this frequently is definitely a sign that there may be some type of hardware failure occurring. We have information about why this can happen here in our Help Center. I’d definitely recommend running some tests on the SSD and RAM on the Core machine to verify that there are no signs of failure.

Unfortunately, if the backups aren’t working, it means that corruption also exists in your backups. In this case, there is no way to recover that information.

As mentioned by David above, we are working on some improvements in this area and if you’re willing to help, we’d appreciate it if you could upload your backups here. Your participation will go a long way in helping our team improve corruption detection, so we’d greatly appreciate your help. :pray:`



I was expecting it, the game thats always played : Hardware is pointing to Software as faulty and vice versa. But to explain more detailed : As I had bad experience last June (as I wrote previously), after doing all the editing work again I certainly checked the backups by setting up roon from scratch and restoring the backup and you know what : At the end of August this worked fine . And now, after turning up the Innuos after a one weeks break, roon said that due to updates the database has to be also updated and after this the problems occured. And thats exactly the same thing that happened in April, when I first lost all my data. So for me it’s clearly no hardware issue - would be too much of a coincidence that this happens twice just when some software updates were carried out. But yes, you can push off the blame to hardware immediately, but for customer satisfaction i don’t think it’s helpful, at least not for me. And when I browse through the forum I found a lot of similar issues , all got he same wishy washy answers. Funny how much buggy hardware is out in the field (NUCs, MacMinis, Innous, …) all with hardware issues - sorry but thats ridiculous. I personally have no trust in stability anymore and am thinking how to find an alternative. Thats sad, cause functionality of roon is really amazing, but i don’t have the spare time to reenter every several months my data due software issues.
I will upload my backups soon.
Regards from a disappointed user

Hey @Michael_Krpec,

It truly is saddening to see what your experience has been with Roon - reading about your specific case, I can see what a disappointing experience it must be. We are truly sorry.

Of course you can choose to give up on Roon anytime, but I would lie to say we’d like that. We’re still hoping you might continue to use Roon.

I’m sorry you find our answers to be shifting blame… it is not our intention. On the contrary, our very jobs are to make sure we reach a resolution.

In this specific case, hardware issues are likely, due to the Core (the Innuos Zen) not even meeting our minimum requirements (more on that here), let alone reach optimal performance. Issues are bound to appear.

Even so, if you’d like to upload those backups, our team would love to take a look and see in what ways we can help :pray: