Frustration with iPad

Seems to happen for no particular reason - the iPad will not load and just hangs. Previously I have blamed Roon updates but today it hung just out of the blue. The only “cure” appears to be to delete the Roon APP and reload it.

Thanks for your report, @JOHN_COULSON.

To start, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

  • Does this only happen with the iPad? If you use other remote devices you do not have this issue?
  • How often does this happen? Is there anything in particular you are doing when you’ve noticed this behavior, or any other patterns involved in this process?
  • What model iPad is being used and is it fully up to date on iOS?


Roon is installed on this ASUS Z87-PRO motherboard PC with LAN cabling to an Auralic Aries Bridge. LAN cabling connects to various DACs and amplifiers. Wireless is via RT-AC66U ASUS Router set up -

The iPad is the only remote control item used but a couple of times I have returned to this PC and found it had hung and recently it did this while listening to music in another room via Roon. The music just stopped and this PC had to be powered off and re-started.
However when the iPad froze the other day, this PC and Roon were operating as normally.

The iPad is a 12" iPad Pro and is not used for anything but Roon and the occasional net search. This PC has Windows 7 64 bit on board.

Is there any more operational info I’ve missed?



Thank you for the update, @JOHN_COULSON!

  • Can you give me some more information on the Core machine? Is it connected to the network via WiFi or Ethernet? What CPU and RAM is being used? SSD?

The iPad is the only remote control item used but a couple of times I have returned to this PC and found it had hung and recently it did this while listening to music in another room via Roon. The music just stopped and this PC had to be powered off and re-started.

  • Just to confirm, the PC was in a frozen state, it wasn’t just that Roon had stopped playing, correct?
  • Can you confirm that your iPad is on the latest version of iOS?
  • Can you confirm how often this happens? Are there any patterns you notice about when this happens? Were you actively using it when this happened, or was the iPad idle and upon reopening you saw this? Was Low Power Mode active?


Hard wired throughout except of course for the iPad.

Apologies if my earlier message was confusing. I was reporting TWO unrelated incidents:

  1. A couple of times in the past couple of weeks this PC has just frozen while Roon was playing music files.
  2. My iPad frustration was a different issue. It would see the Roon APP but would not load up the files for control and the APP needed to be reinstalled before it would. Roon on this PC was operating normally.

Yes, I have regularly updated IOS .

No pattern observed so far. The most recent freezing of this PC happened when Roon was operating. Next time it happens I’ll double check if Roon was actually operating. I sometimes leave music files playing without actually listening always so cannot be certain if earlier freezes occurred because of Roon or not. In general terms this PC is stable and I have no issues with programs.

I do not use low power mode.


Thanks for the update, @JOHN_COULSON.

Just so we are on the same page, the PC freezing has happened multiple times, and the iPad app only happened once, correct?

So I can get some greater insight into your setup, may I ask you to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Just to get some more information on the PC issue:

  • Does the PC completely freeze during playback? Is it just Roon that freezes, or is it not responsive at all and needs to be rebooted?
  • Are there any other applications in use when this happens?
  • Does this happen when playing all media types? Only certain media? TIDAL and local?
  • Does this happen when playing to a specific zone, or does this happen for all of them?

Next time it happens, may I ask that note the time of the occurrence? I can enable diagnostics on your account and the team can review the diagnostics report in relation to the timestamp you note.


  • Yes, the PC freezes completely, CNTRL/ALT/DEL achieves nix so this PC has to be powered off, rebooted for Windows 7 and Roon
  • No, it has never happened on this PC when using other applications. Roon is always operating and most times is accessing the music database to play album
  • It has not happened when access internet radio, but that is not done very frequently so that is really no help. I do not access Tidal or anything else with Roon - 99% of the time it plays albums from a 6TB HDD
  • No, I have experienced the “hang” problem with the iPad several times - this is the third time in the last 3 months I’ve had to reinstall the Roon APP
  • I only have one zone setup and it happens with that.

Network configuration:
This PC -> RT-AC66U ASUS Router -> 24 port switcher -> LAN cabling to Aurilac Aries Bridge -> Mostly balanced digital line with Canare cabling -> DACs -> amps -> Speakers or headphones. Wireless connection is from the Router - see earlier for its configuration.
I have changed the router from 2.4 Ghz (when the crashes occurred) to 5Ghz now and have had no further problems since my first post. The iPad is in the next room to the router and wireless connection around the house is good. This wireless connection is currently only used for Roon and the iPad although visitors use it with no problems (it is an open system which is of no concern as the nearest house is 300m away).
Yes, I will note the time is next happens if I’m aware of that event happening and let you know.

All very frustrating and annoying when I settle down to listen to music or internet radio and find the iPad will not communicate but if I come back to this PC, Roon operates fine. Note I have never had problems communicating with Roon on this PC while it is operating but, as mentioned before, have come back to this PC to find it has hung, although that is an infrequent occurrence and has not happened for some time now. I have Malwarebytes Premium protecting the PC from net nasties and have virus protection up to date, all MS updates in place so do not suspect any problem from malware etc. Similarly I update the iPad as soon as notified.
Maybe the change from 2.4Ghz to 5Ghz will solve the issue?? Apart from this I have no more clues to offer.

Thanks for your contact about this - most appreciated. Obviously Roon is not perfect and probably never will be but it is a much nicer (and simpler) system than the Sooloos I migrated from.

Thanks for the details, @JOHN_COULSON, and sorry for the frustrations you’ve experienced.

This is definitely a good idea - let me know if you continue to see improvements here. We recommend using 5Ghz whenever possible for best performance.

When this happens if you manually close the app and then re-open it, is it still hanging? Is it just a frozen screen or does it say “connecting to Core”?

Thanks! Just send me the timestamp and I’ll enable diagnostics for the technical team.


Here we go again :frowning: iPad connected OK yesterday but come to it this morning - “Lost Connection”. It will just not connect .

  • Roon operating normally on the PC (Core)
  • Roon playing on devices if controlled by this PC
  • Roon configured to accept remote connections
  • The iPad connects to the net OK so one presumes there is no wireless problem
  • The only way of restoring iPad control was top remove the APP and re-install it

CONCLUSION: The Roon APP is at fault

And another exact repeat of the post above - “Lost Connection” BUT the iPad connects to the net, all is fine on this PC, …

I guess I’ll have to delete and re-install the Roon APP once again :frowning:


I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Can you provide the a timestamp for about when this happened? I’ll be passing the report along with this timestamp to the tech team for analysis.

Kind regards,

It happened around 10.10 Australian Eastern Standard time.

Note that I have not used the iPad since then and still have not deleted and replaced the APP so the iPad is still not communicating with the core, The music that was playing earlier in the day had been controlled by the iPad and the system was playing music at 10.10 yesterday and it was when I tried to stop play that the communication between the iPad and core (this PC) ceased. Roon was subsequently controlled from this PC.

I now have Roon set up for remote control on a Thinkpad notebook (hardwired on the network and not set up for wireless yet) and just fired it it to see if Roon loaded - it did. But the iPad is still not communicating, even with it situated here in the office 2 feet away from the router.

20 minutes after posting the above I have deleted the APP and reinstalled it and Roon is again controllable on the iPad.


Thanks for the details here. The diagnostics report for the Core has been uploaded to our servers, but I haven’t noticed any for the iPad remote. Next time you connect it to the Core it should upload it automatically, I’ll keep an eye open for that.

Just to confirm — The core is connected directly into the router and not the switch, correct? It looks that way based on your earlier response, but just wanted to make sure.

If you’re able to, it would be a great data point for the team to know if the Thinkpad connects just fine over WiFi as well. If it has issues over WiFi there may be networking troubles to look into, but if it still works fine then we know the issue is isolated to the iPad remote.


Yes. Core (this PC) -> Router -> switcher -> Auralic bridge -> digital outs

The ThinkPad is a relatively new (but used) acquisition and I have just finally got it connected to the network by wireless so will check it out next time the iPad loses connection and let you know. BTW the iPad was also purchased used but I cannot see any reason why it should dropout from Roon while it still connects to the net.


It would definitely be good to know whether all WiFi devices experience this issue when it happens or if only the iPad is affected. When you do this test, please note the time as well so we can review this instance in the diagnostics report as well.

Kind regards,

After 3pm this afternoon and Roon would open up completely on the ThinkPad but only partially on the iPad - the graphics was all missing as you can see from the pics below. Perhaps there is a graphics problem with the iPad? But that makes no sense as other graphics open up without difficulty.

And BTW the iPad was 100% charged. And apart from the graphics display, Roon controlled albums as normal via the iPad.

Thanks for the update, @JOHN_COULSON.

Glad to know that it seems to be working okay for the most part now. Has the album art issue always been this way, or did this just start?

Do you have any firewalls active on your Core machine? If so does disabling them and restarting the Remote app yield improvements?


John, have you tried a hard reset on the iPad Pro? I don’t remember exactly how it’s done, but it’s something like hold down the down volume button then hold down the power button and slide to off. Wait several seconds, then power up again. Check with Apple for the exact way to do it. This has cured several weird problems with Apple products for me. Good Luck!

A hard reset is a factory reset which erases user data, I think you mean the soft reset as below

Soft reset with hardware keys
Reset the iPad by holding the sleep/wake button at the top right of the device and the home button at the bottom center of the face at the same time.
Hold them both until you see the screen go black.
Wait until the white Apple logo appears.
When this happens, you can let go.

Thanks guys, yes, that did it. All back to normal album display again. I’ll try that next time it has trouble communicating with the core.


1 Like