Fully Rendered MQA Audio (and DSD Audio) Not Available Through USB-C Port of 2018 iPad Pro

@support I am experiencing the identical phenomenon with my 2018 iPad Pro 12.9” and a new Dragonfly Red on iOS 12.1.1. I have tried both of Apple’s official adapters (USB-C Digital AV Adapter and USB-C to USB Adapter) as well as several adapters from Anker and iFi. However, they all yield the identical crackling MQA sound and rapidly cycling indicator color between magenta and purple. It seems as if the Dragonfly is trying to lock onto an MQA signal but cannot as the signal is badly distorted and/or rapidly cycles on and off.

This identical behavior has also been reported recently in a couple of forums on Head-Fi, and needs to be reported to Roon support if it hasn’t already.

A KEY OBSERVATION that I and others have made is that the 2018 iPad Pro endpoint shows up as HEADPHONES in the Roon Signal Path, whereas the iPhone is listed as a USB OUTPUT or USB DEVICE in the Roon Signal Path.

I don’t know if the issue lies with a faulty implementation of USB-C Audio and/or USB Host Mode on Apple’s end, or if the fault lies on Roon’s end. All I know is that this issue needs to be addressed as soon as possible by Roon.

For myself, I reluctantly purchased an additional 2017 iPad Pro 10.5” with lightning connector to replace the 2018 iPad Pro as my iOS Roon endpoint.

I have noticed the new USBC iPad’s show any DAC connected as a headphone rather then a USB device. DSD (plays but lots of white noise) and MQA playback is impossible. The 3 new iPhones, still with lightning connectors continue to work fine with the CCK and show up as usb devices.

There is a known issue on the USB-C iPads. Any connected DAC shows as a connected headphone rather than a USB Device. (see roon forum for photos). This means playback is being limited. Also DSD and MQA fails. DSD plays, but with severe white noise in the background.

I found out the hard way after trying just about every app in the playstore, and finally tried roon, and when that didn’t even work I gave up.

If the iPhone goes USB C next year it could have the same effect. Will apple ever fix it? Who Knows…

I love this posting. Basically it goes like this. I bought something that I did not know if it was supported. Now I find it is not. So fix it quickly because I asked nicely. Or else I will drop my Roon subscription because this functionality is important to me. How can Roon release a program not knowing if everything that comes out in the future is supported? :joy:


Excuse me. I in no way meant for my post to sound flippant or unappreciative. I am NOT going to cancel my Roon subscription. As I stated, I am not sure which platform is causing the issue.

Roon has an iPad app that is supposed to allow for a fully functioning iOS endpoint, so I believe they want to know about this issue — especially since more and more of their iOS users will have devices with a USB-C port in the future, as Apple does away with their lightning connector.

Moreover, if the issue lies at the feet of Apple and the iOS implementation of their USB-C port, I hope that Roon would have enough “clout” to convince Apple that it is worth their while to address this issue.

Edward, my guess is that you have about the same clout with Apple as does Roon.




Just checking to see if someone from Roon has reviewed this issue yet. Thanks very much.

Hello @Edward_Gerber,

We are currently investigating this issue with an iPad Pro we have in-house. I will be sure to update you when we have determined the root cause of this issue.


Thank you so much, John. I really appreciate the feedback!


Just checking in. Any progress on this issue yet? Thanks!

Hello @Edward_Gerber,

We do not have anything to share at this point in time. We are able to reproduce this behavior with our hardware which should help us narrow down the cause of this issue. I’ll be sure to chime in when the Dev team has made a determination.


Thanks again John. I’ll wait to hear from you. I had a feeling this one might take some time :ok_hand:


Just a quick update: The MQA issue still remains exactly the same after (1) updating all Roon software [Core, iOS Remote endpoints] to version 1.6 AND updating all iDevices [2018 iPad Pro 12.9, 2018 iPhone XS Max, 2017 iPad Pro 10.5] to Apple iOS version 12.1.3.

I was really hoping this issue would be rectified by the Apple iOS update given that Apple included the following in the release note:

– Fixes an issue that may cause audio distortion when using external audio input devices on iPad Pro (2018)

But that has done nothing to fix the problem. The 2018 iPad Pro (USB-C device) still shows up as “HEADPHONES”, rather than “USB OUTPUT”, in the Roon Signal Path, and the MQA audio output to my DAC remains badly distorted. And, once again, the MQA output from both the iPhone XS Max and iPad Pro 10.5 (both Lightning devices) is perfect.

Thanks again for your continued work on this issue! -Edward

Just upgraded to Lifetime Membership to support the entire Roon team — and put my money where my mouth is. Thanks Roon team!

1 Like

Same issue, happy to purchase if it ever gets fixed so will keep an eye on this thread…

1 Like


Another quick note — DSD continues to be unlistenable as well on the 2018 iPad Pro. What plays is a continuous stream of white noise, with a very faint musical signal in the background. This is the exact phenomenon described by other users earlier in this topic thread.

Please advise further when you have new information or a fix for this MQA/DSD issue.

Thanks again,


Just checking in. Any update on this issue? Thanks.

MQA does not work on nugs.net and DSD has the same white noise issue on about 10 DSD apps I’ve tried (that all work fine on iPhone).

So I guess until Apple fix it, roon and others are powerless…

The new 2018 iPad… what a bad bendy purchase that was :frowning:


Play DSD over PCM through ipad pro 2018 (USB type-c interface) will provide large noise with fading music on the background. No problem if I replace the ipad pro with any other iphone and older iPad.

You have no need to replicate my whole system. Just try to connect any USB DAC to ipad pro 2018 USB type-c interface, probably the problem can be replicated.

My setup is

[Music library+Roon Core@synology NAS ds918] —(wifi)->
[Roon Bridge@ipad pro] --(usb-c) ->
[USB TYPE C hub with power delivery (with mechanical timer on at night for charging)] —(usb-a) -->
[Audio-gd NFB-11] -->