Galaxy S7 Edge - Roon errors

@support I get lots of error messages ‘stopped responding’ reported by the phone itself (SM-G935F - S7 Edge)).t

Also as describend in one of the other posts Roon often loses its connection to the core. It can only be restored by restarting the phone. This stops me from commiting to it fully.
The phone is up to date (Android 7.0 - kernel version 3.18.14-12365438). I guess this is for you @support to investigate.

Hi @wobare ---- Thank you for the feedback, the insight is appreciated!

Moving forward, to help aide in our evaluation of this behavior you are reporting, may I very kindly ask you to please provide the following information:

  • A brief but accurate description of your current setup using this link as a guide.

  • Please describe your network configuration/topology, being sure to provide insight into any networking hardware you are currently implementing. I want to have a clear understanding as to how your devices are communicating and all the “tools” being utilized that make those connections possible.

  • Since noticing this behavior have you…

    • Tried rebooting any relevant networking hardware (router, switch(es), etc)?

    • Reinstalling the application on the mentioned remote devices?

  • Additionally, what is the experience like when the following tests are performed:

TEST #1:

  1. Shut down your Core
  2. Open Roon on your Remote
    (Tip: If you are using a phone, make sure you keep it awake)
  3. Roon should be on the “Searching For Core” screen
  4. Start up the Core

TEST #2:

  1. Start up your Core
  2. Open Roon on your Remote
    (Tip: If you are using a phone, make sure you keep it awake)
  3. Kill the Roon app
    (Tip: If you are using Android please go to Settings > Apps > Roon > Force Stop)
  4. Restart Roon on on your Remote

Test #3

  1. Go into “settings” and select “Battery”.
  2. In the right hand corner of the screen please select “battery optimization” from the “3 dot menu”.
  3. You should see a header at the top of the window saying “not optimized” with a little drop down next to it. Click the dropdown and choose “All apps”.
  4. Once the “All apps” window is open navigate to and select “Roon”.
  5. Once Roon has been selected please choose “Don’t optimize”.
  6. With this adjustment in place please verify what the experience is like with the Roon remote app.